Ajax ModalPopupExtender not displaying controls in Safari browser.

Hello Everyone,
Can you help me on this?
In Safari my panel which I am displaying in ModalPopupExtender goes behind the modal popup ;

this works properly in other browsers.
Can you suggest me what can be cause for this?


Thanks.
LVL 1
winjittechnologiesAsked:
Who is Participating?
 
MaxOvrdrv2Connect With a Mentor Commented:
ah HA! here's something that sounds more like your problem:

If you have a bunch of AutoComplete extenders that are wrapped inside of ModalPopup and you try to run it in Safari, chances are, you will not like what you see. The autocomplete div will be shown under the modalpopup. Works fine in Firefox and IE, but Safari is screwed up. What gives?

Well, if you look into source code of AutoComplete extender, you will notice that they have a special handling for Safari (also known as a one-button mouse of the browsers  Just kidding!). Because of this special handling, the correct z-index is not being set on the autocomplete div.

But how can I fix it? Well, all you need to do is to add a div somewhere near the extender with id of AutoCompleteDiv and in your extender set the property of CompletionListElementID to AutoCompleteDiv.

Here is how I found this info:

http://logbook.trioro.com/2006/12/ajaxnet-autocompleteextender.html 
http://tim.mackey.ie/ProblemsWithTheAJAXAutoCompleteExtenderArrgh.aspx 

Also, there is a custom autocomplete extender based on prototype and script.ac.ulous. I have not tried but it looks really interesting. I would like to take a look the source when I have a bit more time. Here is the link.
0
 
MaxOvrdrv2Commented:
0
 
winjittechnologiesAuthor Commented:
Thanks MaxOvrdrv2,

but this link is not so useful for my case as my issue seems to be related with z-index as I can see my
 controls but those controls are going behind the modal popup.
can you help me how can I get this fixed?

Thanks for your help.
0
 
MaxOvrdrv2Commented:
i can't seem to find anything about it... the only problems i see are that they simply don't render, or all the controls become un-usuable...

have you tried setting it's CSS to position:abosulte ?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.