Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 780
  • Last Modified:

Windows Integrated Authentication will not work.

Windows Server 2003 IIS 6 supports integrated authentication. Theoretically it should pass the authenticated username and password to IIS when anonymous access is turned off and windows integrated authentication and basic authentication are enabled. The server is an Active Directory server with computername "computername". The domain name is subdomin.domain.com. When I browse to https://domain.subdomain.com I continue to get prompted for the username and passsword.Well,,,the password is all I have to enter to get in successfully but it won't save it. The user name I don't have to change in any way and I do not recieve any logon errors in eventvwr. The application is a sql web app and when I add the site to the trusted sites list I no longer get prompted for credentials...however, I get the messaage "do you want to display secure and non secure items"? Of course I say yes and I only get half the page...that is I get the banner for the app but not the log in  console portion of the app. Where te login portion of app should be is an error messge saying the web site could not be displayed go to the home page subdomain.domain.com and try to find it.

If anyone has experience with this type of issue I would appreciate the feedback.

Oh ya, Browser is version 6.0

Thanks.
0
smartsystemsinc
Asked:
smartsystemsinc
  • 2
2 Solutions
 
wolfcamelCommented:
check also the folder security for the home folder for the site.
0
 
drgonzo1967Commented:
Hey smartsystemsinc,
This seems more like an IE settings issue.  First off add the site to 'Trusted Sites'.  Then click 'Custom Level' button on in the 'Security Level for this Zone' box.  Scroll to the bottom and click the radio button under Logon that states 'Automatically logon with current username and password'.  That should let you pass through.  Hope this helps!

-gonzo
0
 
smartsystemsincAuthor Commented:
Thanks for responding.

I have checked permissions and given users full control on the folder with no change in symptoms.

I have also done as drgonzo1967 suggested (seemed logical to me). No joy, the pass username and password box is already checked for trusted zone.

If I connect with https....I am authenticated. If I connect with http I am not authenticated and I do not see the entire page (login missing).

Shouldn't  I get same behavior no matter the the url? I have tried localhost...loopback (127.0.0.1), netbios name of server..dns name...everything.

Each time I get  a little diffferent result since the realm  in IIS is set to subdomain.domain.com so anything but subdomain.domain.com as a connect url will not authenticate correctly no matter what I type in username /password field. And where I connect with the correct subdomain.domain.com I just put the password in and I am through, but it will not automatically authenticate.

This is a TSS box...Don't know if that matters or not.

Hmmm...still stumped.
0
 
smartsystemsincAuthor Commented:
Thank you for your inputs. Your inputs help me narrow down the appropriate behavior for the broswer in this implemmentation. The actula problem was with Web Extensions. Since authentication was enabled, the configured web extensions could nto work.
0

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now