Solved

Microsoft SMS 2003, Setting up and deploying packages (basic help)

Posted on 2009-05-13
12
1,467 Views
Last Modified: 2013-11-21
I've come into an environment where they have an SMS 2003 installation, but it seems to have never been implemented 100% (there are a few packages that seem to be for testing).

I am new to SMS, and need a bit of guidance, here is what I have done:


-Obtained a 7zip MSI.
-Placed MSI on a network share (permissiosn are domain admin access only)

1. Create Collection
-Created a new collection in SMS named 7zip.
-Clicked the "Query Rule Properties" button (yellow), on the "Membership Rules" tab for the collection.
-Named the Query Rule "7zip" and chose "User Group Resource" for the Resource Class.
-Clicked "Edit Query Statement" and switched to the Criteria tab.
-Clicked the yellow star button to open the Criterion Properties general tab.
--Criterion Type: Simple value
--Where: User Group Resource - User Group Name
---Attribute Class: User Group Resource
---Alias as: <No Alias>
---Attribute: User Group Name
--Operator: is equal to
--Value: 7zip

2. Created Group
-Created a new security group in AD named 7zip.
-Added my user account "jdoe" to the security group.

3. Created "Package From Definition"
-Right clicked Pagage, went to "New>Package From Definition"
-Browsed to and selected the 7zip MSI file, "Igor Pavlov" showed as publisher, "7-Zip 4.65" showed as name under "Package definition".
-Source File> Chose "This package does nto contain any files" (THIS MAY BE WRONG..?)

4. Created Advertisment
Name: 7zip
Package: Igor Pavlov &-Zip 4.65.......
Program: Per-user attended
Collection: 7zip

When I log into a computer as the user "jdoe" I would expect either 7zip installation to launch automatically, or for it to appear in "Add-Remove Programs" under "Add New Programs".

What am I missing here? Do I need to configure group policy to use SMS or something?

Thanks.

0
Comment
Question by:bradl3y
  • 7
  • 3
  • 2
12 Comments
 
LVL 8

Accepted Solution

by:
U_Mansson earned 250 total points
ID: 24375748
Hi

First you need to include the files in your package. Right click on your package - properties - data source and change the setting.
Then you have to distribute your packages to a distribution point.

If you want the application to install  automatically set it to mandatory in your advertisement.

Hope that helps,

regards

Ulf M.
0
 
LVL 6

Author Comment

by:bradl3y
ID: 24376305
Once set up properly, the advertisment should show in "Add Remove Programs", under the "Add New Program" section right? Where currently it says "No programs are available on the network"?

Ok, I've added the distribution point (the SMS server itself, the only one listed).

I chose to include the source file directory, and pointed it to the directory with the MSI file.

I changed my collection to include a resource by netbios name, entered the name of the PC, it listed the PC and i checked the box to include the PC in the collection.

I changed the advertisement to use the "per-system attended" program rather than the "per-user attended". These were both already existing programs (created by default?).

The command for "per-system attended" is :

msiexec.exe ALLUSERS=2 /m MSI5JDA0 /i "7z465.msi"



I have tried rebooting again, tried a gpupdate /force (not sure if this is neccisary), and am still getting "No programs are available on the network"

Any ideas? Do i need to configure the domain client in any way to look for these advertisments? Do i need to install the SMS client on the client PC?

Thanks.
0
 
LVL 22

Expert Comment

by:Adam Leinss
ID: 24376414
I believe "Add New Program" is based off of GPOs, not SCCM.
To run SCCM based programs, you would use the "Run Advertised Program" applet in the Control Panel.
The adveristment would also need to set to "Allow users to run program independently of assignments" to show up in RAP.
0
 
LVL 6

Author Comment

by:bradl3y
ID: 24377127
I do not have a "Run Advertised Program" at all in Control Panel. I am running SMS 2003, not SCCM, not sure if it would be the same.

Is the SMS Advanced Client required for SMS deployment?
0
 
LVL 6

Author Comment

by:bradl3y
ID: 24377332
I've installed the SMS Advanced client by running the client.msi located on SMS server CIFS share for the site. I now have a "Run Advertised Programs" icon in control panel, however, when i launch it there are no programs listed.

I noticed this server was not previously enabled as a Management point, so i enabled this role on the SMS server. Still no programs in "Run Advertised Programs".
0
 
LVL 22

Expert Comment

by:Adam Leinss
ID: 24377765
Is the client even registered to your MP?  Check C:\windows\system32\ccm\logs\ClientIDManager.log.
I would suggest picking up a book on SMS from Amazon.  The MS Press books are pretty good. SMS is not just something you can wing by trial and error.  Well, you can I guess...until the VP's laptop reboots while he's working on a document :)
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 6

Author Comment

by:bradl3y
ID: 24378520
The LocationServices.log file shows what you are referring to (I think):

Current AD site of machine is: (my site name)
Retreived local Management Point from AD: (SMS server name)

For both local management point and proxy MP.

I have found the following error in the execmgr.log: <![LOG[Software Distribution Site Settings for the client are missing from WMI.]LOG]!>

I have checked that it is set as "Use this site system as a distribution point" in Site Settings>Site Systems

I found a "ClientIDMAnagerStartup.log" file, but do not see any references to registering with the MP.

I will be doing some reading, but i'd like to do a little hands on approach to see how things work first. I'm not too worried about disruption, they don't current use SMS and i am only testing with a very specific collection containing my test accounts/test computers.
0
 
LVL 22

Assisted Solution

by:Adam Leinss
Adam Leinss earned 250 total points
ID: 24378818

You should see something like this:
RegTask: Client is not registered. Sending registration request... ClientIDManagerStartup 5/13/2009 8:02:47 AM 1848 (0x0738)
RegTask: Client registration is pending. ClientIDManagerStartup 5/13/2009 8:02:48 AM 1848 (0x0738)
RegTask: Client is pending registration. Sending confirmation request... ClientIDManagerStartup 5/13/2009 8:02:48 AM 1848 (0x0738)
RegTask: Client is pending registration. Sending confirmation request... ClientIDManagerStartup 5/13/2009 8:03:48 AM 1848 (0x0738)
RegTask: Client is registered. ClientIDManagerStartup 5/13/2009 8:03:48 AM 1848 (0x0738)

And in the SMS console, the client should show "Client Installed = Yes"
0
 
LVL 6

Author Comment

by:bradl3y
ID: 24379168
I see no lines like that in any of the log files (tried searching for "RegTask", "Client is not registered")..

I did find when running the MP Troubleshooter there were errors on two things:

Verify Default Website Is Running ( Solution: Cannot create ActiveX component. )

If the MP is W2k3: Verify that Background Intelligent Transfer Service is enabled. ( Solution: Cannot create ActiveX component. )



Thanks for your help thus far.
0
 
LVL 8

Expert Comment

by:U_Mansson
ID: 24379368
Have you enabled the Advertised Programs Client Agent. You find it under Site management - site code - site settings - client agents?

After you enabled it, update the machine policy on your client.
0
 
LVL 6

Author Comment

by:bradl3y
ID: 24424303
Yes i did try that.

I think there was quite a bit wrong with the install. For one the previous IT person set this machine up as a domain controller. I removed the DC role from the machine, removed SMS, IIS, and SQL, and started from scratch. Things are now working somewhat as I expected, I have successfully deployed a package to a test client. I am still running into some problems here and there, but I am going to award points for this one as the two of you have been helpful in troubleshooting.
0
 
LVL 6

Author Closing Comment

by:bradl3y
ID: 31583118
I will be posting a few separate related questions after this, each with a specific error/prolem i am running in to, so please keep an eye out for those if you are interested.

Thanks.
0

Featured Post

Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The environment that this is running in is SCCM 2007 R2 running on a Windows 2008 R2 server. The PXE Distribution point is running on its own Windows 2008 R2 box. This is what Event viewer showed after trying to start the WDS service:  An erro…
On a regular basis I get questions about slow RDP performance, RDP connection problems, strange errors and even BSOD, remote computers freezing or restarting after initiation of a remote session. In a lot of this cases the quick solutions made b…
Migrating to Microsoft Office 365 is becoming increasingly popular for organizations both large and small. If you have made the leap to Microsoft’s cloud platform, you know that you will need to create a corporate email signature for your Office 365…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now