Solved

External email not being recieved

Posted on 2009-05-13
30
481 Views
Last Modified: 2013-11-30
I ahve users not getting ut hexternal email. I have tracked messages and can see they are leaving, how do I see what is coming in?
0
Comment
Question by:shawkins331
  • 14
  • 7
  • 6
  • +1
30 Comments
 
LVL 10

Accepted Solution

by:
Korbus earned 100 total points
ID: 24378224
The first test I would suggest to to connect to your external IP address using telnet on port 25, from offsite.
If you fail to connect, either SMTP is off (not if you send mail though), it is a network problem.  Posibly due to a firewall, or ISP issue.
There is no inbound queue to view in exchange.

0
 

Author Comment

by:shawkins331
ID: 24378244
how do you test dmx records?
0
 
LVL 10

Expert Comment

by:Korbus
ID: 24378255
this link will help with HOW to do that SMTP test I suggested.

http://exchange.mvps.org/smtp_frames.htm
0
Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 

Author Comment

by:shawkins331
ID: 24378282
CheckDNS.NET is testing wykous.com


CheckDNS.NET is asking root servers about authoritative NS for domain
  Got DNS list for 'wykous.com' from L.GTLD-SERVERS.NET
  Found NS record: ns5.wykous.com[66.132.144.222], was resolved to IP address by L.GTLD-SERVERS.NET  
  Found NS record: ns6.wykous.com[66.132.144.223], was resolved to IP address by L.GTLD-SERVERS.NET  
  Domain has 2 DNS server(s)  

CheckDNS.NET is verifying if NS are alive
  DNS server ns5.wykous.com[66.132.144.222] is alive and authoritative for domain wykous.com  
  DNS server ns6.wykous.com[66.132.144.223] is alive and authoritative for domain wykous.com  
  2 server(s) are alive  

CheckDNS.NET checks if all NS have the same version
  All 2 your servers have the same zone version 1229441570  

CheckDNS.NET verifies www servers
  Checking HTTP server www.wykous.com [66.132.212.68]  
  HTTP server www.wykous.com[66.132.212.68] answers on port 80  
  Received: HTTP/1.1 301 Moved Permanently (Server: Apache/2.2.3 (Red Hat)) Location: http://www.wykotiretechnology.com/ 
  Your main page redirects to another location. Several search engines will be unable to index your site.  

CheckDNS.NET tests mail-servers
  Domain wykous.com has only one mail-server  
  Checking mail server (PRI=5) mail.wykous.com [72.159.70.30]  
  Mail server mail.wykous.com[72.159.70.30] answers on port 25  
  <<< 220 wykoinceng.com Microsoft ESMTP MAIL Service, Version: 6.0.3790.3959 ready at Wed, 13 May 2009 14:50:34 -0400  
  >>> HELO www.checkdns.net 
  <<< 250 wykoinceng.com Hello [195.60.98.253]
  >>> MAIL FROM: <dnscheck@uniplace.com>
  <<< 250 2.1.0 dnscheck@uniplace.com....Sender OK
  >>> RCPT TO: <postmaster@wykous.com>
  <<< 550 5.1.1 User unknown
  >>> RCPT TO: <root@wykous.com>
  <<< 550 5.1.1 User unknown
  >>> RCPT TO: <info@wykous.com>
  <<< 550 5.1.1 User unknown
  >>> RCPT TO: <webmaster@wykous.com>
  <<< 550 5.1.1 User unknown
  Probably mail server does not accept mail for wykous.com (received status 550)  
  Some of your MX do not work properly  
0
 
LVL 24

Assisted Solution

by:Rajith Enchiparambil
Rajith Enchiparambil earned 300 total points
ID: 24378328
This test is trying a couple of generic users and failing.

Create a test account in AD with mailbox and run the last test in the Microsoft test site.
See what it flags and post the error here.

https://www.testexchangeconnectivity.com/

Rajith.
0
 
LVL 3

Assisted Solution

by:johnpitt
johnpitt earned 100 total points
ID: 24378339
>>> HELO www.checkdns.net
  <<< 250 wykoinceng.com Hello [195.60.98.253]
  >>> MAIL FROM: <dnscheck@uniplace.com>
  <<< 250 2.1.0 dnscheck@uniplace.com....Sender OK
  >>> RCPT TO: <postmaster@wykous.com>
  <<< 550 5.1.1 User unknown
  >>> RCPT TO: <root@wykous.com>
  <<< 550 5.1.1 User unknown
  >>> RCPT TO: <info@wykous.com>
  <<< 550 5.1.1 User unknown
  >>> RCPT TO: <webmaster@wykous.com>
  <<< 550 5.1.1 User unknown
  Probably mail server does not accept mail for wykous.com



Do you actually have any of those e-mail addresses in your org?
Do you have any scanning or Antivirus running on exchange?
0
 

Author Comment

by:shawkins331
ID: 24378363
Attempting to retrieve DNS MX records for domain wykous.com
 Successfully retrieved one or more MX records from DNS
Additional Details
 MX Records Host mail.wykous.com, Preference 5

Testing Mail Exchanger mail.wykous.com.
 This Mail Exchanger was tested successfully.
Test Steps
 Attempting to Resolve the host name mail.wykous.com in DNS.
 Host successfully Resolved
Additional Details
 IP(s) returned: 72.159.70.30

Testing TCP Port 25 on host mail.wykous.com to ensure it is listening/open.
 The port was opened successfully.
Additional Details
 Banner Received: 220 wykoinceng.com Microsoft ESMTP MAIL Service, Version: 6.0.3790.3959 ready at Wed, 13 May 2009 15:00:05 -0400

Attempting to send test email message to shawkins@wykous.com using MX mail.wykous.com.
 The test message was delivered successfully.

Testing the MX mail.wykous.com for open relay by trying to relay to user Admin@TestExchangeConnectivity.com
 Open Relay test passed. This mx is not an open relay
Additional Details
 The open relay test message delivery failed (a good thing).
The exception detail is:
Exception Details:
Message: Mailbox unavailable. The server response was: 5.7.1 Unable to relay for Admin@TestExchangeConnectivity.com
Type: System.Net.Mail.SmtpFailedRecipientException
Stack Trace:
at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, SmtpFailedRecipientException& exception)
at System.Net.Mail.SmtpClient.Send(MailMessage message)
at Microsoft.Exchange.Tools.ExRca.Tests.SmtpOpenRelayTest.PerformTestReally()
0
 
LVL 3

Expert Comment

by:johnpitt
ID: 24378393
Looks like that worked. Did Shawkins get the message in their inbox?
0
 

Author Comment

by:shawkins331
ID: 24378409
yes. I have several users complaining of the same problem
0
 
LVL 24

Assisted Solution

by:Rajith Enchiparambil
Rajith Enchiparambil earned 300 total points
ID: 24378446
""yes. I have several users complaining of the same problem""

Which problem? Did you get the test email?
0
 

Author Comment

by:shawkins331
ID: 24378467
Yes I got the test email, I can send and recieve from both of my external mails (aol, yahoo) but i have users saying they are not recieving emails from external users. I emailed a test message to one of the people they had been trying to reach. He had gotten the email but when he responded to it I get nothing.
0
 
LVL 3

Expert Comment

by:johnpitt
ID: 24378482
Did that user you sent the message to get a bounce message?
Those are great troubleshooting tidbits.
0
 

Author Comment

by:shawkins331
ID: 24378489
no he did not.
0
 
LVL 3

Expert Comment

by:johnpitt
ID: 24378505
You never said if you have any antivirus scanners installed on exchange. Or Spam filters.
0
 
LVL 24

Assisted Solution

by:Rajith Enchiparambil
Rajith Enchiparambil earned 300 total points
ID: 24378539
What if you try to reply to an external email using OWA?

Exchange version?
Outlook MAPI?
0
 

Author Comment

by:shawkins331
ID: 24378560
symantec information foundation mail security for exchange
Background scanning is active
Auto=protect is active
scan message bodies
on virus updates, force rescan
virus message scann during SMTP transport are all active
0
 

Author Comment

by:shawkins331
ID: 24378583
exchange 2003
0
 
LVL 24

Expert Comment

by:Rajith Enchiparambil
ID: 24378591
Delete the symantec stuff, restart the server and see what happens.

Most of the time, AV scans exchange folders (even if excluded) and mess with email flow.
0
 

Author Comment

by:shawkins331
ID: 24378602
ok we dont need symantec information foundation mail security for exchange?
0
 
LVL 3

Expert Comment

by:johnpitt
ID: 24378605
I would check the windows application event log first. There may be some info in there to lead you in the right direction.
0
 
LVL 24

Expert Comment

by:Rajith Enchiparambil
ID: 24378694
Atleaset disable all third party softwares, stop their services, restart all exchange services and see what happens
0
 

Author Comment

by:shawkins331
ID: 24378703
i am not sure what to stop. Sry new at exchange administration
0
 

Author Comment

by:shawkins331
ID: 24378885
any more ideas?
0
 

Author Comment

by:shawkins331
ID: 24378982
application log show the following warning:
warning brightmail warning 9720.7128:8010 problem encountered during folder creation. Could not open root folder for mailbox: /0=domain/0u=first administrative group/cn=configuration/cn=connections/cn=smtp servername /cn=19255e10-2651-4447-9e6e-4850b61ac944
0
 
LVL 10

Expert Comment

by:Korbus
ID: 24381582
so your anti-spam seems to be having a problem, I'm not very familiar with brightmail.  It may be sucking up all your incomming email.  Can you check to see what messages it has marked?  Can you disable it?
Might want to contact thier tech support.
0
 
LVL 3

Expert Comment

by:johnpitt
ID: 24385626
What is the event ID of that error?
0
 

Author Comment

by:shawkins331
ID: 24386684
513
0
 
LVL 3

Expert Comment

by:johnpitt
ID: 24386826
It is a problem with the SpamFolderAgent of Brightmail.
Have you bounced that box lately?
0
 

Author Comment

by:shawkins331
ID: 24387019
rebooted last night
0
 
LVL 24

Expert Comment

by:Rajith Enchiparambil
ID: 24394334
You need to disable your AV, spam filter to see which one is playing up. Most of the time AV scans exchange files and create troubles with email flow.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Utilizing an array to gracefully append to a list of EmailAddresses
Find out what you should include to make the best professional email signature for your organization.
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…

713 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question