Solved

After logon explorer.exe doesn't appear to load - no startbar or icons on desktop

Posted on 2009-05-13
20
639 Views
Last Modified: 2012-06-27
Hi, I've a number of laptops on a small network.  Most of the laptops have intermittent logon troubles.  I turn on the laptop, press ctrl-alt-del and enter the username and password (logging onto the domain, offline) and then it appears to be loading showing the Loading Personal Settings windows and then the background (no icons though), and there it stays.... no start bar, no access to the task manager when I press ctrl-alt-del nothing - all i can do is hold in the power button.

Can anyone suggest anything as this problem has been affecting the laptops on my office network for years and I've run out of ideas!

thanks in advance


vasp
0
Comment
Question by:vasp
  • 7
  • 5
  • 2
  • +3
20 Comments
 
LVL 2

Expert Comment

by:xnatex21
ID: 24379247
Hi vasp,
Have you tried disabling everything on start up (start > run > msconfig > start up tab > disable all) and if that doesnt help, trying to disable all of the non-windows services?

If it's a start up program then its possible that there is a compatibility issue with Windows and software you run.

If not, then you might want to try disabling other Windows services. Here is a link that will link you to a list of ones you can disable. http://forums.majorgeeks.com/showthread.php?t=25835

As always, try at your own risk.

Good Luck,
Nate
0
 
LVL 3

Expert Comment

by:Waynepre
ID: 24379251
Hey when you logon can (i know the system seems like it freezing) can you press al, ctrl, delete and click on Task Manger?

If so click New Task
Type Explorer
Press Enter

What happens?

If you can access your profiles that are stored on the machine delete them and try and log on again while you are connected to the network.

Hope this helps

Cheers
Wayne
0
 
LVL 3

Expert Comment

by:Waynepre
ID: 24379265
Opps sorry i just read the Question over again and you have said you can't access the Task Manager..,
Can you log on to the laptop with a local administrator account? also have you tried Safe Mode?
0
 

Author Comment

by:vasp
ID: 24379299
this is an intermittent problem.  i've just tried logging onto my work laptop 3 times now (at home) and no joy. but yesterday it logged on just fine.  i should say that when connected to the office network it never happens... it's only when offline... it's almost like it 'get's lost' during startup

vasp
0
 
LVL 3

Expert Comment

by:Waynepre
ID: 24379341
Ah, I think the best cause of action to take is to log onto your laptop using the local Administrator account and delete your profile. once deleted logon using your logging on details and your profile will automatically download from the server.

You must be logged onto your network for this to work.

Hope this helps.

Wayne


0
 
LVL 2

Expert Comment

by:xnatex21
ID: 24379376
vasp,
Have you tried running
chkdsk
or
sfc /scannow
from the windows recovery consol???
0
 

Author Comment

by:vasp
ID: 24379510
don't use roaming profiles
0
 
LVL 3

Expert Comment

by:Waynepre
ID: 24379529
Can you log on using Local Administrator at home?
0
 

Author Comment

by:vasp
ID: 24379734
sure..
0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 
LVL 3

Expert Comment

by:Waynepre
ID: 24379752
Does the local Administrator profile work?
0
 

Author Comment

by:vasp
ID: 24379761
local accounts are unaffected
0
 
LVL 10

Expert Comment

by:frostburn
ID: 24379762
Hi there,

Do the laptops have any mapped drives configured? If so the laptop might be trying to establish a connection with them before finishing the startup process. In that case remove the mapped drives and see if the login times are better.

Also it could be that at login the laptop is searching for a valid domain controller to verify the login credentials before using the cached credentials and continuing the login process.

Hope this helps

-FB
0
 

Author Comment

by:vasp
ID: 24379956
i thought of that... but since it accepts the user name and password and proceeds to partial load windows it can't be...  if it were looking for a domain controller then it'd pause at the logon window.

0
 
LVL 19

Expert Comment

by:PeteJThomas
ID: 24383468
We had exactly the same problem a while ago, and we still get it occasionally. It seems random, but is network related somehow I'm certain of it.

For us, the problems seem to have disappeared for the most part, but I tried all sorts at the time, removed from the domain, readded etc, and nothing got rid of it. In our case, if you left it long enough (in that 'frozen' state) it would eventually continue on.

I tried suggestions from the net on problems you can experience with Gigabit NICs and services starting too quickly/slowly and all sorts.

The ONLY possibility I can logically come up with as to why the problem has mostly gone, is that as we update Windows on all our clients quite regularly (through WSUS), and that some of these updates have sorted it in one form or another...

Not that that's much help, but I'll watch this one with interest, as I spent a fair few days solidly looking at this, and absolutely nothing tried got rid of it. It's hard to test too, as half the way they logged on fine anyway, and it was only a select few machines (though new ones cropped up here and there)...

Anyway, good luck! :)

Pete
0
 
LVL 47

Accepted Solution

by:
Donald Stewart earned 500 total points
ID: 24386229
Try saving the below as fixshell.bat and running on problem machine.

regsvr32 comcat.dll /s

regsvr32 CSSEQCHK.DLL /s

regsvr32 shdoc401.dll /s

regsvr32 shdoc401.dll /i /s

regsvr32 asctrls.ocx /s

regsvr32 oleaut32.dll /s

regsvr32 shdocvw.dll /I /s

regsvr32 shdocvw.dll /s

regsvr32 browseui.dll /s

regsvr32 browsewm.dll /s

regsvr32 browseui.dll /I /s

regsvr32 msrating.dll /s

regsvr32 mlang.dll /s

regsvr32 hlink.dll /s

rem regsvr32 mshtml.dll /s

regsvr32 mshtmled.dll /s

regsvr32 urlmon.dll /s

regsvr32 plugin.ocx /s

regsvr32 sendmail.dll /s

rem regsvr32 comctl32.dll /i /s

rem regsvr32 inetcpl.cpl /i /s

rem regsvr32 mshtml.dll /i /s

regsvr32 scrobj.dll /s

regsvr32 mmefxe.ocx /s

rem regsvr32 proctexe.ocx mshta.exe /register /s

regsvr32 corpol.dll /s

regsvr32 jscript.dll /s

regsvr32 msxml.dll /s

regsvr32 imgutil.dll /s

regsvr32 thumbvw.dll /s

regsvr32 cryptext.dll /s

regsvr32 rsabase.dll /s

rem regsvr32 triedit.dll /s

rem regsvr32 dhtmled.ocx /s

regsvr32 inseng.dll /s

regsvr32 iesetup.dll /i /s

rem regsvr32 hmmapi.dll /s

regsvr32 cryptdlg.dll /s

regsvr32 actxprxy.dll /s

regsvr32 dispex.dll /s

regsvr32 occache.dll /s

regsvr32 occache.dll /i /s

regsvr32 iepeers.dll /s

rem regsvr32 wininet.dll /i /s

regsvr32 urlmon.dll /i /s

rem regsvr32 digest.dll /i /s

regsvr32 cdfview.dll /s

regsvr32 webcheck.dll /s

regsvr32 mobsync.dll /s

regsvr32 pngfilt.dll /s

regsvr32 licmgr10.dll /s

regsvr32 icmfilter.dll /s

regsvr32 hhctrl.ocx /s

regsvr32 inetcfg.dll /s

rem regsvr32 trialoc.dll /s

regsvr32 tdc.ocx /s

regsvr32 MSR2C.DLL /s

regsvr32 msident.dll /s

regsvr32 msieftp.dll /s

regsvr32 xmsconf.ocx /s

regsvr32 ils.dll /s

regsvr32 msoeacct.dll /s

rem regsvr32 wab32.dll /s

rem regsvr32 wabimp.dll /s

rem regsvr32 wabfind.dll /s

rem regsvr32 oemiglib.dll /s

rem regsvr32 directdb.dll /s

regsvr32 inetcomm.dll /s

rem regsvr32 msoe.dll /s

rem regsvr32 oeimport.dll /s

regsvr32 msdxm.ocx /s

regsvr32 dxmasf.dll /s

rem regsvr32 laprxy.dll /s

regsvr32 l3codecx.ax /s

regsvr32 acelpdec.ax /s

regsvr32 mpg4ds32.ax /s

regsvr32 voxmsdec.ax /s

regsvr32 danim.dll /s

regsvr32 Daxctle.ocx /s

regsvr32 lmrt.dll /s

regsvr32 datime.dll /s

regsvr32 dxtrans.dll /s

regsvr32 dxtmsft.dll /s

rem regsvr32 vgx.dll /s

regsvr32 WEBPOST.DLL /s

regsvr32 WPWIZDLL.DLL /s

regsvr32 POSTWPP.DLL /s

regsvr32 CRSWPP.DLL /s

regsvr32 FTPWPP.DLL /s

regsvr32 FPWPP.DLL /s

rem regsvr32 FLUPL.OCX /s

regsvr32 wshom.ocx /s

regsvr32 wshext.dll /s

regsvr32 vbscript.dll /s

regsvr32 scrrun.dll mstinit.exe /setup /s

regsvr32 msnsspc.dll /SspcCreateSspiReg /s

regsvr32 msapsspc.dll /SspcCreateSspiReg /s

regsvr32 licdll.dll /s

regsvr32 regwizc.dll /s

regsvr32 softpub.dll /s

regsvr32 IEDKCS32.DLL /s

regsvr32 MSTIME.DLL /s

regsvr32 WINTRUST.DLL /s

regsvr32 INITPKI.DLL /s

regsvr32 DSSENH.DLL /s

regsvr32 RSAENH.DLL /s

regsvr32 CRYPTDLG.DLL /s

regsvr32 Gpkcsp.dll /s

regsvr32 Sccbase.dll /s

regsvr32 Slbcsp.dll /s

exit

Open in new window

0
 
LVL 19

Expert Comment

by:PeteJThomas
ID: 24387357
If that works you'll be my hero too! :)
0
 

Author Comment

by:vasp
ID: 24388041
Pete - I'm pleased (!) that I'm not the only one with the problem, only in our case, it never does carry on - even if left overnight.

thanks for everyone's suggestions btw...

xnatex21 - I'm going to look at the list of services soon.

dstewartjr - before I run that batch file I'm going to have to look into what all those dlls are for (just to be safe)

lastly, something occurred to me earlier today.  my laptop is a brand new (latitude E5500) and I hadn't got around to specifying the DNS server addresses and the gateway address under the TCP/IP settings on the LAN connection (Network Connections), and it wasn't having the logon problem.  I set those yesterday and that night at home the laptop froze (as described above) 3 times before I gave up with it...

could that be the source of the problem??? or am I spouting garbage!?

vasp
0
 
LVL 47

Expert Comment

by:Donald Stewart
ID: 24388083
Those are DLL's your system already has, It is just re-registering them.
0
 

Author Comment

by:vasp
ID: 25112049
I still have the same problem.  Can't find a solution.  Only thing really left to try is a different laptop manufacturer.
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
windows 10 install 6 93
Application Not Found 3 91
Installing Windows XP from USB 10 91
How Do I Set Up XP Mode in Windows 7? 8 63
Are you unable to synchronize your OST (Offline Storage Table) file with Microsoft Exchange Server? Is your OST file exceeding 2 GB size limit? In Microsoft Outlook 2002 and earlier versions, there is a 2 GB size limit for the OST file. If the file …
Issue: Unstable cursor in Windows XP and Windows runs extremely slow in that any click will bring up the Hour glass (sometimes for several seconds before giving you what you want) . Troubleshooting Process and the FINAL FIX: This issue see…
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now