Solved

Disable "Customize Links" In IE Permanently.

Posted on 2009-05-13
22
707 Views
Last Modified: 2012-05-06
Hello,

Is there a way to permanently disable the "Customize Links" button that appears in the toolbar of IE? Everytime I refresh GP it comes right back so I am assuming there is a way to remove this permanently from the domain side of things.

Please let me know!

Thanks,
Ryan
0
Comment
Question by:Ryan Rood
  • 12
  • 8
  • 2
22 Comments
 
LVL 50

Expert Comment

by:jcimarron
ID: 24379858
0
 
LVL 1

Author Comment

by:Ryan Rood
ID: 24381307
Hi,

I saw the one link before ... the other one does not apply. I have deleted that key already but everytime I refresh the link comes right back.

Very frustrating.
0
 
LVL 19

Expert Comment

by:PeteJThomas
ID: 24383339
Hmmm, the only policy setting I can find that MAY work is:

User Config > Admin Templates > Windows Components > Internet Explorer > Toolbars > Disable Customising browser toolbars.

Problem is, this stops them from changing which toolbars are displayed, but I see no way of defining which are displayed to begin with??

:/
0
 
LVL 19

Expert Comment

by:PeteJThomas
ID: 24383402
From another perspective, you could 'bodge' this yourself... You can download a toolset called NUTS, which contains a tool call "RegToAdm". (http://3d2f.com/programs/35-903-nuts-download.shtml)

(I've used this before with success). What you can do with this tool, is take a specific registry setting (i.e. modify the registry so that the button disappears, then export that key to a .reg file) and turn it into a customised Admin Template for group policy.

Then using the GPMC as normal, you can create a policy where you enable this setting you just created, and it will forcibly add that reg key to any computers its linked to.

Obviously this would need thorough testing before any kind of implementation in a live environment... :) It's at least an option to try...

Pete
0
 
LVL 1

Author Comment

by:Ryan Rood
ID: 24437604
I have tried a couple of different options including having a reversing registry key that would delete this ... unfortunately it still seems that when the GP is refreshed this little icon comes right back.

Extremely frustrating!
0
 
LVL 19

Expert Comment

by:PeteJThomas
ID: 24473441
Well, I'd be interested to look at 1 more thing - The Links toolbar just displays 'shortcuts' to the links contained within the links folder, which is in your favourites folder. If you actually delete the 'customise links' shortcut from the folder itself (i.e. deleting the actual file itself through the file system), then see if it comes back.

Bare in mind that it may also be worth deleting that same file not only from your profile, but from the 'default user' profile (hidden folder in Docs & Settings) as well...

Then just see if it comes back?
0
 
LVL 1

Author Comment

by:Ryan Rood
ID: 24473470
I have done this ... not sure about the default profile ... i will check that. Default should only apply to new user creation though?
0
 
LVL 19

Expert Comment

by:PeteJThomas
ID: 24473500
Agreed, but it's getting put back from somewhere... You could try searching the entire machine for any references to 'Customize Links' to ensure that you delete all instances of it. It can;t hurt to be as thorough as possible!!
0
 
LVL 1

Author Comment

by:Ryan Rood
ID: 24473520
I will give that a try ... its just very tedious because I need to remove this from 60+ computers ... hoping for an automated solution ...
0
 
LVL 19

Expert Comment

by:PeteJThomas
ID: 24473593
Of course, but we don't even know how to achieve it in the first place yet. Most of the time if you can figure out how to do it manually, you can then figure out how to automate the process in turn... :)

Also, have you tried actually moving this user object outside of your policy structure completely? Or create a test user or something, just ensure that absolutely NO policies are applying to the object whatsoever, and see if the problem is still occuring once manually deleted. I find the idea that a policy is doing this when there are no policy options TO do this a little more than strange...

Pete
0
 
LVL 19

Expert Comment

by:PeteJThomas
ID: 24473668
Hmmm just found something else (I'm currently viewing local group policy as don't have access to the domain group policy right now -

Under User Config > Windows Settings > IE Maintenance > URLs > Favorites and Links, I see what's in the screenshot below.

Not sure how I missed this before as it seems an obvious place to start - Maybe the 'Delete Existing...' tick box can be ticked and tested?

Pete

Links.JPG
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
LVL 1

Author Comment

by:Ryan Rood
ID: 24473681
Can't do that, user favorites would be deleted then ... which would cause an uproar.
0
 
LVL 19

Expert Comment

by:PeteJThomas
ID: 24473700
Well you only need to be using a test account when you try it, I would never suggest doing this in a live environment for the first time!!!

It does seem to imply that, but would it not be interesting just to see if it does actually remove the default 'links'?

And what about that extra option to 'Only delete favorites created by the administrator' or something??

It's worth at least playing with to see if it can work for you.
0
 
LVL 19

Accepted Solution

by:
PeteJThomas earned 500 total points
ID: 24473782
Well that's odd - I just tried this on my machine (took a copy of all my favourites of course!!) by setting those 2 tick boxes in the local policy.

Unexpectedly, the only change it's made, is to remove the 'customize links' link within the links folder. The other default links are still there, along with all my favourites... So, though not what I thought would happen from those 2 settings, isn't that exactly what you wanted?

Pete
0
 
LVL 1

Author Comment

by:Ryan Rood
ID: 24473804
try doing a gpupdate/force now ... to see if it pushes it back through?
0
 
LVL 19

Expert Comment

by:PeteJThomas
ID: 24473832
It was a gpupdate /force that removed it after I'd altered the settings... However I've run another /force and it's still not there... I added a couple new URLs (again through local GP) to the 'Links' folder, ran another /force - the ones I added have appeared, but 'Customize Links' is still not there...

0
 
LVL 19

Expert Comment

by:PeteJThomas
ID: 24473858
I would definitely attempt this with a test account! Create a new domain user, logon to some random currently unused machine. Copy some favourites into their favourites folder.

Now create a NEW gpo ("Test" or something), and change JUST those 2 tick boxes within that policy setting, nothing else. Ensure the policy has applied to the user object properly, and see what the result is... (log off/on just in case, restart the machine etc).

Pete
0
 
LVL 19

Expert Comment

by:PeteJThomas
ID: 24473875
Sorry, you probably already figured this out, but as I didn't say it - This would also mean creating a new Test OU as well, to contain the user object and to link the policy to in the first place!!
0
 
LVL 1

Author Comment

by:Ryan Rood
ID: 24473907
ok ./.. i will test this tonight when i have some time to play around.

thanks!
0
 
LVL 19

Expert Comment

by:PeteJThomas
ID: 24473946
No worries, will be interesting to see what the result is! If you need more time to carry out further testing, please remove the pending deletion request or this will end up vanishing!
0
 
LVL 1

Author Comment

by:Ryan Rood
ID: 24473961
pending solution
0
 
LVL 50

Expert Comment

by:jcimarron
ID: 24475707
coppsbuildall--Had you seen these two references?
http://www.microsoft.com/windows/about/customizelinks.mspx
http://support.microsoft.com/kb/305604
They both talk about enabling "Customiize Links", but the info could be used to disable it.
Also, you have mentioned that Customize Links appears in the TOOLBAR (not Taskbar).  
It still is in the Links folder on my PC, but it does not appear in the Toolbar.  This is because I Unlock the Toolbars and move "Customize Links" down to the bottom of the Links menu.  Then I move the Word "Links" over as far to the right as needed to eliminate "Customize Links" from the Toolbar--hidden in the dropdown Links menu--allowing only the Links I want to show on the Toolbar.  Then I Lock the Toolbars.
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
This tutorial will give a an overview on how to deploy remote agents in Backup Exec 2012 to new servers. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as connecting to a remote Back…
This tutorial will walk an individual through locating and launching the BEUtility application and how to execute it on the appropriate database. Log onto the server running the Backup Exec database. In a larger environment, this would generally be …

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now