[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

windows mail

Posted on 2009-05-13
7
Medium Priority
?
1,016 Views
Last Modified: 2012-06-27
When I open a link in windows mail I get this error "blockedhttp://........    
this file does not have a program asociated with it for performing this action. Create an association in the Set Associations control panel.
0
Comment
Question by:bobbogler
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
7 Comments
 
LVL 38

Accepted Solution

by:
BillDL earned 600 total points
ID: 24405644
Hello bobbogler

I do not have Windows Vista and, being honest, my exposure to it is limited, but there are some basic principles that are common.  It sounds like for some reason the "URL" protocols (we can loosely refer to these as "File Types") are not associated with the program you expect them to be associated with, or with no programs at all.

I am assuming here that you expect the following to happen when you click a hyperlink in a Windows Mail Message:
1. An "http" link - Internet Explorer launches, or if already launched, takes you to the page linked to.
2. An email address link (ie. a mailto:" link) - opens a new "compose message" window in Windows Mail ready for composing
3. An "ftp" link - could do anything from trying to download what it is linked to, or open the folder on the FP erver.

Before we get into the nitty gritty, could you please do a couple of experiments to see if we can establish if the problem exists outside Windows Mail.

Close Windows Mail and Internet Explorer.

Right-Click on your Desktop and choose New > Shortcut.
In the field for the command or path to file, enter a valid web page address such as http://www.experts-exchange.com
Continue, and name it whatever you want.
Once the new shortcut is created, it should display the same icon as the list in your Internet Explorer Favorites.
Double-Click on the new link.

The expected behaviour is to open Internet Explorer and take you to this site's home page.  Let us know what happens.

Now do the same again, except this time in the command/path field of the shortcut you are creating, enter a real (eg. your own) or bogus (eg. someone@anywhere.com) email address BUT ADD    mailto:   right in front of the email address with no spaces like this:   mailto:bill@bogus.com

The shortcut should change to a recognisable icon for (presumably) Windows Mail when finished.

When double-clicked, this type of "mailto:" protocol shortcut should open the default mail program with a new message to compose and the recipient's email address already inserted into the "To:" field.

Tell us what happens.

One thing that is important is whether, when you click a link in the Windows mail message, you see the familiar Internet Explorer type "Information Bar" at the top which would have to be clicked on to "unblock" the action.  It sounds like this is not the case though, because the error message being shown to you tells you to "Create an association in the Set Associations control panel".  

In previous versions of Windows, File Associations can be viewed, created, modified, etc by opening Folder Options and viewing the "File Types" tab.  In addition, in Windows XP there is the "Set Program Access and Defaults" shortcut in the Start Menu somewhere and also as an extra icon in the "Add/Remove Programs" window.  It sounds like Vista has simplified this to some extent with the "Set Associations" item in your Control Panel.

Start off by opening Internet Explorer, click the down arrow against "Tools", and click "Internet Options".  Open the "Programs" tab.  make sure these are set to your default programs which should be available from the drop-down list.  Click "Apply" to set any changes made, close and reopen Internet Explorer.

Also what I suggest you do is open Windows Mail and open the Tools > Options menu.  If you see "This application is NOT the default Mail handler"  and the "Make Default" button, then Windows Mail is not set as your default email program.  You should click the "Make Default" button.  Go back and double check again in Internet Options under the "Programs" tab.

If it still isn't working, then find the "Set Associations" referred to.  I have found some images that should guide you there seeing as I don't have Vista available for screenshots.

Get to your Control Panel and look for Programs > Default Programs, and open that.  This should be what it looks like:

http://i.msdn.microsoft.com/Cc144154.DefaultProgramsMain(en-us,VS.85).png

First of all I suggest opening the "Set your default programs":
http://i.msdn.microsoft.com/Cc144154.SetYourDefaultPrograms(en-us,VS.85).png
and ensuring that the programs you want to use for the standard functions are all set as the default ones.  Click the "Save" button to apply the changes.

Go back when done and open the "Set Program Associations" window.  This will provide you with a list of file types and "protocols".  The following screenshot shows it with the "URL" protocols showing:

http://i.msdn.microsoft.com/Cc144154.SetAssociationsForAProgram(en-us,VS.85).png

Set it the same as shown in the screenshot, ie. Internet Explorer for all the "URL:" protocols, and click the "Save" button to apply the changes.

Close the open configuration Windows and try again.  I would probably reboot before trying again, but it's probably not necessary.

I hope this helps, but just ask if you get stuck or are unsure.  It's easy to mess up file associations, but it seems like Vista has made it easier to fix them again.

Bill
0
 
LVL 38

Expert Comment

by:BillDL
ID: 24405647
I hope the Program Associations allow you to click the links in my comment and see the *.png image files ;-)
0
 
LVL 37

Assisted Solution

by:Joanne M. Orzech
Joanne M. Orzech earned 150 total points
ID: 24416231
I seem to recall that I had this problem as well.  And I think it was due to a corrupt registry key.  Believe it or not, I went into Internet Explorer and reset the IE Web Settings.

That fixed it for me.

0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Windows 10 Creator Update has just been released and I have it working very well on my laptop. Read below for issues, fixes and ideas.
In this modest contribution, I want to share with the IT community (especially system administrators, IT Support Engineers and IT Help Desks) about Windows crashes/hangs and how to deal with these particular problems.
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question