Microsoft DPM 2007 Client Installation Problems

I have a Windows 2003 Storage Server SP2.  Using the DPM Agent Install feature I successfully installed DPM agent on 3 of my 4 servers.  The problem server will not let me install DPM 2007 using this utility.  The server runs 2k3 sp2 and it's primary role is a BDC and houses various public folders.

When I attempt to install the agent onto the computer I get the following message:  The user administrator does not have administrator access to the following items; <servername> (ID:271)
Remove the computers from the "Select Computers" page or provide credentials for an account that has administrator access to all of the selected computers.

I have verified that all of the prerequisetes are installed and configured properly.

Also, I tried to install the agent manually on the server following this link exactly
http://technet.microsoft.com/en-us/library/bb870935.aspx

When attaching the agent from the DPM server I received the following error message:

There is failure while attaching production server
c:\Program Files\Microsoft DPM\DPM\bin\Attach-ProductionServer.ps1 : When trying to retrieve information from the Windows Management Instumentation <WMI> service on <servername>, access was denied.

I verified that the WMI services were started.

{{{Firewall is disabled}}}
LVL 1
Calebs_DadAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Noam_KuilboerCommented:
Are you a local administrator on that server ?
0
Calebs_DadAuthor Commented:
I am using the Domain Administrator account...
0
Calebs_DadAuthor Commented:
Perhaps I misunderstood the question.

The server that I am trying to install the agent on is a domain controller.  Therefore the local security manager is moved to Active Directory.

The DPM is just a member server.
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

Calebs_DadAuthor Commented:
Has anyone got any ideas on this problem?
0
Calebs_DadAuthor Commented:
Ok here is what I did to resolve my problem:
Note: Corpserver2 was the problem server.
           Corpserver5Nas1 is the DPM 2007 Server
Below is a detailed description of the error:
- Ran the following command on CORPSERVER2
  SetDpmServer -dpmservername PROPSERVER5NAS1
- On the DPM Server, ran the following command from DPM Shell
 
  PS C:\Program Files\Microsoft DPM\DPM\bin> .\Attach-ProductionServer.ps1
  DPMServer:: corpserver5nas1
  PSName:: corpserver2
  UserName:: administrator
  Password:: ********
  Domain:: corp.hitchcocks
  There is failure while attaching production server
  C:\Program Files\Microsoft DPM\DPM\bin\Attach-ProductionServer.ps1 :
  When trying to retrieve information from the Windows Management Instrumentation
  (WMI) service on corpserver2, access was denied.
  At line:1 char:29+ .\Attach-ProductionServer.ps1 <<<< 
  Verify that you have access to the WMI service on corpserver2.
- From DPM Server, ran WBEMTEST.
  Clicked on Connect and typed in \\corpserver2\root\default
  When clicked on connect, got the following error:
 
  --------------------------------------------
   Error                          
  -------------------------------------------
   Number: 0x80070005            
   Facility: Win32                
   Description: Access is denied  
                                 
   Dismiss       More Information  
  -------------------------------------------
 
- Running WBEMTEST from CORPSERVER2 pointing to CORPSERVER5NAS1 gives the same access denied error above.
Resolution:

- Went to DCOMCNFG on CORPSERVER2
  Expanded Component Services -> Computers and right click My Computer and select Properties
  Under Default Properties, "Enable Distributed COM on this computer" wasn't checked.
  Checked and rebooted the server.
- This fixed the problem we were having protecting CORPSERVER2.
Isn't it funny that some of the biggest problems are resolved by putting a check in a box?
Hope this helps anyone having this similar problem!!!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Aaron_DentonCommented:
I've been getting a similar error 270 but the wbemtest tool works fine both ways between DPM server and Server 2008 DC...
 
0
Calebs_DadAuthor Commented:
I think this kb article nails your problem.  let me know if i can help you further.
http://support.microsoft.com/kb/970090
0
Aaron_DentonCommented:
I finally got some assistence from Microsoft and the solution was quite simple.  There's a glitch in the way the agent works on a DC so you have to add the DPM Server object to your Domain Admins group to allow the DPM server to correctly communicate with the production server.  Once we added that the agent started working fine.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.