Solved

Bandwidth settings Cisco Routers and Speed Related Problems

Posted on 2009-05-13
12
4,740 Views
Last Modified: 2013-12-14
HI Team, I sems like i bogged in bandwidth settings on Cisco router 837. I have ADSL2+connectionand, and have configured Cisco 837 which is working ok and conencting fine but have slow speed. I think this only support ADSL1, and carrier says taht speed is correct for adsl1 but i think there might be issues with bandwidth settings as i see all diferent settings every where. i.e on ATM Interface , ATM0.1 Interface, Dialer Interface. Below is what i have configured as bandwitdh
Interface atm0.1 is the actual interface configured with ADSL credentials.
--------------------------------------------
Dialer1 is up, line protocol is up (spoofing)
  Hardware is Unknown
  Description: Internet Link Fixed IP
  Internet address is a.a.a.a
  MTU 1400 bytes, BW 56 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 1 seconds on reset
  Interface is bound to Vi2
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 15:39:15
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 81
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 42 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     110180 packets input, 40725000 bytes
     117189 packets output, 13618612 bytes
Bound to:
Virtual-Access2 is up, line protocol is up
  Hardware is Virtual Access interface
  MTU 1400 bytes, BW 100000 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
--------------------------------------------------------------

ROUTER#sh int atm0
ATM0 is up, line protocol is up
  Hardware is PQUICC_SAR (with Alcatel ADSL Module)
  MTU 1500 bytes, sub MTU 1500, BW 800 Kbit/sec, DLY 80 usec,
     reliability 255/255, txload 3/255, rxload 36/255
-------------------------------------------------------------------
ROUTER#sh int atm0.1
ATM0.1 is up, line protocol is up
  Hardware is PQUICC_SAR (with Alcatel ADSL Module)
  Description: Link to PowerTel Internet Connection
  MTU 1500 bytes, BW 800 Kbit/sec, DLY 80 usec,
     reliability 255/255, txload 5/255, rxload 71/255
--------------------------------------------------------------------------

Can you please assist, Thanks,
0
Comment
Question by:tariqmansoor
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
12 Comments
 
LVL 1

Expert Comment

by:equarando
ID: 24381968
The bandwidth statement on both atm0 and atm0.1 is hard coded at 800kbps. What bandwidth tier should you be getting with your DSL that your paying for? I would go into the interface and just up the bandwidth statement and see if your speeds increase.

Best of luck
-Eric
0
 
LVL 8

Expert Comment

by:ludo_friend
ID: 24381986
hi
cisco 837 does not support adsl2/adsl2+
you can see your connection speed by typing
show dsl interface atm 0
look for the "speed (kbps)" section
i.e.
                 Interleave             Fast    Interleave              Fast
Speed (kbps):             0             1536             0               512
the first number is download, the second is upload.

you can set your dialer "bandwidth" by using the bandwidth command. but isn't so much setting the interface speed, its used in route calculation in dynamic routing protocols.
i.e.  (for 1536/512)
int dialer 1
bandwidth 512
bandwidth receive 1536

you can also set upload speeds via the ubr command in the pvc section of the atm subif. - but this is for upload only and won't be of any use to you.

0
 

Author Comment

by:tariqmansoor
ID: 24381997
Thanks  Eric for response.

i also had alook around and Cisco 837 does not suuport ADSL2+ router, but deos support ADSL1.

Do you mean i go to Dialer1 Interface and increase the bandwidth by bandwitdh command ?
by doing that would i get getting best of ADSL1  ?

Thanks,


0
Flexible connectivity for any environment

The KE6900 series can extend and deploy computers with high definition displays across multiple stations in a variety of applications that suit any environment. Expand computer use to stations across multiple rooms with dynamic access.

 

Author Comment

by:tariqmansoor
ID: 24382001
Sorry i did not see your complete response , i will do that and will advise

Thanks Eric, :)
0
 
LVL 8

Expert Comment

by:ludo_friend
ID: 24382026
the bandwidth and bandwidth receive commands won't actually increase your throughput any. they are just there to be used in calculations for dynamic routing protocols -  good explanation of the command here. http://articles.techrepublic.com.com/5100-10878_11-6093972.html

do a "show dsl interface atm 0"

if that doesn't show the speed you should be connecting at for ADSL (not 2/2+) you need to contact your ISP and get them to look at it.

0
 

Author Comment

by:tariqmansoor
ID: 24382036
Hi Guys,

sh dsl interface atm0 showing quite good bandwidth for that link. Is it suggesting that router is configured and getting ~6.3 Mbps ?
Speed tests performed in isolation only gave 800 Kbps.

Can you please assist ? Taanks
-------------------------------------------------------------------------------------
                 Interleave             Fast    Interleave              Fast
Speed (kbps):          6336                0           800                 0
Reed-Solomon EC:       3511                0             4                 0
CRC Errors:              35                0             0                 0
Header Errors:           33                0             0                 0
Bit Errors:               0                0
BER Valid sec:            0                0
BER Invalid sec:          0                0
----------------------------------------------------------------------------------

Thanks,
0
 
LVL 8

Expert Comment

by:ludo_friend
ID: 24382040
yes - the interface has trained up at 6mbit down, 800kbit up.
how long has it been on for? there are a few errors there, but if its been online for more then a few minutes thats probably nothing to worry about.

what test are you running exactly?
0
 
LVL 8

Expert Comment

by:ludo_friend
ID: 24382045
should probably mention that your isp can still be filtering you, and I'd probably have to see a copy of your routers config (passwords/keys removed) to see if you have any QoS settings that could be clamping your speed.
0
 

Author Comment

by:tariqmansoor
ID: 24428285
Thanks Ludo, Here you go
--------------

Building configuration...

Current configuration : 5618 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname a-ROUTER
!
boot-start-marker
boot-end-marker
!
no logging on
enable secret 5 $
enable password 7
!
no aaa new-model
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.26.0.1 10.26.0.99
ip dhcp excluded-address 10.26.0.199 10.26.0.254
!
ip dhcp pool apool
   network 10.26.0.0 255.255.255.0
   dns-server 10.10.10.133 10.201.1.1 203.8.183.1 61.88.88.88
   default-router 10.26.0.1
   domain-name au.itod
!
!
ip cef
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!

!
crypto isakmp policy 20
 encr 3des
 authentication pre-share
 group 2
!
crypto isakmp policy 30
 encr 3des
 authentication pre-share
 group 2
crypto isakmp key xxxxxxxxxxx address a.a.a.a
crypto isakmp key xxxxxxxxxxx address c.c.c.c
!
!
crypto ipsec transform-set avpn esp-des esp-md5-hmac
crypto ipsec transform-set cvpn esp-des esp-md5-hmac
!
crypto map vpn 20 ipsec-isakmp
 description **VPN Link to **
 set peer a.a.a.a
 set transform-set avpn
 set pfs group2
 match address a
crypto map vpn 30 ipsec-isakmp
 description ** VPN Link to c **
 set peer c.c.c.c
 set transform-set cvpn
 set pfs group2
 match address c
!
!
!
interface Ethernet0
 ip address 10.26.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 hold-queue 100 out
!
interface Ethernet2
 no ip address
 shutdown
 hold-queue 100 out
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.1 point-to-point
 description Link to  Internet Connection
 pvc 1/34
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface FastEthernet1
 duplex auto
 speed auto
!
interface FastEthernet2
 duplex auto
 speed auto
!
interface FastEthernet3
 duplex auto
 speed auto
!
interface FastEthernet4
 duplex auto
 speed auto
!
interface Dialer1
 description Internet Link Fixed IP b.b.b.b
 mtu 1400
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname 02
 ppp chap password 7
 crypto map vpn
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip http server
no ip http secure-server
!
ip nat inside source list 105 interface Dialer1 overload
ip nat inside source static tcp 10.26.0.100 3389 interface Dialer1 3389
!
!
ip access-list extended a
 permit ip 10.26.0.0 0.0.0.255 10.10.10.0 0.0.0.255
 permit ip 10.26.0.0 0.0.0.255 10.0.0.0 0.0.0.255
ip access-list extended c
 permit ip 10.26.0.0 0.0.0.255 10.200.0.0 0.0.255.255
 permit ip 10.26.0.0 0.0.0.255 10.202.0.0 0.0.255.255
 permit ip 10.26.0.0 0.0.0.255 10.201.0.0 0.0.255.255
no logging trap
access-list 1 permit 10.26.0.0 0.0.0.255
access-list 105 deny   ip 10.26.0.0 0.0.0.255 10.10.10.0 0.0.0.255
access-list 105 deny   ip 10.26.0.0 0.0.0.255 10.90.30.0 0.0.0.255
access-list 105 deny   ip 10.26.0.0 0.0.0.255 10.201.0.0 0.0.255.255
access-list 105 deny   ip 10.26.0.0 0.0.0.255 10.202.0.0 0.0.255.255
access-list 105 deny   ip 10.26.0.0 0.0.0.255 10.200.0.0 0.0.255.255
access-list 105 deny   ip 10.26.0.0 0.0.0.255 10.0.0.0 0.0.0.255
access-list 105 permit ip 10.26.0.0 0.0.0.255 any
access-list 105 permit tcp any host 10.26.0.100 eq 3389
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
!

end

a-ROUTER#exit
0
 
LVL 8

Accepted Solution

by:
ludo_friend earned 500 total points
ID: 24428381
no QoS,  I'd be talking to your isp.

0
 

Author Comment

by:tariqmansoor
ID: 24428785
Thanks for that,
0
 

Author Closing Comment

by:tariqmansoor
ID: 31581297
Completed
0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question