Hyperlinks with merge fields lose the reference to the merge field after save in word 2007

I am trying to create a hyperlink in Word 2007 that references a merge field to provide the location of an image. When I insert the hyperlink it looks as follows:
However when I click save and reopen the file the merge field no longer appears and all I see is
When I merge the letter none of my photos print as a result of this.

This works fine in word 2000 and word2003. If I save as a word2003 format it still works ok, but if I save as a DOCX then the merge field gets removed.

Any help with this would be appreciated. It seems like this is a known issue but the other solutiions I have seen do not seem to apply to what I am doing or work for me.
Who is Participating?
Joanne M. OrzechConnect With a Mentor Manager, Document Services CenterCommented:
You should not be inserting the picture itself from what I am reading...

As I said above, go to Insert, QuickParts, Field, and select INCLUDEPICTURE.   Click OK.  Then, press Alt-F9 to view the field codes and insert your mergefield at that point.

Joanne M. OrzechManager, Document Services CenterCommented:
Is that the only field in the document?  Or do you have other merge fields?
I'm having the exact same trouble.  In my documnent I also have other standard merge fields.  Those save just fine.  

This is what my field looks like before I save it --- {HYPERLINK {MERGEFIELD Bus_Dir_Link } \* MERGEFORMAT }.  It works great to pull variable hyperlinks from my .csv file.

After returning to the saved doc, then the Mergefield section contains the actual data from my first record and no longer performs the merge.

If I recall correctly, this was working fine in Word 2003 and I just upgraded to Word  2007.
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Joanne M. OrzechManager, Document Services CenterCommented:
What happens when you press Alt-F9?
kmccannAuthor Commented:
When I press ALT F9 it toggles between showing the hyperlink and mergefield syntax and the display text. After I save and come back in the toggle will display the display text or the HYPERLINK syntax with no mergefield syntax. Basically the mergefield inside the hyperlink is deleted every time you save the document. I read somewhere that due to the way that XML saves the hyperlink in DOCX it cannot be dynamic but has to be a simple hyperlink. So I need to find some alternate solution that does not use hyperlinks to do this.

This definitely worked in 2003 and will still work if I save the doc back from 2007 to the old 2003 format, but I have 800 users who will not remember to do this.

I saw some references to INCLUDEPICTURE that looked like they may work but I have not been able to get the syntax to be recognized. I have followed the help and it does not work the way it is described in help and I never can see the field code. If someone know how to get to the field codes for INCLUDEPICTURE that may be my solution.
kmccannAuthor Commented:
btw, other mergefields work fine as long as they are not inside the hyperlink.
Joanne M. OrzechManager, Document Services CenterCommented:
Insert, QuickParts, Field, IncludePicture

Is that what you need?

Although this article is for 2003, it works the same way in 2007.

kmccannAuthor Commented:
Hi Jorzech
   I have been away on vacation for a few days and just getting back. Let me check this out and see if it will work for me. Thanks for the link.
Joanne M. OrzechManager, Document Services CenterCommented:
Lucky you...vacation! Let us know Kmccann.... *smile*

kmccannAuthor Commented:
I have tried this 10 different ways and still cannot get the field to display. I do the following:
- click on Insert..picture
-select the file I am interested in
- on the insert button click the drop down and select "link to file"
- I then see the actual picture in the document.
- if I click alt f9 I still see the picture

I cannot get back to the field codes that would show me something like "{ INCLUDEPICTURE "FileName" [Switches ] }" so that I could override the hard coded file name with the mergefield that I need to make this dynamic.
If I right click on the picture I donlt see anything useful that would get me back to the field code or to edit the file name that I initially selected.

I just can't seem to find a way to get back to the actual field code once the picture is inserted, regardless of which insert option I select.It seems like I have to be missing something obvious but I have tried this every way possible.

I would be eternally grateful to anyone who can give me step by step instructions as how to get in an edit the fieldcode for the INCLUDEPICTURE field.

kmccannAuthor Commented:
Sorry, I followed the hyperlink and was using that approach. I did not notice that you had said to insert quickparts in the text of your response. This does expose the fieldcode to me  and it holds on to the merge field after saving and reopening the file. Now i just need to rewrite the automation code I have that updates the path to the file and I should be good to go. Thanks so much for the help JOrzech.
Joanne M. OrzechManager, Document Services CenterCommented:
That's wonderful news!!!  I am so glad I was able to help... Thank you.

Joanne Orzech
EE Zone Advisor
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.