Configure Exchange 2007 to Route Messages for a Shared Address Space on SBS2008


I have a client running  SBS2008 who share their domain with external email recipients.  Their domain is, email is hosted on a 3rd party mail server, and  their exchange server grabs mail via POP3 connector.  They also have many external users with email addresses.

Previously they had SBS203 which hasa  neat option to send email for unresovled local recipients via the smarthost and out to the internet.  This worked fine for emailing external recipients from inside the network.

In SBS2008 the process is different, requiring you to change the accepted domain type to internal relay and add an additional  send connector for the shared address space (

I followed the instructions here to the letter:

also same thing is stated here:

however email to external addresses still bounces with an NDR from the exchange server saying no recipient found.

What am i missing?  do i need to change the Cost on the default "Windows SBS Internet Send SBS" send connector or my custom connector?

Do i need to restart particular services to make the change effective?
Who is Participating?
natrat22Connect With a Mentor Author Commented:
here are screenshots of the internal relay settings.
natrat22Author Commented:
Further to this, another book i am reading suggests that is the public MX for the customer is an external mail server then all you need to do is change the Acceted Domains to External Relay Domain, and no additional send connector is required.

When itry and do this i get the error:

Microsoft Exchange Error
The following error(s) occurred while saving changes:

Cannot remove the domain ''because it is referenced by the proxy address template ''.

The problem is that you have your server configured to be authoritative for the domain in question, because of this - it is going to look in its local GAL for any mailbox in the * domain - and, when it fails to find one - it generates the NDR instead of sending the mail through the external connector

clear the "This Exchange Organization is responsible for all mail delivery to this address" check box in the SMTP Address Properties dialog box and you should be ok provided you have the appropriate downstream connector configured for
natrat22Author Commented:
There is no "This Exchange Organization is responsible for all mail delivery to this address check box in the SMTP Address Properties dialog box "  on SBS2008 / Exchange 2007 that i am aware of.  Thats from older Exchange servers.
natrat22Author Commented:
FYI all my settings were correct and the server started routing mail correctly when left for an hour or two.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.