Solved

Wireless Access Point to Wireless Access Point Configuration

Posted on 2009-05-13
11
1,224 Views
Last Modified: 2013-11-09
Greetings,

I'll try my best to describe the problem and provide enough information.

Problem is:
Numerous network disconnects when trying to access Microsoft Access Database's on a Server located in Building #1 from a PC located in Building #2....internet works fine...internet radio (probably due to buffer) works fine....it's only when trying to access data on our Server other than "internet" data that we experience network disconnects.The disconnect is very brief (1/2 a second or less) but enough to produce the "ballon" message from the adaptor icon located in the tray of the PC
 in Building #2.

Question is:
is there a better way to configure the the 2 AP's to communicate to each other instead of the "Access Point" / "Repeater" configuration mentioned above?
I'm thinking that the   Access Point / Repeater setup, while it works, may be contributing to network disconnects when trying move larger amounts of data.
Is it possible to "tweak" advanced settings in Wireless AP's to remedy this problem?...for example changing the Data Rate from Auto to ?.




Building #1 (T-1 Internet Connection)
DWL-2100 AP (192.168.111.30) Connected to Linksys Switch > Connected to Belkin Router (192.168.111.254) >Connected to Cisco Router which delivers the T-1 to Belkin Router.
DWL-2100 AP (192.168.111.30) Connected to Omni-Directional Antenna (rated for 1.5 mile range) setup as an  "Access Point" with Static IP on same Subnet as Belkin Router.DHCP Turned off on this AP.DHCP coming from Belkin Router to clients in Building #1 & Building #2

Building #2 (Less than 1/4 mile away)
DWL-2100 AP (192.168.111.20) Connected to Outdoor Patch Antenna setup as a "Repeater" with static IP on same subnet as Belkin Router.
DWL-2100 AP (192.168.111.20) plugged into Linksys Switch providing network/internet to 2 other workstations utilizing DHCP from the Belkin Router. DHCP turned off on this AP as well.

Wireless Signal Strength between Wireless AP's = 70%-74% consistantly between Omni-Directional Antenna and Patch Antenna.

Firmware on both DWL-2100 AP's = v 2.11
Turbo G disbled on both AP's.
802.11g only is enabled (tried with 802.11g disabled with no difference)

Ping results from a PC on same side as DWL-2100 AP configured as "Access Point" in Building #1  to DWL(cannot ping with a packet size larger than 34,000bytes)  0% Loss /  min=58ms / max=541ms / avg=136ms


Any Advice or direction is appreciated.

Thank you,
John B




Building-2-Wireless-AP-Statistic.pdf
Wireless-AP-Advanced-Settings-bo.pdf
0
Comment
Question by:jbaretta
  • 4
  • 3
  • 3
  • +1
11 Comments
 
LVL 2

Accepted Solution

by:
v46n earned 250 total points
ID: 24381686
a couple of things
download speedtest.net/mini.php on a computer on the remote network and perform a speedtest to test your internal network throughput over the wireless

Once you have established a good link speed we can start to look at some other things.

your signal was 74% does it give you a signal over noise level?  What channel are you using

Also the 2100 work better as host and wireless client as appose to host/repeater.

Also change the premable to long instead of short, this should help if their is an lag.

Once you tweak these settings perform a speedtest again.

Also note that if you statically set the speed lower on the access points you can achieve a better quality signal


0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 24381693
Hi,

From what you tell it seems that you're running an ideal configuration. To use the network in AP/ Repeater mode is your only alternative. In that it is this mode what provides you to use addresses from the same subnet in two buildings. If you had used routing instead of bridging you'd had PC's in diffrent buildings assigned addresses from different subnets.  It is to allow you could route packets from one network to another. In short bridging is a low level protocol and it runs with Hardware Addreseses rather than Routing which is a high level protocol and runs with TCP/IP addresses.

In the internet world packet sizes are around 1500 bytes. Since each device who wants to communicate each other knows that and sets the packet size around 1500 bytes no problems occur. but in Intranets it is sometimes a good idea to keep packet sizes larger. Because this provides higher when  large chunks of data are transferred from one end to the other where communication speeds re relatively higher in intranets. As your posting suggests in your network this value is near 32K.

What happens when a large packets like 32K wants to be transferred over a network which has a smaller packet size say, 1500 byte is large packet to be divided several small size packets during transmission and receiving end just collects them all and assembles the packet. but if Larger packet size is not at a size that ii not powers of the smaller size. The packets can not always be assembled at receiving end. When a packet could not been assembled at receiving end it requests whole packet to be retransmitted from the sender.

I believe you problems lies in this size discrepancy. Let me check your config files closely and let you know about what to change.
0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 24381694
Will you please post MTU sizes from both AP and Router ?
0
 
LVL 2

Expert Comment

by:v46n
ID: 24381697
also believe it or not you may get a better result by lowering the input power of the radio to the antenna. If you push out too much energy it can be like holding a loud speaker to someones ear and cause a poor quality link
0
 

Author Comment

by:jbaretta
ID: 24382183
Thank you both for commenting.
Here are responses to your comments:

v46n:
I'll download mini.php and test wireless network throughput tomorrow.
No "signal over noise level" reading available on AP.
Channel 1 ( Hmmmmm.....I have not tried changing to different channel).
It is in the middle of nowhere....I can't imagine any interference.
I was unable to get host / "wireless client" config to work...only Host / Repeater seems to work-it's my understanding only 1 PC would work in building#2 if "wireless client" used on AP in building #2 (?).
I'll try changing preamble  from short to long tomorrow.
"Statically set the speed lower" ......I think you are referring to the "Data Rate"?....I'll try setting the "Data Rate" from "Auto" to 36Mb.
"Lowering the input power of the Radio to the antenna"....should I try this on both
AP's .....or just the AP Attached to the Omni-Directional antenna?....good analogy.

KeremE:
I agree....."Size" does appear to matter in this problem  :-)
I looked on both D-Link DWL-2100 AP's and the Belkin Router and could not locate a setting or stat for MTU. The only time I've noticed this setting is on Linksys Routers (Maximum Transfer Unit)...if this is what the MTU is your referring to.
Since "Size" appears to affect network performance....do you think v46n's suggestion of chaging the "Data Rate" and "input power" settings will help?

Thank you both again for commenting...I await your expert opinions.
John B








0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 
LVL 30

Assisted Solution

by:Kerem ERSOY
Kerem ERSOY earned 250 total points
ID: 24382312
KeremE:
I agree....."Size" does appear to matter in this problem  :-)
I looked on both D-Link DWL-2100 AP's and the Belkin Router and could not locate a setting or stat for MTU. The only time I've noticed this setting is on Linksys Routers (Maximum Transfer Unit)...if this is what the MTU is your referring to.
Since "Size" appears to affect network performance....do you think v46n's suggestion of chaging the "Data Rate" and "input power" settings will help?

Yeh MTU = Mx Transfer Unit. Dlink also has it It has send treshold of 2346 and RTS Trshold are the same.
I really liked v4n's suggestion. It is worth to give a try but since you interconnect intranets you'd better be as fast as possible.  Plaing around with power might or might not benefit you'd better try. Cus the alternative is to measure the power and it will require some sophisticated equipments :)
0
 
LVL 3

Expert Comment

by:biofishfreak
ID: 24392811
Frankly I'd try picking up another directional antenna and sticking the "repeater antenna" directly into building #2 and run off the ethernet ports on that. The router is rated at up to 400m anyway outdoors, so the use of two directional antennas should boost that a little (just be sure to line them up precisely!) If you do do that, try enabling the Extreme G. Also do a spectrum test using a program like Network Stumbler. http://www.netstumbler.com/downloads/ That software can also tell you your signal to noise ratio.

-Guy
0
 
LVL 2

Expert Comment

by:v46n
ID: 24395051
once your thoughtput test is done with the data rate on auto you will probably see a result much lower then 36mb. If this is the case, try setting it really low to like 5.5 and run the test just to compare results. You can lower the power on both radios or just 1, its better the lower both to 3/4 input power then one to 1/2 input power.

netstumbler wont really help you out unless you have a wireless card with a removal antenna that you can plug directly into one of the antennas to see the true signal over noise.

0
 

Author Comment

by:jbaretta
ID: 24398073
Thank you all for commenting,
I have done some preliminary testing and found that the AP setup as a "Repeater" is powering off (the power light blinks then returns to solid) during heavy data transfer......data other than normal internet data. Ther are no power delivery problems in the location where the "Repeater" AP is due to no power problems with other devices...switches, camera DVR.etc.
I have removed both AP's, attached the original antenna's  and tested the same exact setup in another enviroment. With the AP's closer together due to smaller antennas, setup as is with no changes to power, data rate, etc, they work flawlessly...I can ping 65500bytes of data 50x w/0% loss at 30ms-45ms.
I will be returning to the site today where the antenna's are and re-install the AP's.
v46n: Is it possible that the transmit power set at full could cause the AP to reboot? I will work with the power settings as you mentioned...should I try removing the Wi-Fi booster between the AP and outdoor omnidirectional antenna to see the result? It appears that the problem is releated to equipment other than the AP's....antenna's, booster, cabling (?).
Thanks biofishfreak: we went with the Omni-directional setup since we originally had 2 buildings that needed to communicate with the main building with the AP setup as "Access Point" (that 2nd building was crushed by a train car during loading but we did manage to salvage the AP...not the antenna  :-/  )
Plus we use it in the surrounding area to connect with our laptops.....we only use the laptops for internet access so heavy data transfer while connecting to the Server is not a problem....it's only in building #2 with the workstations connecting to the Server.
Since the beginning I never enable SuperG Turbo since I was advised against it from the location I purchased the equipment from.
I will update this post evening of 5/15/09 with my results from changing power settings per v46n.
Any additional info is appreciated.
Thanks all,
John B
0
 

Author Comment

by:jbaretta
ID: 24416041
Greetings all,
Thank you all for your input...the problem has been resolved using the following settings:

1. Changed from channel 1 to 6 on the "Access Point" AP - "Repeater" AP set to automatically use the channel from the "Access Point" AP.
2. Changed the Fragment Length from 2346 to 1500
    Changed the RTS Length from 2346 to 1500.
3. Turned on Wireless Setting of "Super G".
Data Rate still set at "Auto" and Transmit Power still set at "Full".

After making these changes I am able to ping with a packet size of 65500bytes  with 0% loss and average rate of 24ms between the AP's. Before making these settings I was only able to ping with a max packet size of 32000bytes.
We are no longer experiencing network disconnects during increased traffic usage....we only experience a slow down in the transfer rate.

Thank you again to all for assisting in solving our problem!

John B
0
 

Author Closing Comment

by:jbaretta
ID: 31581306
Thank you for time and expertise.
John B
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Need WiFi? Often, there are perfectly good networks that don't have WiFi capability - and there's a need to add it.  - Perhaps you have an Ethernet port into a network but no WiFi nearby. - Perhaps you have a powerline extender and no WiFi at the…
This article is a step by step guide on how to create a basic PTP link using Ubiquiti airOS devices. This guide can be used on the following Ubiquiti AirMAX devices. Nanostation, Bullets, AirBridge, Nanobeam, NanoBridge to name a few. Please review …
This Micro Tutorial will show you how to maximize your wireless card to its maximum capability. This will be demonstrated using Intel(R) Centrino(R) Wireless-N 2230 wireless card on Windows 8 operating system.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now