Solved

Oracle Vmware - Error, some other host already uses address 10.98.1.102. FAILED

Posted on 2009-05-14
7
2,151 Views
Last Modified: 2013-12-18
I am following the wartak document located under http://www.oracle.com/technology/pub/articles/wartak-rac-vm.html

"Build Your Own Oracle Extended RAC Cluster on Oracle VM and Oracle Enterprise Linux"

I am hitting a problem when bringing up the rac1 and rac2 eth2 network devices.

E.g. rac2 eth2 shares the same I.P. address as iscsi2 :

root@iscsi2 network-scripts# cat ifcfg-eth1
DEVICE=eth1
BOOTPROTO=none
ONBOOT=yes
TYPE=Ethernet
USERCTL=no
IPV6INIT=no
NETMASK=255.255.255.0
IPADDR=10.98.1.102
MTU=9000

Note above that the address is 10.98.1.102.

As per the document, this is the same I.P. address as rac2 eth2:

root@rac2 network-scripts# cat ifcfg-eth2
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
TYPE=Ethernet
DEVICE=eth2
HWADDR=00:16:3E:22:78:26
NETMASK=255.255.255.0
IPADDR=10.98.1.102
MTU=9000

When I start the network, I get the following error:

root@rac2 network-scripts# service network start
Bringing up loopback interface: OK
Bringing up interface eth0: OK
Bringing up interface eth1: OK
Bringing up interface eth2: Error, some other host already uses address 10.98.1.102.
FAILED

I believe I am following the document to the letter but I cannot get the device to come up without taking down the opposite device on iscsi2.

Please help.

Thanks.
0
Comment
Question by:theslothuk0
  • 4
  • 3
7 Comments
 
LVL 10

Expert Comment

by:elf_bin
ID: 24383379
So you have eth0 as a different IP, eth1 and eth2 as a shared IP.  To allow that you need to "tell" both the OS and the switches that you are bonding eth1 and eth2 (well actually you only HAVE to tell the OS, the switches are a good idea as that *may* allow for primitive load balancing depending on the switches you're using).
When eth2 is coming up it'll do a subnet broadcast claiming it's <this_mac> and has <this_ip>, eth1 will state it already has <this_ip> and that's where eth2 will shutdown.  
Follow the instructions at http://www.cyberciti.biz/tips/linux-bond-or-team-multiple-network-interfaces-nic-into-single-interface.html to setup a bond between eth1 and eth2 (or google search for how to ethernet bonding linux).

Hope this helps.
0
 

Author Comment

by:theslothuk0
ID: 24383794
Thanks, what you're saying makes sense and please know your help is very much appreciated.

I went to the link you gave me and it seems that this version of linux does not support the bonding you speak of.

Also, the document I am following (above) which is from oracle doesn't mention any of that. Plus, the version of Linux is specific to a VMWare template supplied by them from their web site (link given in the doc)

It has to be something more simple that I have missed.

I have attempted to contact the guy that wrote the doc to no avail and have posted all my issues in great detail in an oracle forum under:

http://forums.oracle.com/forums/thread.jspa?threadID=899426

In order to get all the possible help available to me as the problem persists and I am at my wits end.
0
 
LVL 10

Expert Comment

by:elf_bin
ID: 24383969
Where are you up to in the document - give me a title so I can read from there.  (BTW, bonding with XEN is available here: http://sadiquepp.blogspot.com/2008/01/bonding-with-xen.html)
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:theslothuk0
ID: 24384195
Just below figure 32, at this point:

[root@localhost ~]# echo 'nameserver 10.99.1.1' > /etc/resolv.conf
[root@localhost ~]# cat >  /etc/sysconfig/network
NETWORKING=yes
NETWORKING_IPV6=no
HOSTNAME=rac1
<CTRL+D>
[root@localhost ~]# echo MTU=9000 >> /etc/sysconfig/network-scripts/ifcfg-eth1
[root@localhost ~]# echo MTU=9000 >> /etc/sysconfig/network-scripts/ifcfg-eth2
[root@localhost ~]# service network restart
Shutting down interface eth0:  [  OK  ]
Shutting down loopback interface:  [  OK  ]
Bringing up loopback interface:  [  OK  ]
Bringing up interface eth0:      [  OK  ]
Bringing up interface eth1:      [  OK  ]
Bringing up interface eth2:      [  OK  ]
[root@localhost ~]#

Which is when I get the error telling me the address for eth2 is already in use. (The same problem occurrs with iscsi1 vs rac1 as they too have the same duplication in terms of I.P. addresses)

Using iscsi2 and rac2 as examples, this is what I have configured and believe it to be correct as per the doc:

MACHINE ISCSI2:

root@iscsi2 network-scripts# cat ifcfg-eth0
DEVICE=eth0
BOOTPROTO=none
ONBOOT=yes
TYPE=Ethernet
USERCTL=no
IPV6INIT=no
NETMASK=255.255.255.0
IPADDR=10.99.1.102

root@iscsi2 network scripts # cat ifcfg-eth1
DEVICE=eth1
BOOTPROTO=none
ONBOOT=yes
TYPE=Ethernet
USERCTL=no
IPV6INIT=no
NETMASK=255.255.255.0
IPADDR=10.98.1.102
MTU=9000

MACHINE RAC2:

root@rac2 network scripts # cat ifcfg-eth2
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
TYPE=Ethernet
DEVICE=eth2
HWADDR=00:16:3E:22:78:26
NETMASK=255.255.255.0
IPADDR=10.98.1.102
MTU=9000

I can start the services on one machine but not both together as I get the clash.
0
 
LVL 10

Expert Comment

by:elf_bin
ID: 24385059
Either you've got the wrong IP addresses in use or you're not connecting them to the right bridge.  Slightly up from fig. 32 it says:
"To summarize, you want RAC VMs to be connected to bridges in the following manner:

    * eth0 connected to xenbr0 (bridged with first physical Ethernet of Oracle VM server; one can check that by issuing brctl show); this is the public interface for Oracle VM clients
    * eth1 connected to ibr0, Interconnect network for Cache Fusion
    * eth2 connected to sanbr0, our iSCSI SAN network"
Check that you have attached those physical devices to those virtual switches.
A little further down from fig.32 it lists the IP's you're supposed to have:
"Save the following as the /etc/hosts file:

127.0.0.1     localhost.localdomain localhost

# eth0: public network
10.99.1.91    rac1
10.99.1.92    rac2

# eth1: interconnect
10.97.1.1     rac1-priv
10.97.1.2     rac2-priv

# VIPs
10.99.1.201   rac1-vip
10.99.1.202   rac2-vip

# eth2: iSCSI SAN
10.98.1.101   iscsi1
10.98.1.102   iscsi2

# PUB for openfilers
10.99.1.101   iscsi1-pub
10.99.1.102   iscsi2-pub"

& I don't see where you've got the idea that eth1 & eth2 should be the same IP address.  That bit above says iSCSI (on eth2) should be 10.98.1.101 for iscsi1 & 10.98.1.102 for iscsi2

BTW, I note you're using jumbo packets (MTU=9000) you should note that not all switches support passing jumbo packets around.

Hope this helps.
0
 

Author Comment

by:theslothuk0
ID: 24386239
Hi,

If you look further up the page you will see where the I.P. addresses are duplicated.

It says to use 10.98.1.101 for eth1 on iscsi1 but later says to use that address for eth2 on rac1. It's this that causes me trouble when I try to start services for one or the other.

[root@localhost sysconfig]# cat >network-scripts/ifcfg-eth1
DEVICE=eth1
BOOTPROTO=none
ONBOOT=yes
TYPE=Ethernet
USERCTL=no
IPV6INIT=no
NETMASK=255.255.255.0
IPADDR=10.98.1.101
MTU=9000
<CTRL+D>

It's the same are for iscsi2 and rac2. Different devices, same I.P. address.

I've used brctl show but the output means nothing to me as it doesn't state what you should expect from the command output. Here is mine. (My virtual server which has ipscsi1, ipscsi2, rac1 and rac2 on it is called oravmsr1)

##############################################################

[root@oravmsr1 ~]# brctl show
bridge name     bridge id               STP enabled     interfaces
ibr0            8000.feffffffffff       no              vif11.1
                                                        vif10.1
sanbr0          8000.feffffffffff       no              vif11.2
                                                        vif10.2
                                                        vif9.1
                                                        vif8.1
xenbr0          8000.feffffffffff       no              vif11.0
                                                        vif10.0
                                                        vif9.0
                                                        vif8.0
                                                        peth0
                                                        vif0.0

0
 

Accepted Solution

by:
theslothuk0 earned 0 total points
ID: 24440216
I HAVE RECENTLY DISCOVERED THAT THIS IS THE CORRECT CONFIG:

VMRAC1
eth0 10.99.1.91
VIP 10.99.1.201
eth1 10.97.1.1
eth2 10.98.1.91

VMRAC2
eth0 10.99.1.92
VIP 10.99.1.202
eth1 10.97.1.2
eth2 10.98.1.92

ISCSI1
eth0 10.99.1.101
eth1 10.98.1.101

ISCSI2
eth0 10.99.1.102
eth1 10.98.1.102
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

It Is not possible to enable LLDP in vSwitch(at least is not supported by VMware), so in this article we will enable this, and also go trough how to enabled CDP and how to get this information in vSwitches and also in vDS.
In this article, I will show you HOW TO: Install VMware Tools for Windows on a VMware Windows virtual machine on a VMware vSphere Hypervisor 6.5 (ESXi 6.5) Host Server, using the VMware Host Client. The virtual machine has Windows Server 2016 instal…
This video shows how to configure and send email from and Oracle database using both UTL_SMTP and UTL_MAIL, as well as comparing UTL_SMTP to a manual SMTP conversation with a mail server.
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now