Solved

OMA problem - Event ID: 1503 Source: MSExchangeOMA

Posted on 2009-05-14
4
1,370 Views
Last Modified: 2012-05-07
Hi guys

I'm desperate for help with this issue, as I've got a number of people asking why OMA isn't working.  I'm running SBS 2003 with exchange and sharepoint (including v3).  I've checked that all the IIS settings and HTTP protocol settings reconcile with all KB articles that I've come accross, as far as I'm aware (disable Forms Based Authentication, no SSL, correct authentication on all virtual sites etc.).  I'm getting the following error in event viewer, which I  believe is some sort of issue with .NET 1.1?

When I navigate to http://server/oma I get a blank page with the following message:

A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator.
Home

OWA works perfectly when using https, however a few errors are displayed on the page when http, although it's still operational.  I'm assuming that it's ok for companyweb and default web site to operate through the same port?  The IP address of companyweb is defined as the server, however default web site is [All Unassigned].  

I didn't set this server up, so not quite sure what's been done.  Unfortunately a clean install is not an option.

Any suggestions would be much appreciated, it's driving me mad!

Many thanks

Adrian
Event Type:	Error

Event Source:	MSExchangeOMA

Event Category:	(1000)

Event ID:	1503

Date:		14/05/2009

Time:		11:20:23

User:		N/A

Computer:	SERVER

Description:

An unknown error occurred while processing the current request:

Message: Item has already been added.  Key in dictionary: "AspCookielessSession"  Key being added: "AspCookielessSession"

Source: mscorlib

Stack trace:

   at System.Collections.Hashtable.Insert(Object key, Object nvalue, Boolean add)

   at System.Collections.Hashtable.Add(Object key, Object value)

   at System.Web.SessionState.SessionStateModule.OnBeginRequest(Object source, EventArgs eventArgs)

   at System.Web.SyncEventExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute()

   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

 

 

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Open in new window

0
Comment
Question by:jonesgiles
  • 2
4 Comments
 
LVL 24

Expert Comment

by:Rajith Enchiparambil
ID: 24383431
0
 

Author Comment

by:jonesgiles
ID: 24383603
Many thanks for the link.  I've tried the majority of the suggestions with no luck, i'm afraid.  How do I check if I have a host header set for the website managing Exchange web access?

I tried:
"Damien Genbrugge (Last update 1/26/2008):
We encountered this event after changing the IP-address of our Exchange-server. We forgot to change the IP-restrictions on the "Exchange-OMA" virtual directory in IIS. Changing to the correct IP resolved the issue.

Anonymous (Last update 9/16/2007):
In my case, this problem occurs if a host header is set for the website managing Exchange web access.

Ben Weeks (Last update 2/20/2007):
"EventID 1101 from source MSExchangeOMA" may prove useful in solving this problem.

Anonymous (Last update 3/27/2006):
I had this same issue and it ended up being caused by my dual nic setup. I disabled the second nic and it worked fine.

Jens Haase (Last update 12/12/2005):
This event occurred after a SP2 installation on a Server where CRM was also installed. The following resolution helped. Edit the web.config File in the \Program Files\Exchsrvr\OMA\Browse directory and search for a line:

<sessionState mode="InProc"/>

Then add the following line in a new line above this line:

<pages enableSessionState="true"/>. "

However received the following error message when navigating to http://server/oma:

"Parser Error Message: Sections must only appear once per config file. See the help topic <location> for exceptions.

Source Error:


Line 110:              To disable cookies, set sessionState cookieless="true".
Line 111:      -->
Line 112:            <pages enableSessionState="true"/>
Line 113:            <sessionState mode="InProc" cookieless="true" timeout="20" />
Line 114:            <mobileControls SessionStateHistorySize="8">"

Thanks again for your suggestions, any comments on the above would be much appreciated.
0
 

Accepted Solution

by:
jonesgiles earned 0 total points
ID: 24387919
I resolved the above by replacing the web.config from another SBS 2003 box.  I decided to give this a go as it was an ASP.NET issue.  I also didn't have the application names and pools set correctly for all of the virtual servers.  It seems to be an issue that was caused by the installation of .NET 2x.

I'm now able to naviage to //server/exchange and //server/oma through IE, however am now receiving a slightly different error when attempting to sync with with a mobile device.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
how to add IIS SMTP to handle application/Scanner relays into office 365.

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now