[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

ASA RA VPN No LAN access - maybe NAT?

Posted on 2009-05-14
2
Medium Priority
?
918 Views
Last Modified: 2012-05-07
Hi,

I know there are plenty of these in the knowledge base but I couldn't find one that solved my issue.

The setup is:

HOST (192.168.1.0/24) ---- (192.168.1.250) ASA (192.168.0.2) --- (192.168.0.1) ISP ROUTER --- (200.1.1.1) .

The 200.1.1.1 ip address is NATTED to 192.168.0.2, and the VPN connection gets established. The problem is that no packets can be sent between the RA VPN Client and the internal network, neither the internal ASA interface (192.168.1.250). I can however send between client and outside ASA interface (192.168.0.2).

The pathping on the client shows that traffice is routed over the VPN interface.
I think it may be because my VPN clients receive IP addresses that are in the same subnet as the LAN and the ASA does not return the packets correctly or something. However when I do a hypothetical packet trace on the ASA it shows that the packet to the client should be forwarded over the outside interface.

Can you please help:
ASA Version 7.2(4) 
!
hostname blahasa
domain-name blah
enable password DO8Oc533.vJWmhVe encrypted
passwd DO8Oc533.vJWmhVe encrypted
names
name 192.168.1.1 lrserver1
name 192.168.1.2 lrserver2
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.250 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 192.168.0.2 255.255.255.0 
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
banner motd $
banner motd Only attempt to access this device, network or server if you are authorized to do so. All access will be logged and unauthorized access will be prosecuted.
ftp mode passive
dns server-group DefaultDNS
 domain-name blah
object-group network lrdwhk-lan
 network-object 192.168.1.0 255.255.255.0
object-group service inside_in_ports_tcp tcp
 port-object eq www
 port-object eq 8080
 port-object eq https
 port-object eq pop3
 port-object eq smtp
 port-object eq ftp
 port-object eq ftp-data
 port-object eq domain
object-group service inside_in_ports_udp udp
 port-object eq domain
object-group service outside_in_ports_tcp tcp
object-group service outside_in_ports_udp udp
 description NAT-T VPN POrt
 port-object eq 4500
 port-object eq isakmp
access-list inside_in extended permit tcp object-group lrdwhk-lan any object-group inside_in_ports_tcp 
access-list inside_in extended permit udp object-group lrdwhk-lan any object-group inside_in_ports_udp 
access-list outside_in extended permit udp any any object-group outside_in_ports_udp 
access-list inside_nat0_outbound extended permit ip any 192.168.1.192 255.255.255.224 
access-list LRDWHKLAN standard permit 192.168.1.0 255.255.255.0 
access-list LocalLANAccess standard permit any 
pager lines 24
logging enable
logging asdm debugging
mtu inside 1500
mtu outside 1500
ip local pool LRDWhkRAVPNIPPool 192.168.1.200-192.168.1.210 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
access-group inside_in in interface inside
access-group outside_in in interface outside
route outside 0.0.0.0 0.0.0.0 192.168.0.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
aaa-server LRDlrserver1IAS protocol radius
aaa-server LRDlrserver1IAS (inside) host lrserver1
 key 19radiusauth79
 acl-netmask-convert auto-detect
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-AES-128-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto ca trustpoint LRDASA1
 enrollment terminal
 crl configure
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption aes
 hash md5
 group 2
 lifetime 86400
crypto isakmp nat-traversal  20
telnet timeout 5
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 5
ssh version 2
console timeout 0
dhcpd auto_config outside
!
dhcpd address lrserver2-192.168.1.129 inside
!
 
group-policy LRDRAVPNWHK internal
group-policy LRDRAVPNWHK attributes
 wins-server value 192.168.1.1 192.168.1.2
 dns-server value 192.168.1.1 192.168.1.2
 vpn-tunnel-protocol IPSec 
 split-tunnel-policy excludespecified
 split-tunnel-network-list value LocalLANAccess
 default-domain value lr.local
tunnel-group DefaultRAGroup general-attributes
 address-pool LRDWhkRAVPNIPPool
tunnel-group LRDRAVPNWHK type ipsec-ra
tunnel-group LRDRAVPNWHK general-attributes
 address-pool LRDWhkRAVPNIPPool
 authentication-server-group LRDlrserver1IAS
 default-group-policy LRDRAVPNWHK
tunnel-group LRDRAVPNWHK ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:c046557e73946cb5fda5cf28000f2521
: end
asdm image disk0:/asdm-524.bin
no asdm history enable

Open in new window

0
Comment
Question by:schoemans
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 

Accepted Solution

by:
schoemans earned 0 total points
ID: 24383990
Sorry my stupidity, it was just plain access-list rules that was needed to allow all traffic to be passed over the interfaces if the IP address matches that of the local LAN.

I also completely disable NAT as it was not needed and removed all NAT exempt rules.

It is now working.
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 24383999
Try this:

conf t
no split-tunnel-policy excludespecified
no split-tunnel-network-list value LocalLANAccess
split-tunnel-policy tunnelspecified
split-tunnel-network-list value LRDWHKLAN
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This past year has been one of great growth and performance for OnPage. We have added many features and integrations to the product, making 2016 an awesome year. We see these steps forward as the basis for future growth.
In this article, WatchGuard's Director of Security Strategy and Research Teri Radichel, takes a look at insider threats, the risk they can pose to your organization, and the best ways to defend against them.
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question