WPAD problem. Not going to proxy. Local works fine?

Hello!
I have this code pasted below here and it works great on all I have defined except that it will not go to the proxy outside of the networks I have on the exception list.
What am I doing wrong here?

Just to clarify :
I have two proxy's as stated in the config below. NB. This does not work with one proxy configured.
All the networks are pr site networks wich works going right past the proxy.
I am on the 10.220.0.0 network. The other 10.220.x.x networks are /24 and I am on a /16.
Why does it not route me to one of the proxy's when I try to go to an external webpage or something not on the list?

Tom :)
function FindProxyForURL(url, host)
 
{
 
// ## Variables used to determine proxy
var proxy_yes = "PROXY 172.31.0.70:80";
var proxy_yes2 = "PROXY 172.31.1.70:80";
var proxy_no = "DIRECT";
 
// no proxy for specific IP ranges on sites http/https (wildcard)
 
if (shExpMatch(url, "http://200.1.203.*")) { return proxy_no; }
if (shExpMatch(url, "https://200.1.203.*")) { return proxy_no; }
if (shExpMatch(url, "http://10.220.10.*")) { return proxy_no; }
if (shExpMatch(url, "https://10.220.10.*")) { return proxy_no; }
if (shExpMatch(url, "http://192.168.7.*")) { return proxy_no; }
if (shExpMatch(url, "https://192.168.7.*")) { return proxy_no; }
if (shExpMatch(url, "http://10.220.14.*")) { return proxy_no; }
if (shExpMatch(url, "https://10.220.14.*")) { return proxy_no; }
if (shExpMatch(url, "http://10.220.23.*")) { return proxy_no; }
if (shExpMatch(url, "https://10.220.23.*")) { return proxy_no; }
if (shExpMatch(url, "http://10.220.17.*")) { return proxy_no; }
if (shExpMatch(url, "https://10.220.17.*")) { return proxy_no; }
if (shExpMatch(url, "http://10.220.27.*")) { return proxy_no; }
if (shExpMatch(url, "https://10.220.27.*")) { return proxy_no; }
if (shExpMatch(url, "http://193.71.146.*")) { return proxy_no; }
if (shExpMatch(url, "https://193.71.146.*")) { return proxy_no; }
if (shExpMatch(url, "http://10.220.20.*")) { return proxy_no; }
if (shExpMatch(url, "https://10.220.20.*")) { return proxy_no; }
if (shExpMatch(url, "http://10.220.4.*")) { return proxy_no; }
if (shExpMatch(url, "https://10.220.4.*")) { return proxy_no; }
if (shExpMatch(url, "http://10.220.5.*")) { return proxy_no; }
if (shExpMatch(url, "https://10.220.5.*")) { return proxy_no; }
 
// no proxy for specific protocol (FTP)
if (shExpMatch(url, "ftp://*")) { return proxy_no; }
 
// check local network
if ( isInNet(myIpAddress)), '10.220.0.0', '255.255.0.0') { return proxy_yes; proxy_yes2; }
 
// If nothing above matches finally return to proxy
else
{ return proxy_yes; proxy_yes2; }
 
}

Open in new window

Laksen83Asked:
Who is Participating?
 
Kevin HaysIT AnalystCommented:
I would go ahead and create a cname or (a) record in your DNS just for the sake of it.  When I create a machine for instance a dev machine, I may not call it a DEV for the name, but when I want to access it I will do dev.mydomain.com

If that doesn't work I'll see if I still have my wpad file somewhere.

Kevin
0
 
Laksen83Author Commented:
On another note I read on "google" about people setting a cname for wpad i.e. wpad.server
I have this only posted on a server called minnelli on port 8090.
So in the address for the script in IE I have http://minnelli:8090
Now I can download the wpad.dat script from that location and my IE does get the script.
Do I need a cname called like wpad.minnelli wich points to http://minnelli:8090 ?
0
 
Laksen83Author Commented:
All sorted out.
WPAD cannot be used with a portnumber in the address.
The best way also is to create a wpad cname as IE will automatically search for http://wpad/wpad.dat when it is setup for automagical discovery. The WPAD file can just be under the default webpage on the WPAD server as a file. No need to alter any default site if there is one in use on port 80. Just add the WPAD file there and add the MIME type application/x-ns-proxy-autoconfig (? Don't have the exact name infront of me now) and .dat as extension.
I also had some issues with not beeing able to ping "wpad" after I have added it as an alias in the DNS, but thats just some DNS issues with the suffixes.

Thanks :)
0
 
Kevin HaysIT AnalystCommented:
Glad you got it sorted out Laksen83.  Thanks for the grade and have a great day.
Kevin
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.