SQL 2005 Time Format needs to be UK

Hi

Our new SQL server 2005 database is using american time format, causing the newly migrated databases to fall over.

Could someone please advise how to change the time format to UK time in SQLserver 2005.

Kind regards

TMOTech
TMOTechAsked:
Who is Participating?
 
tbsgadiCommented:
Have a look at the following discussion
http://www.sqlteam.com/forums/topic.asp?TOPIC_ID=62891
0
 
TMOTechAuthor Commented:
Hi

No help I'm afraid.

The default time needs to be (DMY) instead of (MMDDYY) time format which appears to have been selected on installation by mistake.

Is there anyway to change this format without having to re-installed SQL Server 2005.

Please advise

Regards

TMOTech
0
Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

 
Raja Jegan RSQL Server DBA & ArchitectCommented:
Please find below the steps to set Language and Date format in SQL Server:

http://support.microsoft.com/default.aspx?scid=kb;en-us;173907

No need for reinstallation.
0
 
TMOTechAuthor Commented:
Hi,

I came across that article, but unfortunately it only seems to apply to Sql Server 6.5.  2005 doesn't appear to have the command sp_addlanguage.

Is there any equivalent for SQLServer 2005?
0
 
tbsgadiCommented:
0
 
TMOTechAuthor Commented:
Hi,

I've already tried that, but unfortunately changing the default language on logins, or the server itself doesn't change the language of the server (see Server properties --> general --> language) and hence the date format!
0
 
TMOTechAuthor Commented:
Hi,

Thanks for that.  I had come across that one but I was trying to avoid hacking the registry!!!  If I do a re-install can I solve the problem that way?  Some of the forums I've read suggest even then the dateformat will be fixed to US.
0
 
TMOTechAuthor Commented:
I went with the registry hack in the end.  It's solved the date format issue and hasn't caused any side affects - yet!
0
 
tbsgadiCommented:
I wouldn't use the word "hack"..Fix or edit is more appropriate ! :>
0
 
Raja Jegan RSQL Server DBA & ArchitectCommented:
Have you checked out my comment 24384018.
No registry hackings..

Steps from Microsoft to set the DD/MM/YY format.

http://support.microsoft.com/default.aspx?scid=kb;en-us;173907

Check that one out.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.