Solved

Remote Desktop cannot connect to the remote computer because the authentication certificate received from the remote computer is expired or invalid.

Posted on 2009-05-14
6
12,734 Views
Last Modified: 2012-05-07
Using remote desktop attempting to access a 2008 server I am getting the following error message.  The error does not appear when using XP, the time difference between the server and work station is  negligible - Remote Desktop cannot connect to the remote computer because the authentication certificate received from the remote computer is expired or invalid.
In some cases, this error might also be caused by a large discrepancy between the client and server computers.

0
Comment
Question by:Melvinf
  • 3
  • 2
6 Comments
 
LVL 74

Expert Comment

by:Glen Knight
ID: 24384343
Try allowing the less secure remote desktop in Windows 2008 Server by default it requires a higher level of security.
Right click my computer, select properties then Advanced System Settings.
You will then see 3 options.  Select "Allow connections from computers running any version of Remote Desktop"

Alternatively if you are running XP SP3 it should have 6.1 version of the remote desktop client
0
 

Author Comment

by:Melvinf
ID: 24384584
I checked the settings and "Allow connections from computers running any version of Remote Desktop"
is set.
0
 
LVL 1

Expert Comment

by:Saldavo
ID: 24384945
This message can appear when the date isn't set correctly in your bios.
0
Use Case: Protecting a Hybrid Cloud Infrastructure

Microsoft Azure is rapidly becoming the norm in dynamic IT environments. This document describes the challenges that organizations face when protecting data in a hybrid cloud IT environment and presents a use case to demonstrate how Acronis Backup protects all data.

 

Author Comment

by:Melvinf
ID: 24385256
I believe you are on to something.  Is there a way to set the bios clock without rebooting the system?
0
 
LVL 1

Accepted Solution

by:
Saldavo earned 125 total points
ID: 24385473
I have seen such a utilty to change some bios settings in Windows. However it was developed especially for that type mainboard. If your mainboard doesn't come with such a utility, you should reboot your system to change the bios settings.
0
 

Author Comment

by:Melvinf
ID: 24394425
The solution came down to rebooting the server.  Funny the problem on affected Vista work stations.

Thank you for the help.
0

Featured Post

Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Scenario:  You do full backups to a internal hard drive in either product (SBS or Server 2008).  All goes well for a very long time.  One day, backups begin to fail with a message that the disk is full.  Your disk contains many, many more backups th…
I was supporting a handful of Windows 2008 (non-R2) 2 node clusters with shared quorum disks. Some had SQL 2008 installed and some were just a vendor application that we supported. For the purposes of this article it doesn’t really matter which so w…
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

679 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question