Solved

How do I import a very large .SQL file using PHPMyAdmin?

Posted on 2009-05-14
14
1,521 Views
Last Modified: 2012-08-14
I am trying to import a .SQL file using PHPMyAdmin. The file I am trying to import is 71MB.
I create the database first using PHPMyAdmin, then use "Import". The process proceeds for a few minutes, then the status bar does not progress much, and then I get the following message:

Fatal error: Maximum execution time of 300 seconds exceeded in C:\AppServ\www\phpMyAdmin\libraries\import\sql.php on line 87

The end result is that it imports one table, and I can browse the table using PHPMyAdmin, but there are numerous more tables that are not created.  It is timing out in the process and the full database is not created.

When I attempt the same without the database already created, I get an error that no database is found. and this happens quickly.

I will admit, I am definitely a newbie when it comes to PHP / MySQL and I did try the same using the MySql command prompt suggestions posted in this forum, but nothing happens after executing the command.

Any Suggestions would be greatly appreciated. Thank You!
0
Comment
Question by:Kevin212
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 5
  • 3
  • +1
14 Comments
 
LVL 10

Expert Comment

by:mahome
ID: 24384842
You can use the mysql console

mysql dbname < sql.php
0
 
LVL 10

Assisted Solution

by:mahome
mahome earned 80 total points
ID: 24384875
Sorry you are on windows, then you call

mysql.exe dbname < sql.php

mysql.exe is located in your bin folder of Mysql, for example: C:\Programs\MySQL\MySQL Server 5.0\bin

if you have user and password, command is:

mysql.exe -u user -p password dbname < sql.php
0
 

Author Comment

by:Kevin212
ID: 24384930
Ok, thank you. one thing I am not clear onL in your syntax, I don't see where I indicate the backed-up .sql file that needs to be imported. if the file is named "test.sql", were does that factor into thet syntax you mentioned?, let's assume the database is named Testdb in PHPMyAdmin

0
Get Database Help Now w/ Support & Database Audit

Keeping your database environment tuned, optimized and high-performance is key to achieving business goals. If your database goes down, so does your business. Percona experts have a long history of helping enterprises ensure their databases are running smoothly.

 
LVL 10

Assisted Solution

by:mahome
mahome earned 80 total points
ID: 24385053
You use
mysql.exe -u user -p password Testdb < test.sql

where user and password are variables, you have to replace it with your username and password for Mysql
0
 

Author Comment

by:Kevin212
ID: 24385147
I used that exact syntax, with the propper User name and PW, with the tes.sql file in the "C:\AppServ\MySQL\bin" directory. Nothing happens, just a flashing cursor on the next line.

do I need to put that .sql file in a different directory? 0r to I need to do specify a hard path such as:

mysql.exe -u user -p password Testdb < C:\Temp\test.sql

??
0
 
LVL 39

Assisted Solution

by:Roger Baklund
Roger Baklund earned 40 total points
ID: 24385219
There should not be a space between "-p" and "password". You don't need to type the ".exe" part:

mysql -u user -pPassword Testdb < C:\Temp\test.sql
0
 
LVL 39

Expert Comment

by:Roger Baklund
ID: 24385228
If the test.sql file is in the current folder, you don't need to specify the path.
0
 

Author Comment

by:Kevin212
ID: 24385319
Thank you very very much for your help, Unfortunately...

..not sure what I am missing here. I'm doing exactly as stated, but again, just a flashing cursor. When I look in the .."MySQL\Data\Testdb" folder, there is only the file "db.opt"
0
 
LVL 10

Assisted Solution

by:mahome
mahome earned 80 total points
ID: 24385419
Try a login with console to get sure that everything works so far:

mysql -u user -pPassword

in the console you can check databases:
show databases;
0
 

Author Comment

by:Kevin212
ID: 24385527
I did that, no errors or anything.

I think I will satrt from scratch. Is there a particular version of WAMP that you suggest I install, don't wanna spin my wheels if there is a version issue going on here..
0
 
LVL 10

Assisted Solution

by:mahome
mahome earned 80 total points
ID: 24385737
0
 
LVL 39

Assisted Solution

by:Roger Baklund
Roger Baklund earned 40 total points
ID: 24386374
>> I did that, no errors or anything.

You did not even get the MySQL welcome message? This is how it should look like:
C:\Users\cxr>mysql -uUsername -pPassword DatabaseName
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 441
Server version: 5.0.67-community-nt MySQL Community Edition (GPL)
 
Type 'help;' or '\h' for help. Type '\c' to clear the buffer.
 
mysql>

Open in new window

0
 

Accepted Solution

by:
Kevin212 earned 0 total points
ID: 24402519
I was able to accomplish this by changing a setting in "config.inc.php"

The setting I changed was:

$cfg['ExecTimeLimit']  = 0;

I forget what the original value was, but by setting it to "0", it allowed the import to run to completion. I'm up and running now.

Thanks for the answers I did get, much appreciated.
0
 

Expert Comment

by:stmayes
ID: 24402547
I recommend that you just edit your .sql file. Split it into smaller files. If it is a PHPMyAdmin dump it is very verbose. So cut it at the comment sections and just upload it in multiple files.
0

Featured Post

Is Your DevOps Pipeline Leaking?

Is your CI/CD pipeline a hodge-podge of randomly connected tools? You’ve likely got a tool to fix one problem & then a different tool to fix another, resulting in a cluster of tools with overlapping functionality. Learn how to optimize your pipeline with Gartner's recommendations

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I have been using r1soft Continuous Data Protection (http://www.r1soft.com/linux-cdp/) for many years now with the mySQL Addon and wanted to share a trick I have used several times. For those of us that don't have the luxury of using all transact…
This article shows the steps required to install WordPress on Azure. Web Apps, Mobile Apps, API Apps, or Functions, in Azure all these run in an App Service plan. WordPress is no exception and requires an App Service Plan and Database to install
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

710 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question