Solved

asa5520 basic config

Posted on 2009-05-14
4
961 Views
Last Modified: 2012-05-07
Hi,

Have just taken delivery of a Cisco ASA5520 running 8.0(4) which a customer wants to install next week. I have just tried to log in to the device using the instructions in the cisco manual, (https://192.168.1.1), but get no response.

I have logged into the device using the console port and noticed that there was no address assigned to the management interface and it was shutdown. I have assigned 192.168.1.1 to the interface and 'no shut' it but I still cant get the device to respond to any pings. Although the interface shows as being up and up, (its physically connected to a hub at the moment), I cannot even ping from within the Cisco, (responds with 'no route to host').

The running/startup config as it came out of the box doesnt seem to be set up to allow web access into the device, (its supposed to be have dhcp enabled but didnt either?), so my question is, is there a script out there that I can use that allows me to get browser access as described in the manual?

BTW, although Ive had exposure to Cisco previously I havent ever played with one of their security devices, (no chance to get on a course just yet either), so many appologies for the very simplistic nature of this question.

The running config I have is as follows, (this is as it came out of the box apart from my changes to the management0/0 interface).

ASA Version 8.0(4)
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface GigabitEthernet0/0
 description outside
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/1
 description inside
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/2
 shutdown
 no security-level
 no ip address
!
interface GigabitEthernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 no nameif
 no security-level
 ip address 192.168.1.1 255.255.255.0
 management-only
!
ftp mode passive
same-security-traffic permit inter-interface
access-list External_access_in extended permit icmp any any
pager lines 24
logging enable
logging asdm informational
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
nat-control
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
!
class-map inspection_default
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
prompt hostname context
Cryptochecksum:31cb24d5c00f61dd1e1d314ac56e3cca
: end
0
Comment
Question by:atommo
  • 2
  • 2
4 Comments
 
LVL 33

Expert Comment

by:MikeKane
ID: 24386080
Out of the box the ASA is barebone, you would need to configure what you want.


Here is a very easy step by step to get you started.  
http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a0080094768.shtml
0
 

Author Comment

by:atommo
ID: 24387764
Hi Mike and many thanks for your help. That link will help no end I'm sure when I actually get around to configuring the device.

What I was trying to do was to get the asdm working so I could log into the damn thing, (it couldnt even ping itself in the command line), via a web browser.

I eventually got the supplier to remotely log into the unit and he found that a few images were missing. Once they were loaded and a couple of changes made to the config, (only a couple of lines), I am now able to load the gui asdm up, (after messing about with java versions), and, with a massive stroke of luck, be able to configure from there, (if not I can always refer to the command line stuff where that link will come into its own hopefully).

Many thanks again.
0
 
LVL 33

Accepted Solution

by:
MikeKane earned 50 total points
ID: 24388738
I guess I went to basic there.    I didn't realize it was the ASDM you were trying to access.   Using the cli is helpful in that you can easily copy the entire config into here for review...  

Good luck
0
 

Author Closing Comment

by:atommo
ID: 31581475
Thanks again Mike. I was probably not very clear in my question, (probably because I dont know much about the asa/pix's). I'm sure the link you provided will come in handy when I actually get down to configure the damn thing.

Many thanks again.
0

Featured Post

Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Cisco iWAN 8 46
Guest VLAN not syncing email 13 20
OSPF Question 12 21
Clearing router cache 12 10
Cisco Pix/ASA hairpinning The term, hairpinning, comes from the fact that the traffic comes from one source into a router or similar device, makes a U-turn, and goes back the same way it came. Visualize this and you will see something that looks …
I recently updated from an old PIX platform to the new ASA platform.  While upgrading, I was tremendously confused about how the VPN and AnyConnect licensing works.  It turns out that the ASA has 3 different VPN licensing schemes. "site-to-site" …
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now