Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 834
  • Last Modified:

Bind Euro and Pound Sterling symbols to keyboard

Is it possible to bind these symbols to a keyboard key?

I realize I can use the "ALT + 0128" or "ALT + 156" combinations to do this, but i'm wondering if there's a shorter way?

I'd ideally like to be able to bind ALT plus one other key to each of these symbols. This would be used in a custom accounting package, so I don't think an excel macro would work.

Thanks,

Ryan
0
Stief-Group
Asked:
Stief-Group
  • 5
  • 4
1 Solution
 
delyan_valchevCommented:
Standard UK keyboard layout should already have the Euro sign available by pressing AltGr+4 along with the Pound sign Shift+3.
Hope it helps!
Delyan
0
 
Stief-GroupAuthor Commented:
Unfortunately, it's a standard US layout, so these don't work.
0
 
delyan_valchevCommented:
If you have an older OS which does not support the Euro sign, you can always use:
http://www.chiark.greenend.org.uk/~johns/kbukint.html
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
Stief-GroupAuthor Commented:
I believe that's what i'm doing right now,  ALT + ####.

Just wondering if there's a quicker method.

Thanks for the response though.
0
 
delyan_valchevCommented:
If you want to have the US keyboard layout and still be able to type at least the Euro sign, just change from standard US to US international. This way you get the AltGr+4. The Pound unfortunately is not in the AltGr combinations.
0
 
delyan_valchevCommented:
Just found the combo for the Pound in the US international: AltGr+Shift+4.
Cool!
0
 
Stief-GroupAuthor Commented:
that worked great.

for me though, ALT+5 is the Euro.

Thanks for your help!
0
 
Stief-GroupAuthor Commented:
Ok, I've now got another problem.   This US-International change has made it so that my ' and "  keys don't work the same.  They now seem to be operators for entering letters with accents.

Any way to turn that off?

Thanks
0
 
delyan_valchevCommented:
Well, the so called "dead keys" unfortunately cannot be disabled. You can get the quotes pressing space after ' and ". I know it's kinda cumbersome... You have the options:
- Hardware solution: Set the UK keyboard layout and re-engrave the keyboard
- Software solution: Use the MSKLC (http://msdn.microsoft.com/bg-bg/goglobal/bb964665(en-us).aspx) to create a modified version of the layout. I haven't tried this and I don't know if it can help.
Cheers,
Delyan
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now