Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 9475
  • Last Modified:

Citrix Warning Message

Hello - I'm receiveing a warning message after I installed Citrix client and loged into Citrix site.

Your current browser security settings may prevent you from accessing your published resources or may require your explicit permission to proceed. To access a published resource successfully, save the .ica file locally when prompted and then double - click it to start published resources.

When I try to connect to a app, I get an error occurred while making the requested connection.

I appreciate anyones help.
0
Jaime Campos
Asked:
Jaime Campos
2 Solutions
 
Daniel BorgerSenior Citrix Engineer- CCEECommented:
It's a generic warning message since you have automatic client detection turned off.

Just edit the file MessageUtils.java in folder WI-path\app_code\PagesJava\com\citrix\wi\controlutils
and comment out these two lines (line 53 and 54)

viewControl.addMessage(new MessageScreenMessage(MessageType.WARNING,
wiContext.getString("SaveLaunchFileToDisk"), wiContext.getString("SaveLaunchFileToDisk")));

add // to begining of the line.
0
 
Kentrix70Commented:
You could also add the Citrix Logon Page as a trusted website.
Then in most cases you should be able to launch the applications directly without the eror
0
 
Jaime CamposAuthor Commented:
dborger - searched for MessageUtils.java folder and no luck. Why am I getting this error and is there a way to resolve this issue at the root?

Kentrix70 - I tried adding my site logon page to trusted website and still same error message.

Any other ideas?
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
Jaime CamposAuthor Commented:
ok... I rebooted and warning message went away, however I still get error: An error occured while making the requested connection whenever I select an app.

0
 
Daniel BorgerSenior Citrix Engineer- CCEECommented:
0
 
Daniel BorgerSenior Citrix Engineer- CCEECommented:
I think for that you will need to explain how and what you are connecting to..
0
 
Jaime CamposAuthor Commented:
Connecting to a XenApp server which has my single application. The application is Electronic Medical Record (EclinicalWorks). All worked great when I would connect through HTTP, however when I attempt to connect through HTTPS it seems that something may be getting blocked. I've allowed my TZ190 to NAT public IP to internal IP and created access rules and open ports 444, 443, 80 and Citrix ports.

My STA URL is setup with:
FQDN of XenApp: WIN08CITRIX
Path: /Scripts/CtxSTA.dll
ID: (auto, this will fill itself in)
Protocol Settings: (uncheck "Secure traffic...")
TCP port: 8080 (uncheck "Use default")

Web Interface configuration:
Address (FQDN): WIN08CITRIX
Port: 443
Enable Session Reliability (leave unchecked)
Secure Ticket Authority URLs: WIN08CITRIX
8080/scripts/ctxsta.dll

Web Interface 5.0.1
Web Interface 5.0.1 Access Management Console Extension
Server 1: yes, 64-bit W2K8, loaded XenApp 5, made it the Data Collector.
Server 2: 32-bit W2K3, load Citrix Web Interface and Citrix Secure Gateway

All traffic will go to Server 2 via port 443 and proxy to Server 1 so the only ports you need to open are 80 and 443 to Server 2.

Hope this helps.  
0
 
Jaime CamposAuthor Commented:
Sorry I gave you incorrect info...

The WI is setup for Gateway Direct and I modified the Default (under client IP address). I got to this setting by following instructions that stated for me to go to managed secure client settings - gateway settings, however please note that gateway settings is not listed as an option for me. All I have is Managed secure client access - edit secure client access settings and this is where I modified default settings as I stated. I feel this is where the issue resides, however not sure why I do not see gateway settings.

My current settings are below. I can get to the website, however again when I select app it states error message. An error occurred while making the requested connection. it has to be the managed secure client access setting.

Address (FQDN): ecwtrainingdb.rapa.local
Port: 443
Enable Session Reliability (leave unchecked)
Secure Ticket Authority URLs: WIN08CITRIX
8080/scripts/ctxsta.dll

This has to be the issue. Before I changed the default setting, http access was working fine. Once I changed to gateway direct, HTTPS works, but can not access apps from either http/https.

I appreciat all your help.

nimdatx


0
 
JonathanSpitfireSenior Solutions EngineerCommented:
hello nimdatx. Curious to know how your experience has been publishing eClinicalWorks via XenApp. I'd love the opportunity to chat with you off list if you have some time. Please respond back if you're willing to share your experience.

Thanks!
0
 
Jaime CamposAuthor Commented:
Jon,

I'm sorry I just noticed this message as I was researching back to my old posts. Please let me know if you still need anything?

nimdatx
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now