?
Solved

Single sign on missing

Posted on 2009-05-14
7
Medium Priority
?
522 Views
Last Modified: 2012-05-07
When users attempt to access companyweb from rww, they are prompted for username and password. I am not sure if this is related, but while looking for a solution, I realized that the single sign on service was not listed under services.msc. It is not an option for configuration in the sharepoint management console in the security configuration section. How do I get this service back? Also, will getting this resolved, solve the prompting for username and password?
0
Comment
Question by:xzay1967
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
7 Comments
 
LVL 51

Expert Comment

by:Ted Bouskill
ID: 24392639
SSO will have not effect on the prompt.  The prompt is triggered by accessing the page itself before the page actually executes.

In Windows Authentication a user is automatically logged on if the client domain matches the server domain which let's IE know that they are in a 'Local Intranet' and to automatically sign in.  Or if the site is marked as a 'Trusted Site' and automatic log in is set for the 'Trusted Site'
0
 

Author Comment

by:xzay1967
ID: 24395603
I see what you mean Ted, so, how do I resolve the issue? Or is this something users will have to learn to deal with? At least tell me how to fix it, so if it becomes an issue, I know how to address it. Thanks for the help.
0
 
LVL 51

Expert Comment

by:Ted Bouskill
ID: 24400458
I need more information to answer that.  Does the user log in domain match the domain of the website?

IE: DOMAIN\user with an email address user@domain.com is logged into a computer that belongs to DOMAIN and the domain suffix set by DHCP is set to domain.com and the website is http://*.domain.com (note the '*' represents a wildcard for any site that ends in domain.com)

If all the previous is true, then IE should sign them in automatically.  Otherwise you have to setup the web site as  a 'Trusted Site' with automatica login set for trusted sites.  Group policy objects can control the IE settings for an entire domain if they all do belong to the same domain.   Otherwise they have to do it manually.
0
Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

 

Author Comment

by:xzay1967
ID: 24403654
the internal domain is jonessmith.local, the email addresses are user@jones-smith.com
URL to RWW is https://office.jones-smith.com. When this was initially setup, the users were not prompted with a username and password dialog box after successfully logging in to RWW. This change occurred after doing windows updates. I uninstalle dall the updates, and the issue was still present. The only change that was fixed was the option to login to companyweb from the server (internally) was removed.
0
 
LVL 51

Accepted Solution

by:
Ted Bouskill earned 2000 total points
ID: 24435410
This is a browser issue likely triggered by the last change you mentioned.  IE tries to match the client domain with the web site domain.  If they are the same it assumes that you are in the 'Local Intranet' and automatically logs the user in.  If they don't match it checks the 'Trusted Site' settings.  If the site is trusted and 'Automatically log in' is set, then you will not see a prompt.

If you look at the bottom right of your browser when viewing the site it probably thinks you are acccessing a 'Internet' site which is untrusted and you will see the authentication dialog.
0
 

Author Closing Comment

by:xzay1967
ID: 31583978
The advice was accurate. I added the intranet site to the trusted sites, and the issue is resolved. Hopefully there will be a permanent fix for this. As I mentioned, even after removing the updates, the issue still existed. Either way, thanks for the help.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The articles for turning off the Client firewall policy on the internet are for SBS 2008 and don't really help for SBS 2011. They actually moved the Client firewall policy. In 2011, the client firewall policy has moved to the SBS computers conta…
The vision: A MegaMenu for a SharePoint portal home page The mission: Make it easy to maintain. Allow rich content and sub headers as well as standard links. Factor in frequent changes without involving developers or a lengthy Dev/Test/Prod rel…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question