Solved

EIGRP - how to use "ip default-network" command?

Posted on 2009-05-14
13
1,514 Views
Last Modified: 2012-05-07
Hi Everyone,

I'm studying for my BSCI exam - EIGRP and trying to get the "ip default-network" command to work correctly.

I have three routers in a rectangle, and have added an int l666 interface with an IP of 6.6.6.6/32.  I've included network 6.0.0.0/8 in my EIGRP networks and the other routers are seeing it from EIGRP.  

When I go to add the "ip default-netwok 6.0.0.0" command, to make it the default route and advertise that through eigrp it's not working.  I have tried it several ways, but it just won't work.

Could anyone tell me what I'm doing wrong?

Thanks,

PC
Router11#show run

Building configuration...
 

Current configuration : 1562 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router11

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip subnet-zero

!

!

ip host Router13 10.13.0.1

ip host Router4 10.4.0.1

!

!

!

!         

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination 

!

!

!

!

!

!

interface Loopback0

 ip address 10.11.0.1 255.255.255.0

!

interface Loopback1

 ip address 10.11.1.1 255.255.255.0

!

interface Loopback2

 ip address 10.11.2.1 255.255.255.0

!         

interface Loopback3

 ip address 10.11.3.1 255.255.255.0

!

interface Loopback4

 ip address 10.11.4.1 255.255.255.0

!

interface Loopback666

 ip address 6.6.6.6 255.255.255.255

!

interface FastEthernet0/0

 no ip address

 shutdown

 duplex auto

 speed auto

!

interface Serial0/0

 bandwidth 1500

 ip address 192.168.2.1 255.255.255.252

 ip summary-address eigrp 100 10.11.0.0 255.255.248.0 5

 service-module t1 cablelength short 110ft

 service-module t1 clock source internal

!

interface Serial0/1

 bandwidth 1500

 ip address 192.168.1.1 255.255.255.252

 ip summary-address eigrp 100 10.11.0.0 255.255.248.0 5

 ip summary-address eigrp 100 10.11.0.0 255.255.0.0 5

 service-module t1 cablelength short 110ft

 service-module t1 clock source internal

!

router eigrp 100

 network 6.0.0.0

 network 10.11.0.0 0.0.255.255

 network 192.168.0.0 0.0.255.255

 no auto-summary

!

no ip http server

ip classless

ip default-network 6.0.0.0

!

!

access-list 1 permit 10.11.0.0 0.0.8.255

!

!

!

!         

!

!

!

line con 0

line aux 0

line vty 0 4

!

!

!

end
 

Router11#  

Router11#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route
 

Gateway of last resort is not set
 

 *   6.0.0.0/32 is subnetted, 1 subnets

C       6.6.6.6 is directly connected, Loopback666

     10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks

C       10.11.1.0/24 is directly connected, Loopback1

C       10.11.0.0/24 is directly connected, Loopback0

D       10.11.0.0/21 is a summary, 02:13:05, Null0

D       10.11.0.0/16 is a summary, 02:13:05, Null0

C       10.11.3.0/24 is directly connected, Loopback3

C       10.11.2.0/24 is directly connected, Loopback2

C       10.11.4.0/24 is directly connected, Loopback4

D       10.13.0.0/21 [90/2346496] via 192.168.2.2, 02:13:07, Serial0/0

D       10.4.0.0/21 [90/2346496] via 192.168.1.2, 02:13:07, Serial0/1

     192.168.1.0/30 is subnetted, 1 subnets

C       192.168.1.0 is directly connected, Serial0/1

     192.168.2.0/30 is subnetted, 2 subnets

C       192.168.2.0 is directly connected, Serial0/0

D       192.168.2.4 [90/2244096] via 192.168.2.2, 02:13:08, Serial0/0

                    [90/2244096] via 192.168.1.2, 02:13:08, Serial0/1

Router11#show ip eigrp top

IP-EIGRP Topology Table for AS(100)/ID(192.168.2.1)
 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - reply Status, s - sia Status 
 

P 6.6.6.6/32, 1 successors, FD is 128256

        via Connected, Loopback666

P 10.11.1.0/24, 1 successors, FD is 128256

        via Connected, Loopback1

P 10.11.0.0/16, 1 successors, FD is 128256

        via Summary (128256/0), Null0

P 10.11.0.0/21, 1 successors, FD is 128256

        via Summary (128256/0), Null0

P 10.11.0.0/24, 1 successors, FD is 128256

        via Connected, Loopback0

P 10.11.3.0/24, 1 successors, FD is 128256

        via Connected, Loopback3

P 10.11.2.0/24, 1 successors, FD is 128256

        via Connected, Loopback2

P 10.11.4.0/24, 1 successors, FD is 128256

        via Connected, Loopback4

P 10.13.0.0/21, 1 successors, FD is 2346496

        via 192.168.2.2 (2346496/128256), Serial0/0

          

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - reply Status, s - sia Status 
 

        via 192.168.1.2 (2372096/153856), Serial0/1

P 10.4.0.0/21, 1 successors, FD is 2346496

        via 192.168.1.2 (2346496/128256), Serial0/1

        via 192.168.2.2 (2372096/153856), Serial0/0

P 192.168.1.0/30, 1 successors, FD is 2218496

        via Connected, Serial0/1

P 192.168.2.0/30, 1 successors, FD is 2218496

        via Connected, Serial0/0

P 192.168.2.4/30, 2 successors, FD is 2244096

        via 192.168.1.2 (2244096/25856), Serial0/1

        via 192.168.2.2 (2244096/25856), Serial0/0

Router11#

Router11#

Router11#show ip eigrp neigh

IP-EIGRP neighbors for process 100

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

0   192.168.1.2             Se0/1             14 02:13:25    4   200  0  213

1   192.168.2.2             Se0/0             11 05:58:49    1   200  0  241

Router11#

Router11#show ip proto

Routing Protocol is "eigrp 100"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

  Default networks flagged in outgoing updates

  Default networks accepted from incoming updates

  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0

  EIGRP maximum hopcount 100

  EIGRP maximum metric variance 1

  Redistributing: eigrp 100

  EIGRP NSF-aware route hold timer is 240s

  Automatic network summarization is not in effect

  Address Summarization:

    10.11.0.0/21 for Serial0/0, Serial0/1

      Summarizing with metric 128256

    10.11.0.0/16 for Serial0/1

      Summarizing with metric 128256

  Maximum path: 4

  Routing for Networks:

    6.0.0.0

    10.11.0.0/16

    192.168.0.0/16

  Routing Information Sources:

    Gateway         Distance      Last Update

    Gateway         Distance      Last Update

    (this router)         90      02:13:33

    192.168.2.2           90      02:13:33

    192.168.1.2           90      02:13:34

  Distance: internal 90 external 170
 

Router11#
 
 

*************************************************************
 

Router13#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route
 

Gateway of last resort is not set
 

     6.0.0.0/32 is subnetted, 1 subnets

D       6.6.6.6 [90/2346496] via 192.168.2.1, 02:14:04, Serial0/0

     10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks

D       10.11.0.0/16 [90/2372096] via 192.168.2.6, 02:14:04, Ethernet0/0

D       10.11.0.0/21 [90/2346496] via 192.168.2.1, 02:14:04, Serial0/0

C       10.13.4.0/24 is directly connected, Loopback4

C       10.13.3.0/24 is directly connected, Loopback3

C       10.13.2.0/24 is directly connected, Loopback2

C       10.13.1.0/24 is directly connected, Loopback1

D       10.13.0.0/21 is a summary, 07:17:03, Null0

C       10.13.0.0/24 is directly connected, Loopback0

D       10.4.0.0/21 [90/153856] via 192.168.2.6, 02:14:06, Ethernet0/0

     192.168.1.0/30 is subnetted, 1 subnets

D       192.168.1.0 [90/2244096] via 192.168.2.6, 02:14:08, Ethernet0/0

     192.168.2.0/30 is subnetted, 2 subnets

C       192.168.2.0 is directly connected, Serial0/0

C       192.168.2.4 is directly connected, Ethernet0/0

Router13#show ip eigrp neigh

IP-EIGRP neighbors for process 100

H   Address                 Interface   Hold Uptime   SRTT   RTO  Q  Seq Type

                                        (sec)         (ms)       Cnt Num

1   192.168.2.6             Et0/0         12 02:14:18  308  1848  0  214   

0   192.168.2.1             Se0/0         10 05:59:37   19   200  0  213   

Router13#show ip eigrp top

IP-EIGRP Topology Table for AS(100)/ID(192.168.2.5)
 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - reply Status, s - sia Status 
 

P 6.6.6.6/32, 1 successors, FD is 2346496

         via 192.168.2.1 (2346496/128256), Serial0/0

P 10.11.0.0/16, 1 successors, FD is 2372096

         via 192.168.2.6 (2372096/2346496), Ethernet0/0

P 10.11.0.0/21, 1 successors, FD is 2346496

         via 192.168.2.1 (2346496/128256), Serial0/0

P 10.13.4.0/24, 1 successors, FD is 128256

         via Rconnected (128256/0)

P 10.13.3.0/24, 1 successors, FD is 128256

         via Rconnected (128256/0)

P 10.13.2.0/24, 1 successors, FD is 128256

         via Rconnected (128256/0)

P 10.13.1.0/24, 1 successors, FD is 128256

         via Rconnected (128256/0)

P 10.13.0.0/21, 1 successors, FD is 128256

         via Summary (128256/0), Null0

P 10.13.0.0/24, 1 successors, FD is 128256

         via Rconnected (128256/0)

          

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - reply Status, s - sia Status 
 

P 10.4.0.0/21, 1 successors, FD is 153856

         via 192.168.2.6 (153856/128256), Ethernet0/0

P 192.168.1.0/30, 1 successors, FD is 2244096

         via 192.168.2.6 (2244096/2218496), Ethernet0/0

         via 192.168.2.1 (2730496/2218496), Serial0/0

P 192.168.2.0/30, 1 successors, FD is 2178560

         via Connected, Serial0/0

P 192.168.2.4/30, 1 successors, FD is 25856

         via Connected, Ethernet0/0

Router13#
 

--------------------------------------------------------------------------------------------------
 
 

Router13#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route
 

Gateway of last resort is not set
 

     6.0.0.0/32 is subnetted, 1 subnets

D       6.6.6.6 [90/2346496] via 192.168.2.1, 02:14:04, Serial0/0

     10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks

D       10.11.0.0/16 [90/2372096] via 192.168.2.6, 02:14:04, Ethernet0/0

D       10.11.0.0/21 [90/2346496] via 192.168.2.1, 02:14:04, Serial0/0

C       10.13.4.0/24 is directly connected, Loopback4

C       10.13.3.0/24 is directly connected, Loopback3

C       10.13.2.0/24 is directly connected, Loopback2

C       10.13.1.0/24 is directly connected, Loopback1

D       10.13.0.0/21 is a summary, 07:17:03, Null0

C       10.13.0.0/24 is directly connected, Loopback0

D       10.4.0.0/21 [90/153856] via 192.168.2.6, 02:14:06, Ethernet0/0

     192.168.1.0/30 is subnetted, 1 subnets

D       192.168.1.0 [90/2244096] via 192.168.2.6, 02:14:08, Ethernet0/0

     192.168.2.0/30 is subnetted, 2 subnets

C       192.168.2.0 is directly connected, Serial0/0

C       192.168.2.4 is directly connected, Ethernet0/0

Router13#show ip eigrp neigh

IP-EIGRP neighbors for process 100

H   Address                 Interface   Hold Uptime   SRTT   RTO  Q  Seq Type

                                        (sec)         (ms)       Cnt Num

1   192.168.2.6             Et0/0         12 02:14:18  308  1848  0  214   

0   192.168.2.1             Se0/0         10 05:59:37   19   200  0  213   

Router13#show ip eigrp top

IP-EIGRP Topology Table for AS(100)/ID(192.168.2.5)
 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - reply Status, s - sia Status 
 

P 6.6.6.6/32, 1 successors, FD is 2346496

         via 192.168.2.1 (2346496/128256), Serial0/0

P 10.11.0.0/16, 1 successors, FD is 2372096

         via 192.168.2.6 (2372096/2346496), Ethernet0/0

P 10.11.0.0/21, 1 successors, FD is 2346496

         via 192.168.2.1 (2346496/128256), Serial0/0

P 10.13.4.0/24, 1 successors, FD is 128256

         via Rconnected (128256/0)

P 10.13.3.0/24, 1 successors, FD is 128256

         via Rconnected (128256/0)

P 10.13.2.0/24, 1 successors, FD is 128256

         via Rconnected (128256/0)

P 10.13.1.0/24, 1 successors, FD is 128256

         via Rconnected (128256/0)

P 10.13.0.0/21, 1 successors, FD is 128256

         via Summary (128256/0), Null0

P 10.13.0.0/24, 1 successors, FD is 128256

         via Rconnected (128256/0)

          

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - reply Status, s - sia Status 
 

P 10.4.0.0/21, 1 successors, FD is 153856

         via 192.168.2.6 (153856/128256), Ethernet0/0

P 192.168.1.0/30, 1 successors, FD is 2244096

         via 192.168.2.6 (2244096/2218496), Ethernet0/0

         via 192.168.2.1 (2730496/2218496), Serial0/0

P 192.168.2.0/30, 1 successors, FD is 2178560

         via Connected, Serial0/0

P 192.168.2.4/30, 1 successors, FD is 25856

         via Connected, Ethernet0/0

Router13#

Open in new window

0
Comment
Question by:pseudocyber
  • 8
  • 5
13 Comments
 
LVL 5

Expert Comment

by:ksims1129
ID: 24391998
I just passed the BSCI a few months ago. Im only one away from my CCNP. No to see if i can explain this for you. you have the ip default-network issued on the router where the network is directly connected. it only works if you would lets say go to Router 13 and issue the command ip default-network 6.0.0.0. You would immedialey see

Gateway of last resort is 192.168.2.1 network 6.0.0.0

If you have any questions let me know.i will also see if i can find somethind on the cisco site to send you.
0
 
LVL 27

Author Comment

by:pseudocyber
ID: 24394101
Hi ksims,

Congrats on passing - I failed a month ago ... :(

Ok - here's me doing what you say and it not working.

I created a loopback, L666
I added an IP to it 6.6.6.6/32
I added network 6.0.0.0/8 to eigrp 100
I verified on router 2, that it got the route for 6.0.0.0 through eigrp
On Router 1, I issued "ip default-network 6.0.0.0" and saw it in the route table, on router1
On Router2 - still no candidate default.

I'm pasting all of this below - first router 1, and then below that router2 with the show ip route at different stages.

Thanks for your help,

PC

Router1#
Router1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#int l666
Router1(config-if)#ip address
*Mar 11 14:54:20.311: %LINK-3-UPDOWN: Interface Loopback666, changed state to up
*Mar 11 14:54:21.313: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback666, changed state to up6.6.6.6 255.255.255.255
Router1(config-if)#^Z
Router1#
*Mar 11 14:54:31.037: %SYS-5-CONFIG_I: Configured from console by console
Router1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     6.0.0.0/32 is subnetted, 1 subnets
C       6.6.6.6 is directly connected, Loopback666
     10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
C       10.11.1.0/24 is directly connected, Loopback1
C       10.11.0.0/24 is directly connected, Loopback0
D       10.11.0.0/21 is a summary, 18:07:40, Null0
D       10.11.0.0/16 is a summary, 18:07:40, Null0
C       10.11.3.0/24 is directly connected, Loopback3
C       10.11.2.0/24 is directly connected, Loopback2
C       10.11.4.0/24 is directly connected, Loopback4
D       10.13.0.0/21 [90/2346496] via 192.168.2.2, 18:07:42, Serial0/0
D       10.4.0.0/21 [90/2346496] via 192.168.1.2, 18:07:42, Serial0/1
     192.168.1.0/30 is subnetted, 1 subnets
C       192.168.1.0 is directly connected, Serial0/1
     192.168.2.0/30 is subnetted, 2 subnets
C       192.168.2.0 is directly connected, Serial0/0
D       192.168.2.4 [90/2244096] via 192.168.2.2, 18:07:44, Serial0/0
                    [90/2244096] via 192.168.1.2, 18:07:43, Serial0/1
Router1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#ip eigrp 100
                    ^
% Invalid input detected at '^' marker.

Router1(config)#ip eigrp 100
                    ^
% Invalid input detected at '^' marker.

Router1(config)#router eigrp 100
Router1(config-router)#network 6.0.0.0
Router1(config-router)#^Z
Router1#
*Mar 11 14:55:08.518: %SYS-5-CONFIG_I: Configured from console by console
Router1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     6.0.0.0/32 is subnetted, 1 subnets
C       6.6.6.6 is directly connected, Loopback666
     10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
C       10.11.1.0/24 is directly connected, Loopback1
C       10.11.0.0/24 is directly connected, Loopback0
D       10.11.0.0/21 is a summary, 18:08:17, Null0
D       10.11.0.0/16 is a summary, 18:08:17, Null0
C       10.11.3.0/24 is directly connected, Loopback3
C       10.11.2.0/24 is directly connected, Loopback2
C       10.11.4.0/24 is directly connected, Loopback4
D       10.13.0.0/21 [90/2346496] via 192.168.2.2, 18:08:19, Serial0/0
D       10.4.0.0/21 [90/2346496] via 192.168.1.2, 18:08:19, Serial0/1
     192.168.1.0/30 is subnetted, 1 subnets
C       192.168.1.0 is directly connected, Serial0/1
     192.168.2.0/30 is subnetted, 2 subnets
C       192.168.2.0 is directly connected, Serial0/0
D       192.168.2.4 [90/2244096] via 192.168.2.2, 18:08:20, Serial0/0
                    [90/2244096] via 192.168.1.2, 18:08:20, Serial0/1
Router1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#ip default-net
Router1(config)#ip default-network ?
  A.B.C.D  IP address of default network

Router1(config)#ip default-network 6.0.0.0 ?
  <cr>

Router1(config)#ip default-network 6.0.0.0
Router1(config)#^Z
Router1#
Router1#show
*Mar 11 14:55:42.197: %SYS-5-CONFIG_I: Configured from console by console ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

 *   6.0.0.0/32 is subnetted, 1 subnets
C       6.6.6.6 is directly connected, Loopback666
     10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
C       10.11.1.0/24 is directly connected, Loopback1
C       10.11.0.0/24 is directly connected, Loopback0
D       10.11.0.0/21 is a summary, 18:08:50, Null0
D       10.11.0.0/16 is a summary, 18:08:49, Null0
C       10.11.3.0/24 is directly connected, Loopback3
C       10.11.2.0/24 is directly connected, Loopback2
C       10.11.4.0/24 is directly connected, Loopback4
D       10.13.0.0/21 [90/2346496] via 192.168.2.2, 18:08:52, Serial0/0
D       10.4.0.0/21 [90/2346496] via 192.168.1.2, 18:08:52, Serial0/1
     192.168.1.0/30 is subnetted, 1 subnets
C       192.168.1.0 is directly connected, Serial0/1
     192.168.2.0/30 is subnetted, 2 subnets
C       192.168.2.0 is directly connected, Serial0/0
D       192.168.2.4 [90/2244096] via 192.168.2.2, 18:08:52, Serial0/0
                    [90/2244096] via 192.168.1.2, 18:08:52, Serial0/1
Router1#

-----------------------------------------------------------------------------------------------

Router2#show ip rout
1w1d: %SYS-5-CONFIG_I: Configured from console by consolee
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
D       10.11.0.0/16 [90/2372096] via 192.168.2.6, 18:06:47, Ethernet0/0
D       10.11.0.0/21 [90/2346496] via 192.168.2.1, 18:06:47, Serial0/0
C       10.13.4.0/24 is directly connected, Loopback4
C       10.13.3.0/24 is directly connected, Loopback3
C       10.13.2.0/24 is directly connected, Loopback2
C       10.13.1.0/24 is directly connected, Loopback1
D       10.13.0.0/21 is a summary, 23:09:46, Null0
C       10.13.0.0/24 is directly connected, Loopback0
D       10.4.0.0/21 [90/153856] via 192.168.2.6, 18:06:49, Ethernet0/0
     192.168.1.0/30 is subnetted, 1 subnets
D       192.168.1.0 [90/2244096] via 192.168.2.6, 18:06:51, Ethernet0/0
     192.168.2.0/30 is subnetted, 2 subnets
C       192.168.2.0 is directly connected, Serial0/0
C       192.168.2.4 is directly connected, Ethernet0/0
Router2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     6.0.0.0/32 is subnetted, 1 subnets
D       6.6.6.6 [90/2346496] via 192.168.2.1, 00:00:16, Serial0/0
     10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
D       10.11.0.0/16 [90/2372096] via 192.168.2.6, 18:08:27, Ethernet0/0
D       10.11.0.0/21 [90/2346496] via 192.168.2.1, 18:08:27, Serial0/0
C       10.13.4.0/24 is directly connected, Loopback4
C       10.13.3.0/24 is directly connected, Loopback3
C       10.13.2.0/24 is directly connected, Loopback2
C       10.13.1.0/24 is directly connected, Loopback1
D       10.13.0.0/21 is a summary, 23:11:26, Null0
C       10.13.0.0/24 is directly connected, Loopback0
D       10.4.0.0/21 [90/153856] via 192.168.2.6, 18:08:29, Ethernet0/0
     192.168.1.0/30 is subnetted, 1 subnets
D       192.168.1.0 [90/2244096] via 192.168.2.6, 18:08:32, Ethernet0/0
     192.168.2.0/30 is subnetted, 2 subnets
C       192.168.2.0 is directly connected, Serial0/0
C       192.168.2.4 is directly connected, Ethernet0/0
Router2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     6.0.0.0/32 is subnetted, 1 subnets
D       6.6.6.6 [90/2346496] via 192.168.2.1, 00:00:46, Serial0/0
     10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
D       10.11.0.0/16 [90/2372096] via 192.168.2.6, 18:08:57, Ethernet0/0
D       10.11.0.0/21 [90/2346496] via 192.168.2.1, 18:08:57, Serial0/0
C       10.13.4.0/24 is directly connected, Loopback4
C       10.13.3.0/24 is directly connected, Loopback3
C       10.13.2.0/24 is directly connected, Loopback2
C       10.13.1.0/24 is directly connected, Loopback1
D       10.13.0.0/21 is a summary, 23:11:57, Null0
C       10.13.0.0/24 is directly connected, Loopback0
D       10.4.0.0/21 [90/153856] via 192.168.2.6, 18:08:59, Ethernet0/0
     192.168.1.0/30 is subnetted, 1 subnets
D       192.168.1.0 [90/2244096] via 192.168.2.6, 18:09:02, Ethernet0/0
     192.168.2.0/30 is subnetted, 2 subnets
C       192.168.2.0 is directly connected, Serial0/0
C       192.168.2.4 is directly connected, Ethernet0/0
Router2#
0
 
LVL 5

Expert Comment

by:ksims1129
ID: 24394273
thats not what i said.
Router11(config)#ip default-network 6.0.0.0

Router13(config)#ip default-network 6.0.0.0

you have to issue the command on every router that you want to use 6.0.0.0 network as the default network.
0
 
LVL 27

Author Comment

by:pseudocyber
ID: 24394532
You do!?!?

I thought it's supposed to propagate through the EIRGP domain.

"A router configured with this command considers the network-number the last-resort gateway that it will announce to other routers.  The network must be reachable by the router that uses this command before it announces it as a candidate default route to other EIGRP routers.  The network number in this command must also be passed to other EIGRP routers so that those routers can use this network as their default network and set their gateway of last resort to this default network."

If I have to go issue this command on every single router - why wouldn't I just manually set the default gateway while I'm there?

Plus, ..."Multiple default networks can be configured:  downstream routers then use the EIGRP metric to determine the best default route".

It sounds to me like this command is used near the Internet edge of the network - then the rest of the EIGRP domain learns of it.
0
 
LVL 5

Expert Comment

by:ksims1129
ID: 24394559
Yes you do. It does not propagate the route in EIGRP. the only way to redistribute it is to use the command Router(Config-router)#redistribute static
this will inject any static routes you have configured. you can use route maps to make sure the right static routes get redistributed.I dont know of any other way. If someone does please chime in.
0
 
LVL 27

Author Comment

by:pseudocyber
ID: 24394619
Well, while we're waiting on others to chime in ... ;)

You can configure a default route at your edge - like 0.0.0.0 0.0.0.0 next hop x.  Then, if you go into EIGRP and advertise network 0.0.0.0 - all your other EIGRP routers will learn about the default route that way - but that's not using the command - it's "cheating". :)

Still - it really looks to me like this command is supposed to propogate.


0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 
LVL 27

Author Comment

by:pseudocyber
ID: 24394626
Ok, I found this:

"Gateways of last resort selected using the ip default-network command are propagated differently depending on which routing protocol is propagating the default route. For IGRP and EIGRP to propagate the route, the network specified by the ip default-network command must be known to IGRP or EIGRP. This means the network must be an IGRP- or EIGRP-derived network in the routing table, or the static route used to generate the route to the network must be redistributed into IGRP or EIGRP, or advertised into these protocols using the network command"

Here:  http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094374.shtml
0
 
LVL 5

Expert Comment

by:ksims1129
ID: 24394645
ok. that sounds how i learned it. So, The best way to do it is redistribute the static route
0
 
LVL 27

Author Comment

by:pseudocyber
ID: 24394677
So... you think I'm making a moutain out of a mole hill?  The way I'm doing the command is correct - and should work - and to move on? ;)
0
 
LVL 5

Accepted Solution

by:
ksims1129 earned 500 total points
ID: 24394696
yes. i would move on trust me this won't be your last problems such as this you will run into things like this all the time. the only way to learn it is to do it. Stay in the lab and keep working hard. GOOD LUCK!!!
0
 
LVL 27

Author Comment

by:pseudocyber
ID: 24394706
Thanks!  :)
0
 
LVL 27

Author Closing Comment

by:pseudocyber
ID: 31581632
Thanks.
0
 
LVL 27

Author Comment

by:pseudocyber
ID: 24424581
Addendum - turns out my Sr. Engineer found the answer.  The network wasn't being summarized going out the interfaces.  So, the other routers had a more specific route and were choosing it.  Once summarization was put on the interfaces, it worked like a charm.
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

If you are thinking of adopting cloud services, or just curious as to what ‘the cloud’ can offer then the leader according to Gartner for Infrastructure as a Service (IaaS) is Amazon Web Services (AWS).  When I started using AWS I was completely new…
Configuring network clients can be a chore, especially if there are a large number of them or a lot of itinerant users.  DHCP dynamically manages this process, much to the relief of users and administrators alike!
Viewers will learn how to properly install and use Secure Shell (SSH) to work on projects or homework remotely. Download Secure Shell: Follow basic installation instructions: Open Secure Shell and use "Quick Connect" to enter credentials includi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now