Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 520
  • Last Modified:

FTP Issue

I am have Ubuntu 8.10 running among other things VSFTP and VirtualBox with an XP Virtual Machine...everything works fine but when i ftp from the XP command prompt to the host pc i can login but when i do an LS or DIR i get the error below. If i connect from a different computer to the ftp server it works fine..

500 Illegal PORT command
425 Use PORT or PASV first.


Any idea whats going on?
0
akalbfell
Asked:
akalbfell
  • 5
  • 2
1 Solution
 
cevomanCommented:
The server needs to know wheather you want to use a port-mode channel or passive mode channel, most clients do this automatically for you

type 'quote PASV' and it should work fine

kind regards
James
0
 
akalbfellAuthor Commented:
i tried that. when i issue the quote PASV command i get back
227 Entering Passive Mode (127,0,0,1,170,93)

but when i do a DIR or LS i just get a blinking cursor forever
0
 
cevomanCommented:
ok have you tried 'quote PORT' this should induce Active(port) mode
Let me know if you have any luck

Kind regards
James
0
A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

 
akalbfellAuthor Commented:
in regards to the quote PASV command and doing a DIR or LS, after a while i finally get a 425 Failed to establish Connection error

when i do quote PORT i get 500 Illegal PORT command
0
 
Morne LateganCommented:
Open control panel and make sure windows firewall is disabled. The default windows firewall settings have always messed up all my applications that use ftp. Also have a look at your antivirus firewall, if you have one installed. Disable it and try again.
0
 
akalbfellAuthor Commented:
its off already
0
 
akalbfellAuthor Commented:
i switched to proftpd same issue, attached is the output from the log after i login and then issue a dir command...btw the ip of the virtual XP machine is 10.0.2.2

May 15 08:25:42 ubuntulap proftpd[6688] ubuntulap (localhost[127.0.0.1]): FTP session opened.
May 15 08:25:46 ubuntulap proftpd[6688] ubuntulap (localhost[127.0.0.1]): USER xxxxxx: Login successful.
May 15 08:25:49 ubuntulap proftpd[6688] ubuntulap (localhost[127.0.0.1]): Refused PORT 10,0,2,2,170,253 (address mismatch)

Open in new window

0
 
akalbfellAuthor Commented:
i was able to resolve the issue, for the most part.
I updated to a newer version of Virtualbox that supports bridging out of the box. When i setup like this the virtual machine gets its own Ip and everything works fine. just have to figure out how to get the virtual machine to communicate with the host if no DHCP server is available.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Build your data science skills into a career

Are you ready to take your data science career to the next step, or break into data science? With Springboard’s Data Science Career Track, you’ll master data science topics, have personalized career guidance, weekly calls with a data science expert, and a job guarantee.

  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now