• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 401
  • Last Modified:

Cisco 1841 with T1 Hosting Web need help routing Net traffic In to web server

We just transitioned from a DSL internet connection to a T1 and a Cisco router on the T1.  We tested out and got to the Internet and everything is great except that nobody can get into our network.  We have the T1 going into the Cisco 1841 then to a Sonicwall Firewall that does Nat for our external IPs to internal IPs on our 192 internal subnet.
I have only been gleening commands here and there form posts to figure out what to throw on this router up to this point.

Please help us make this right.   So our internal firewall is on the xxx.xxx.9.194 same subnet as the FastEthernet interface  and we want all traffic coming in to that subnet to go to that ethernet subnet.  Eventually I will add restrictions, but the Sonicwall does the job for us at the moment.

Any other suggestions would be appreciated.

Thanks in advance.... hopefully a quick response will get our sites back up.

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname Router1841
!
boot-start-marker
boot-end-marker
!
enable password password
!
no aaa new-model
!
resource policy
!
ip cef
username user privilege 15 password 0 password
!
!
interface FastEthernet0/0
 description Eth0
 ip address xxx.xxx.9.193 255.255.255.248
 ip nat inside
 speed auto
 half-duplex
 no mop enabled
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 description TWT1
 ip address xxx.xxx.58.134 255.255.255.252
 ip nat outside
 encapsulation ppp
 service-module t1 timeslots 1-24
 service-module t1 remote-alarm-enable
!
ip route 0.0.0.0 0.0.0.0 xxx.xxx.58.133
ip route xxx.xxx.9.192 255.255.255.248 FastEthernet0/0
!
ip http server
ip http authentication local
ip nat inside source list 1 interface Serial0/0/0 overload
!
!
access-list 1 permit any
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 exec-timeout 90 0
 password password
 login
 transport preferred none
 transport input telnet
!
scheduler allocate 20000 1000
end

Open in new window

0
espeterson
Asked:
espeterson
1 Solution
 
JFrederick29Commented:
Remove NAT and the following route as the Sonicwall is handling NAT.

no ip route xxx.xxx.9.192 255.255.255.248 FastEthernet0/0
no ip nat inside source list 1 interface Serial0/0/0 overload

The rest of the config is fine.  Your ISP will route the xxx.xxx.9.192/29 subnet to your serial interface and the Cisco will then route it to the sonicwall.  No NAT is required.  If you are still unable to communicate to your public IP's on the Sonicwall after removing NAT, call your ISP and make sure they are routing xxx.xxx.9.192/29 to you via xxx.xxx.58.134.
0
 
espetersonAuthor Commented:
Thanks a lot, I finally figured out the nat inside was wrong and fixed that and I appreciate the other comments
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Tackle projects and never again get stuck behind a technical roadblock.
Join Now