Solved

Why is NVI0 interface shutdown on Cisco 877-M

Posted on 2009-05-14
17
11,726 Views
Last Modified: 2012-06-27
I've a Cisco 877-M router, just wondering why does the NVI0 interface always remain in shutdown state. I've just configured the router and not plugged in the ADSL link. Upon show ip int brief, NVI shows administratively shutdown. Any reason ?
0
Comment
Question by:nabeel92
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 7
  • 2
  • +1
17 Comments
 
LVL 7

Expert Comment

by:LANm0nk3y
ID: 24391605
0
 

Author Comment

by:nabeel92
ID: 24391615
hmm...yeah, but it doesnt explain why the interface would be in shutdown state ...
0
 
LVL 7

Expert Comment

by:LANm0nk3y
ID: 24391627
I don't think you need it up to make NAT work.  I just set up an 1811, and it's not up.  It's just a virtual interface that cisco probably use so that the IP translation can happen.
0
How Do You Stack Up Against Your Peers?

With today’s modern enterprise so dependent on digital infrastructures, the impact of major incidents has increased dramatically. Grab the report now to gain insight into how your organization ranks against your peers and learn best-in-class strategies to resolve incidents.

 
LVL 7

Expert Comment

by:LANm0nk3y
ID: 24391640
This is from the same document i just sent you:

The NAT Virtual Interface (NVI) feature removes the requirement to configure an interface as either Network Address Translation (NAT) inside or NAT outside. An interface can be configured to use NAT or not use NAT. 
 
NVI allows traffic between overlapped VPN routing/forwarding (VRFs) in the same Provider Edge (PE) router, and traffic from inside to inside between overlapping networks. 
 
History for the NAT Virtual Interface Feature

Open in new window

0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 24391646
The NAT Virtual Interface (NVI) will be down until you configure NAT using the NVI method "ip nat enable".  This is normal.
0
 

Author Comment

by:nabeel92
ID: 24391653
Thanks.
So do I need to issue "Ip nat enable" command or just the router as it is.

Currently, the NAT related commands on the router are

interface vlan 1
ip nat inside

interfave dialer1
ip nat outside

ip nat inside source list 101 interface dialer1 overload
access-list 101 permit ip any any
0
 
LVL 7

Expert Comment

by:LANm0nk3y
ID: 24391665
It's better if you show the sh run.  Without seeinng interfaces it's a little harder to do this.  the VLAN1 interface does not look correct.
0
 

Author Comment

by:nabeel92
ID: 24391677
GG-MelbRtr1#sh running-config
Building configuration...

Current configuration : 2170 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname GG-MelbRtr1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
!
dot11 syslog
ip cef
!
!
ip name-server 139.130.4.4
!
!
!
username admin privilege 15 password 0 xxx
!
!
archive
 log config
  hidekeys
!
!
!
track 1 rtr 1 reachability
!
track 2 rtr 2 reachability
!
track 3 list boolean or
 object 1
 object 2
!
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 8/35
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl operating-mode auto
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 ip address 10.153.25.121 255.255.255.128
 ip nat inside
 ip virtual-reassembly
 glbp 1 ip 10.153.25.126
 glbp 1 preempt delay minimum 30
 glbp 1 weighting 100 lower 95
 glbp 1 load-balancing host-dependent
 glbp 1 weighting track 3 decrement 10
 glbp 1 forwarder preempt delay minimum 0
!
interface Dialer1
 description -- ADSL to Telstra --
 bandwidth 1000
 ip address negotiated
 ip mtu 1440
 ip flow ingress
 ip flow egress
 ip nat outside
 no ip virtual-reassembly
 encapsulation ppp
 ip route-cache flow
 dialer pool 1
 dialer idle-timeout 0
 dialer persistent
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname xxx
 ppp chap password 0 xxx
 ppp ipcp dns request
 ppp ipcp route default
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 10.153.25.0 255.255.255.128 10.150.7.101
!
no ip http server
no ip http secure-server
ip nat inside source list 101 interface Dialer1 overload
ip nat inside source static tcp 10.150.7.101 22 interface Dialer1 222
!
ip sla 1
 icmp-echo 4.2.2.2 source-interface Vlan1
 frequency 10
ip sla schedule 1 life forever start-time now
ip sla 2
 icmp-echo 4.2.2.3 source-interface Vlan1
 frequency 10
ip sla schedule 2 life forever start-time now
access-list 101 permit ip any any
!
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 login local
!
scheduler max-task-time 5000
end

0
 
LVL 7

Expert Comment

by:LANm0nk3y
ID: 24391751
Hmm... I wonder if it's because you have "no ip virtual-reassembly"  As far as your nat config, it looks ok.  I think you need ip virtual-reassembly on the dialer1 interface.
0
 

Author Comment

by:nabeel92
ID: 24391756
just enabled it, didnt made a difference !
0
 
LVL 7

Expert Comment

by:LANm0nk3y
ID: 24391782
what shows up if you do:

sh ip int br
0
 

Author Comment

by:nabeel92
ID: 24391804
Interface                  IP-Address            OK? Method Status                Protocol
FastEthernet0              unassigned       YES unset  up                    down
FastEthernet1              unassigned       YES unset  up                    down
FastEthernet2              unassigned       YES unset  up                    down
FastEthernet3              unassigned       YES unset  up                    down
ATM0                           unassigned       YES NVRAM  initializing          down
Vlan1                         10.153.25.122     YES NVRAM  up                    down
NVI0                              unassigned      YES unset  administratively down down
Dialer1                           unassigned      YES NVRAM  up                    up
Virtual-Access1            unassigned      YES unset  up                    up
0
 

Author Comment

by:nabeel92
ID: 24391813
Well I've configured everything correctly that i know for sure ... And usually when ADSL line is connected to the router, a new virtual-interface by the name of "Virtual-access 2" comes up which usually gets the Dialer I.P address. But i was just curious as to why this particular interface would be donw ?
0
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 500 total points
ID: 24391814
Your config is fine.  The NVI is only used when using "domain-less" NAT.  It is normal to have the NVI shutdown when not using NVI.  Are you having an issue or you are just curious on why NVI is down?
0
 

Author Comment

by:nabeel92
ID: 24391823
Ohh ok ......
0
 
LVL 7

Expert Comment

by:LANm0nk3y
ID: 24391868
I'm so sorry, I thought you were having problem with the internet or something. So sorry.
0
 

Expert Comment

by:Runnex
ID: 37048963
Hi Sir,

Good day to you. Mine also have this NVI0 interface was in administrative down. May i know how to bring it up. Actually i am restore the old cisco 887 router config to new cisco 887 router. but in the show ip int brief of the old router, this nvi0 interface is up. so i believe the new router not function well due to this interface (administrative down). Thanks Please help...(URGENT)
0

Featured Post

Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
NetCrunch network monitor is a highly extensive platform for network monitoring and alert generation. In this video you'll see a live demo of NetCrunch with most notable features explained in a walk-through manner. You'll also get to know the philos…
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…

724 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question