• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1398
  • Last Modified:

Apache 2.0.63: not listening on 443

I need some help.. I copied the ssl.conf and httpd.conf from an existing server, X. this new server is supposed to be a duplicate of X. They are on Solaris 10.
Somehow, I cannot get it to listen on 443. This is most frustrating. How do I troubleshoot it?

Also, if I want to make Apache listen on SSL only, is there a way? I am redirecting all port 80 traffic to 443 now.
0
QLJ
Asked:
QLJ
  • 6
  • 5
1 Solution
 
giltjrCommented:
Is there something else already listening on port 443?  Any errors either in Sun's logs or apache's logs?

You can follow the directions at:

     http://www.cyberciti.biz/tips/howto-apache-force-https-secure-connections.html

to force port 80 traffic to port 443.
0
 
QLJAuthor Commented:
Yup, I was already redirecting port 80 traffic. But i wanted to close port 80 totally. Only listen on 443.
Can this be done?

I dont seem to find any tell tale signs... is there a way to check if the packaged Apache comes with SSL support?
0
 
giltjrCommented:
Where did you get the package?  I fairly sure that most packages of Apache to day for any *nix platform comes with SSL support compiled in already.

To have apache not listen on port 80 in httpd.conf code listen 443 only.  Don't code listen 80.

0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
QLJAuthor Commented:
The apache came pre-installed with the Solaris 10.

All else works fine, until I enable the "Redirect permanent" to 443.
0
 
QLJAuthor Commented:
I forgot to add, SSL has been enabled on ssl.conf (LISTEN 443), but when I do a netstat -an, I realised that it 443 is not listening
0
 
giltjrCommented:
Do you have mod_ssl?
0
 
giltjrCommented:
0
 
QLJAuthor Commented:
giltjr,
yes to both.
0
 
QLJAuthor Commented:
up point value due to increased urgency
0
 
giltjrCommented:
What errors or problems did you run into?
0
 
QLJAuthor Commented:
ok, got it...
aparently there were some issues with the ssl cert. keeps prompting for passphrase...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 6
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now