Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 8709
  • Last Modified:

Why does a HP Vista laptop need a PIN to connect to the wifi router?

I have a new HP Vista laptop and every time I want to connect to a wireless network it wants to know the PIN number on the bottom of the router. I've never seen this before and I would like to disable it.

If I choose the option "I don't want to configure this network now; I just want to connect" it says it can't connect and asks me to choose another network. All other computers (with XP and OS X) connect to the network just fine without knowing a PIN number)

I can't find anyone with the same issue searching Google so I'm thinking it's something new or a HP crapware that they installed to make the wireless connection process "easier"

Any help would be greatly appreciated.  I included a screenshot of the message I get.
HP-PIN-Wireless---Copy.JPG
0
bugsbey
Asked:
bugsbey
1 Solution
 
smiffy13Commented:
This has nothing to do with Vista. It has to do with the way you have setup your Belkin router, you've probably enabled "Wi-Fi Protected Setup" (WPS) in your router configuration, it should be off by default.
0
 
bugsbeyAuthor Commented:
That was it.  However, it is On/Enabled by default. I disabled it and it no longer asks for the PIN.
Thanks smiffy13!
0
 
meatloaf204Commented:
the wierd thing is, however, only one laptop asked for the pin at my place. And then, once we put in the pin,the laptop sort of "hijacked" the router. I'm sure it is the router's settings, but it is also Vista. Is there a way to prevent Vista from asking for the PIN? All other laptops never asked for it, which is good. I mean, incase more laptops want to connect to the router, I don't want to give the PIN coz it will hijack the router again
0
 
xzistance3Commented:
The "solution" is not working for me. My dad has this exact same wireless router and by default it uses WPS. I've reset the router, logged in to the router after reset, changed the Wireless Configuration to 'Manual' instead of 'Wi-Fi Protected Setup', but it still asks for the PIN number which is basically 'hijacking' the router SSID, like meatloaf said.

So, really, it's only allowing one wireless connection to be connected to the router at one time, which is ridiculous. How can this be turned off? I don't get it and am really frustrated with it. Is there a way to turn it off on the router itself? Setting up wireless security and access should not be this difficult, I've done it a million times with other Linksys routers.
0
 
xzistance3Commented:
FINALLY got it after about an hour of frustration and searching.

So, by default, my Linksys WRT54G2 V1 router has Wi-Fi Protected Setup enabled. There is a bug with Wi-Fi Protected Setup, at least with this router and Vista computers, that only really allows for 1 wireless connection to be connected at a time. If I tried connecting with a different Vista laptop with Wi-Fi Protected Setup enabled, it asks me for the PIN, and if I follow through with it, it "hijacks" the router and changes the SSID, which then disables the other laptop from connecting, without going through the exact same process.

So, then the other bug is that I logged in to the router, changed Wireless Configuration to 'Manual' (which should disable Wi-Fi Protected Setup), but it did not. It was still asking for the router PIN and doing that whole annoyance.

Sooo, finally, after more searching and thinking, I found a firmware update for my router, upgraded it, and now it works like it should. When I have it set to 'Manual' Wireless Configuration, it no longer asks for the router's PIN, and I was able to successfully connect multiple wireless connections at the same time (which should have been super easy in the first place).

Hope this helps people.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now