Solved

SiI 3114 not recognizing full capacity of RAID 5 array

Posted on 2009-05-14
7
654 Views
Last Modified: 2013-11-14
I have a SiI 3114 SATA RAID pci controller in a Dell Dim 3000. Previously it was configured as a RAID 1 with two Seagate ST31500341AS drives attached. It worked fine. In the RAID config screen, the drives were recognized as having 1397GB and that was the size of the drive.

The problem was when I wanted to add a drive to it making it a RAID 5 array. I added a third Seagate (same model number) and the drives were all correctly recognized, but when I would try to create an Array, it would limit the size to 744GB. I would have thought the capacity would be 2794 (1397 x (3-1)).
Ive tried to flash the bios of the card, but I'm not having luck with that. Anyone have any other ideas. Why it would create such a small array size.  
0
Comment
Question by:msatterlee
  • 4
  • 2
7 Comments
 
LVL 12

Expert Comment

by:Steve
ID: 24392706
if you have 3 x 700mb drives, under RAID 5 you would have a useable 1400mb with striping across all 3 x  drives..

the only reason i can see for such a small raid 5 array would be because you have mismatched drives..

eg one of your drives is a 380gb drive or something and that limited the array to that maximum size.. but as you've stated all the drives are the same..

first thing I'd be doing is reformatting all 3 x drives on the controller.. using the controllers format then try recreated the array..

if it still dosent work contact the vendor to find out why your re-flashing of the card isnt working.. cause obviously there are problems that the new firmware fixes.. maybe this is one of them..

0
 

Author Comment

by:msatterlee
ID: 24392742
I was successful in getting the card's bios updated. The same problem persisted. I'm trying your Format suggestion. Will let you know.
0
 
LVL 70

Accepted Solution

by:
garycase earned 500 total points
ID: 24392963
A few thoughts ...

First, your controller does not support RAID level migration ... so I assume you deleted your RAID 1 array before creating a RAID 5 arrary -- correct?   [I presume you have this, but just in case, here's your manual:  http://www.siliconimage.com/docs/SATARAID5-UserGuide_v1.60.pdf ]

Second, there's a difference between the RAID containers you can create (that will indeed be 2794 GB) and the size of the volumes you can create with XP (or Vista if you're using MBR based disk volumes) -- which will be limited to 2TB.   It sounds like you've created a full 2794GB container; but have one 2TB disk and one 744GB disk.   Note that the 2TB restriction is in "computerese" -- where 1TB = 1024GB instead of the disk-maker's 1000GB -- so the 2TB restriction is 2048MB.   Add this to the 744GB you're seeing and you're at 2792GB.

Does Disk Management show an uninitialized 2TB "disk" ??

If not, you likely need to create 2 RAID-5 volumes -- assign 1000GB of each of the disks for one of the volumes (this will be 2000GB in size); and the rest of each of the disks for the second volume.   Together this will give the full space you expect from the array.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:msatterlee
ID: 24401302
First - Yes, Had to move all the data off the RAID 1 array before doing the RAID 5 setup.

You're definitely onto something, because in the configuration, trying to go above 744GB would give an error message about deleting data. It would then go to 746GB before it would cycle back to 2 GB.
2794-746=2048.
Something else I should add...  the configuration I was doing up to this point was in a 'bios like' screen; not in windows. After the system bios came up, it would say "Hit F4 to enter raid controller config" (something like that).

Also, after setting up the RAID5 array, Disk management would show an unintialized drive of 744GB, but no other drives.

I got the Raid Manager Software (which runs in windows) and after playing around with that, the RAID card bios configuration allows me to setup a 2794GB Raid partition. It's currently doing a 'Restore Redundancy" operation and has yet to show up in Disk management; but I'll keep you informed.
0
 

Author Comment

by:msatterlee
ID: 24402612
I stopped the RAID manager software last night because it seemed like it was doing nothing, but after that, I could never get a drive to show up in Disk Management. So I reinstalled the Raid Manager SW and let it run.  I now see why I thought it was doing nothing. I'd originally thought the count down timer that said 49 was telling me it was going to take 49 minutes, but apparently it's 49 hours. Because this morning, after 8 hours of running, it's on 14% with 42 hours left. Hard to believe the process should take 50 hours, but I'm going to let it run. I'm going to close the question accepting the last suggestion as solution.
0
 
LVL 70

Expert Comment

by:garycase
ID: 24403143
RAID initialization can indeed take a long time.   (Rebuilds are also a very long process with such large drives).    I'm confident you know what the issue is now -- it's just a matter of getting the arrays set correctly ... one 2TB and one for the rest of the space.
0
 

Author Comment

by:msatterlee
ID: 24404410
Actually, it was setting up a 27xxGB array... I just got to a point where I couldn't afford my server to be down anymore. I re-setup the RAID 1 (which initializes immediately) and I'm copying my data back to it. I'll have to figure out a way to setup the RAID 5 array without so much down time. I guess I'll just need to have a couple more of those 1.5TB seagates around.
0

Featured Post

Free Gift Card with Acronis Backup Purchase!

Backup any data in any location: local and remote systems, physical and virtual servers, private and public clouds, Macs and PCs, tablets and mobile devices, & more! For limited time only, buy any Acronis backup products and get a FREE Amazon/Best Buy gift card worth up to $200!

Join & Write a Comment

Bellevue, WA, USA; Late December, 1980 "OK, folks, we nailed the IBM contract. We're going to have many meetings like this to discuss features and functions...and how to move from 86-DOS, the CP/M clone we just purchased, to our baby, MS-DOS. Thi…
this article is a guided solution for most of the common server issues in server hardware tasks we are facing in our routine job works. the topics in the following article covered are, 1) dell hardware raidlevel (Perc) 2) adding HDD 3) how t…
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now