• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 379
  • Last Modified:

Port foreward to an IP Cam

I have a website hosted on a 2003 server using IIS and port redirections to this server from the router using "Port Foreward"
We have added a Canon Webcam with a fixed IP that uses a Java Applet for http access. I have integrated this in a web page which works fine accessing from within the LAN. However there is no external access. I think this is due to the router not forewarding correctly and dns resolution issues.
Normally the camera uses port 80 for htttp. I have changed this to port9000 as the website http is port 80.
I have added a rule in the router to foreward port 9000 to the ip of the Camera, but how does the outside world see this?

I will be forever grateful for any inspiration/resolution on this
0
barra_boy
Asked:
barra_boy
1 Solution
 
WadskiIT DirectorCommented:
http://xxx.xxx.xxx.xxx:9000

just add 9000 to the URL of your IP or your website
0
 
BlazCommented:
Be sure to use your public IP in the web page - not the internal (LAN) IP you are probably using now.
0
 
Kerem ERSOYPresidentCommented:
Hi,

To get the same setup work you from outside you need a reverse proxy but IIS does not support reverse proxying.

What you gonna do is:
- Go modify the html files in your IIS  to get te images from Your_ExternalIP:9000 instead of local ip.
- Go and check if you can reach the camere from http://Your_External_IP:9000
- If you can try to access files from outside and now they should work.

If you still need to access to camera from inside create another isntance of your web site in IIS say w3.internal.domain and access your website using this address. Then the intranet site (w3) will use the internal address version of the cam page that you've modified.

Cheers,
K.
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
barra_boyAuthor Commented:
Thanks for replies, but its the router simply not forewarding, even though I have put in a rule for it.

Its an iconnect 625 so if anyone know anything on these it would be great.
0
 
Kerem ERSOYPresidentCommented:
Ok then it seems that you camera is not properly configured. Please check Camera setup and make sure that it has a Default Gateway setting and the Default Gateway points to your router's internal ethernet interface. Without Default Gateway hosts can only communicate with other hosts which are in the same subnet.
0
 
barra_boyAuthor Commented:
Name resolution was the problem. Thanks everyone for your input.
0

Featured Post

The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now