• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3275
  • Last Modified:

Firefox homepage hijacked by dell.msn.com

Experts...

Cannot change homepage on new Dell Laptop in Firefox 3.0.8.  Every time i reset the home page it resets to http://dell.msn.com.  I have cleared all cookies, uninstalled Windows Live apps with no luck.

I am able to change home page in Explorer but not Firefox.

Any help appreciated.

0
dkiam
Asked:
dkiam
1 Solution
 
khr2003Commented:
I guess clearing all the cookies should do the trick. In any case try to delete all the private information (tools -> clear private data -> tick all the boxes -> clear private data now). If that did not work try to remove firefox and then install it again (download and install the latest version from firefox website)
0
 
TyTechMilwaukeeCommented:
I would download a program call "Hijack This" from Trend Micro. You can get it from CNET.

Run this program and post the output back to this thread. From there I should be able to tell you which line(s) to check off and select the fix button on. Most likely it is a Browser Helper Object (BHO) that is resetting your home page.
0
 
torimarCommented:
This is no malware (so no need to run Hijack This), and there are no Browser Helper Objects for Firefox.

Your preferences got locked by Dell. Make sure Firefox is not running, and try these methods:
1. Go to your Firefox profiles folder by pressing WinKey + r (or select Start > Run), then typing:
%appdata%\mozilla\firefox\profiles  
hit Enter; you will see your profiles folder named "xxxxxxxx.default" (the x being random characters). Open the folder and check for the existence of a "user.js" file. If found, rename the file or delete it.

2. While in the profiles folder, right-click the "prefs.js" file (and the "prefs.js.moztmp" if it exists), select 'Properties' and check whether the file attributes are set to 'read-only'. If they are, remove the attribute.

3. Start Firefox and try resetting your HP again.

4. I f your HP still resets to the Dell default, check whether the "Dell Network Assistant" is running in the background. Disable it and try again.

5. If still no joy, check this page for other options that might apply to your case:
http://kb.mozillazine.org/Preferences_not_saved
0
 
dkiamAuthor Commented:
Thanks torimar, you nailed the problem.

Steps 1-4 found no joy. Control was regained by manually editing the homepage address in prefs.js.  I am guessing this edit fixed a corruption issue in prefs.js file as I can once again change homepage in Firefox preferences.
0
 
clemexCommented:
Hi. I had a similar problem with seeearch.com.

After cleaning my pc with all possible tools, this site was always coming back as home page.
I did not find reference to seeearch.com on your site but found many on other sites and tried about everything without success.
However, the problem was finally solved by deleting two files in <...AppData/roaming/mozilla/firefox/profiles/w87apyrh.default> sessionstore.js and user.js
Both contained only re-directions to seeearch.com...
I had the idea of looking their content afterI reading on this page that prefs.js file might be corrupted.
Then I changed the homepage in prefs.js (which, in my case, was not read-only).
If this might help somebody else...
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now