Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

autodiscover http status code 301

Posted on 2009-05-15
4
Medium Priority
?
2,291 Views
Last Modified: 2012-08-13
Autodiscover is not functioning, and therefore my resource mailboxes.

The autodiscover Error is confounding me.
Here's the response from autodiscover test:

Attempting URL https://mymailserver.mydomain.com/Autodiscover/Autodiscover.xml found through SCP
Autodiscover to https://mymailserver.mydomain.com/Autodiscover/Autodiscover.xml starting
Autodiscover request completed with a http status code 301
Autodiscover to https://mymailserver.mydomain.com/Autodiscover/Autodiscover.xml FAILED (0x80004005)

The autodiscover placeholder is all that's in the autodiscover.xml :
<?xml version="1.0" encoding="utf-8"?>
<Autodiscover>
<!-- This is a placeholder file -->
</Autodiscover>

But for all intents and purposes this seems correct.

Server is 2008 IIs7

0
Comment
Question by:i8yurdog
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 11

Expert Comment

by:kyodai
ID: 24398232
Try to force outlook to use public folders, that should fix it. Add this reg key to the client:

HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Options\Calendar
Value Type: DWORD
Value Name: UseLegacyFB
Values:0 or not set (default behavior which is to use the Availability Service) or 1 (use Public Folder based Free/Busy information)


(You need to set it to 1 for public folder usage)
0
 

Author Comment

by:i8yurdog
ID: 24398975
This would be viable, except I have 1000 random clients, both attached and unattached to the domain. It's a but hairy to apply a registry hack to everyone.
0
 
LVL 65

Expert Comment

by:Mestha
ID: 24399984
Autodiscover should work, so make registry hacks is just working around the problem, not fixing it.

I would suggest that you go through this article to start with:
http://www.exchange-genie.com/2007/07/exchange-2007-autodiscover-service-part-1/

Ensure that it is configured correctly.

Simon.
0
 

Accepted Solution

by:
i8yurdog earned 0 total points
ID: 24727309
This problem turned out to be due to a redirect, implemented in IIS7 that was set up to redirect to https. Cleared up the redirect and location THEN had the correct permissions to serve as autodetect local.
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Are you an Exchange administrator employed with an organization? And, have you encountered a corrupt Exchange database due to which you are not able to open its EDB file. This article will explain all the steps to repair corrupt Exchange database.
Want to know how to use Exchange Server Eseutil command? Go through this article as it gives you the know-how.
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
Suggested Courses

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question