Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5533
  • Last Modified:

Disable Automatic Update Notficiations on a Terminal Server -- Registry Fix

Hey there!

I have a terminal server that multiple users remote into to carry out their tasks and I just discovered that they are being notified when Automatic Updates has updates available. I remember reading an article describing a method for disabling Automatic Update notifications for all users on a terminal server except administrators via a registry fix. Anybody know what I am talking about?
0
GigiJK
Asked:
GigiJK
  • 4
  • 2
1 Solution
 
DonNetwork AdministratorCommented:
Disable the following:
Allow Non-administrators to Receive Update Notifications
 
http://technet.microsoft.com/en-us/library/cc720539.aspx

This policy specifies whether logged-on non-administrative users will receive update notifications based on the configuration settings for Automatic Updates. If Automatic Updates is configured, by policy or locally, to notify the user either before downloading or only before installation, these notifications will be offered to any non-administrator who logs onto the computer.
If the status is set to Enabled, Automatic Updates will include non-administrators when determining which logged-on user should receive notification.
If the status is set to Disabled or Not Configured, Automatic Updates will notify only logged-on administrators.
0
 
GigiJKAuthor Commented:
Ok so I'm guessing there is not a registry fix that does fix this? So I did go ahead and make changes to the local policy of the terminal server. Now is there a way to disable the notifications that the computer needs to be restarted if I have the automatic restart feature for automatic updates disabled?
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
DonNetwork AdministratorCommented:
You could
 
Either enable No auto-restart for schedule Automatic Updates installations or set Re-prompt for restart with scheduled installations to a long time interval, like 1440 minutes.  
 
or you could try what's mentioned here:
http://www.eggheadcafe.com/forumarchives/windowsserverupdate_services/mar2006/post26154914.asp 
Removing access to wuauclt.exe and wuauclt1.exe for the non-admins
0
 
GigiJKAuthor Commented:
I created 2 policies.  one that did not prompt for windows updates for non-administratorsm, applied to the OU for terminal servers.  and the one in which it does prompt for normal users, desktops, laptops
0
 
DonNetwork AdministratorCommented:
"It worked" ???? what worked??? The suggestions given to you???
0
 
DonNetwork AdministratorCommented:
"2 policies were created.  I clicked accept my comment as solution.  I figured it out on my own.  a policy was set to the OU that our terminal servers were in to not prompt with automatic updates to non-adminstrators."



I object that you figured it out on your own as I provided you with the following ID:24398071



Disable the following:Allow Non-administrators to Receive Update Notifications

among other recommendations.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now