Outgoing Email issues on a virtual server with SBS 2003 after change of ISP

After changing ISPs, I had to change settings on the smtp connector on the virtual server to get emails to flow out.  I reran the CEICW once the ISP changed.  The mail record was also forwarded to the new static IP.  Incoming email has not been an issue.

I had to click "Use DNS to route to each address space on this connector" and  to "allow public folder referrals".  Before I had "forward all mail through.. smart host" .  When I changed it to the new static IP from the ISP, outgoing email was returned by the system administrator - "you do not have permissions".  The connector went to "retry" status.   What do I need to look for?
Ron BaackPresidentAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
cwalter9Connect With a Mentor Commented:
Your ISP needs to permit your server/domain to route through it. Most SMTP relay servers use some protection to prevent spammers from using their relay as hop spot. The reason you can send mail directly is because you are opening a connection to each mail server individually and sending your email. The other way with a smarthost is to send all email to one particular server so that it can relay your email for you. The smarthost is normally only used if your server is behind a firewall and can't connect directly on port 25.

You have 2 options here:

1. Run the way you are setup now and deliver email directly. That is how most companies will do it unless you can't open port 25 connections directly.
2. Contact your ISP and have them check why their SMTP relay is giving you a permission denied when you try to relay thru it.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.