Solved

How do I create a VLAN between DELL PowerConnect 6248 and Cisco 3012 Switch

Posted on 2009-05-15
12
2,185 Views
Last Modified: 2012-05-07
Recently I have run out of IP addresses on my main subnet and now I am using two different subnets on the same LAN. Not being the ideal setup, I would like to create two vlans, one for my 192.168.1.0 (main subnet) and the other for a 192.198.2.0 (secondary subnet).

I currently have two Dell Powerconnect 6248 that i am going to stack and connect to Cisco 3012 switches. I would like to create 2 vlans for both subnets on the stack and make it my core switch. My curent setup is not ideal in which I have one of the Dell switches on the 192.168.1.0 to service my main subnet and the other Dell Switch on the 192.168.2.0 to service the secondary subnet. The switches are directly connected and can communicate just fine, but since they are Layer switches I am not utliizing the routing capability as designed.

Since this is my first time setting up a vlan, i need a little assistance. I understand the general idea that one of the ports on each switch needs to be designated as a trunk port and that the ports in the vlan need to be designated, but i do not know how to make it all happen. Please help. Thanks,
0
Comment
Question by:beargonefishing
  • 7
  • 5
12 Comments
 
LVL 5

Expert Comment

by:ksims1129
ID: 24400688
to setup a vlan on a dell switch all you have to do is issue the following commands on both switches under config mode

vlan database
vlan 10
vlan 20
exit

once you get them setup you have to define one or a group of ports to act as a trunk. to do this use the following commands in config mode

interface ethernet g48
switchport mode trunk
switchport trunk allowed vlan add all

Once you complete that on both switches you have to begin define what ports belong to which vlan. for example if you want port 1 to be in vlan 20 you would issue the following

interface ethernet g1
 switchport mode access
 switchport access vlan 20

Hope this helps.

0
 

Author Comment

by:beargonefishing
ID: 24400734
That is what i have done so far in my test environment. How do I configure the cisco end of the equation. Also, do I need to create separate subnets for these vlans that are different than my main and secondary subnets.
0
 
LVL 5

Accepted Solution

by:
ksims1129 earned 500 total points
ID: 24400761
on the cisco switch connect another cable from either dell switch to a interface and issue the following commands under the port you connected to the dell switch

depending on the software on the cisco switch you under privilege mode type
vlan database
 vlan 10
 vlan 20
exit
 or under global config mode

vlan 10
vlan 20
exit

interface gigabit 3/3
 switchport mode trunk
 switchport trunk allow vlan all
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:beargonefishing
ID: 24402988
Do i need to create separate subnets that are diffferent than the management interfaces on the switch for these vlans.
0
 
LVL 5

Expert Comment

by:ksims1129
ID: 24404414
you can setup management on any of the current subnets you have or you can create a new vlan and subnet for managemnt traffic the choice is yours
0
 

Author Comment

by:beargonefishing
ID: 24404419
But my question is can i create the two vlans without creating additional subnets for them. Just have everything including the vlans on the 192.168.1.0 and 192.168.2.0 subnets.
0
 
LVL 5

Expert Comment

by:ksims1129
ID: 24404491
yes vlans are just used to break up braodcast domain. you can have your network run as before inside of one vlan if you want.
0
 

Author Comment

by:beargonefishing
ID: 24412648
OK, let me try those steps in my test lab and i will let you know how it goes.
0
 

Author Comment

by:beargonefishing
ID: 24422242
Ok, I am creating this setup between one DELL 6248 and a Cisco 2950 in my test lab before i tackle the production ones. Here is my syntax so far:

DELL
******
vlan database
vlan 121
vlan 124
exit

interface ethernet 1/g1
switchport mode trunk
switchport trunk allowed vlan 121,124
exit

interface ethernet 1/g43
switchport access vlan 124
exit

interface ethernet 1/g45
switchport access vlan 121
exit


Cisco
******
interface fa0/1
switchport mode trunk
exit

vlan 121
vlan 124
exit

interface fa0/1
switchport trunk allowed vlan all

interface fa0/24
switchport access vlan 124
exit


Still having issues communicating across the switches. Can ping the PCs within the vlan on the same switch just fine, just not between the switches.




0
 
LVL 5

Expert Comment

by:ksims1129
ID: 24422875
on cisco switch type

interface FastEthernet 0/1
switchport trunk encapsulation dot1q

If that doesnt work include the output of the following command in your next post

Cisco
show interface FastEthernet 0/1 switchport
show interface FastEthernet 0/1 trunk

Dell

show interface switchport ethernet g45

good luck


0
 

Author Comment

by:beargonefishing
ID: 24423224
Ok, I got something working here. A PC plugged into the Cisco switch is on VLAN 124 on the 192.168.
2.0 network and able to communicate with a PC on the other side which is also on the 192.168.2.0 network plugged into the Dell switch.

Now how do i get a PC in VLAN 121 - 192.168.1.0 network to communicate with a PC in VLAN 124 - 192.168.2.0. Or would this negate the whole purpose of vlans. Shouldnt the Layer 3 Dell switch be able to handle the routing between the subnets.
0
 

Author Comment

by:beargonefishing
ID: 24454105
I think i got it working. I was missing the step to enable routing on the vlan interface itself. Also had to change the gateway address on the hosts on either side of the switch to reflect the vlan that they were accessing. Once i did that, everything was talking. Thanks for the help!
0

Featured Post

Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This article is a step by step guide on how to create a basic PTP link using Ubiquiti airOS devices. This guide can be used on the following Ubiquiti AirMAX devices. Nanostation, Bullets, AirBridge, Nanobeam, NanoBridge to name a few. Please review …
Data center, now-a-days, is referred as the home of all the advanced technologies. In-fact, most of the businesses are now establishing their entire organizational structure around the IT capabilities.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

860 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question