i am creating this ftp user on two servers Solaris 8

But i am getting this i have created user xyz on server England  and i have created xyz ftpuser on server japan and they are different ..I need this to be the same when i logged into England and do the pwd it show me / only ..
when i logged into Japan as the same user and do pwd i see the full path where i am ..How can i fix this problem on England so when i ftp to that server it will show me the full path when i type pwd .
The home directory permession is as follow drwxrwsr-x   for the both the users
thanks
kaka123Asked:
Who is Participating?
 
woolmilkporcCommented:
Glad you found it!

So I've been on the right track with my comment 24399726 above -
>> If it's a third party product, maybe it has its own config file ... <<

Cheers

wmp

0
 
woolmilkporcCommented:
Seems that the user on England gets chrooted. Check /etc/ftpaccess.ctl for a puseronly entry for that user on England.
Wmp
0
 
kaka123Author Commented:
There is no such file /etc/ftpaccess.ctl
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
kaka123Author Commented:
The only file is there is /etc/ftpusers

# pwd
/etc
# more ftpusers
root
daemon
bin
sys
adm
lp
uucp
nuucp
listen
nobody
noaccess
nobody4
0
 
woolmilkporcCommented:
/etc/ftpusers contains users who are forbidden to use ftp at all.
Which FTP server do you use? If it'sa third party product, maybe it has its own config file?
What if you login directly (telnet or ssh or the like)? Do you see the same effect?
wmp
 
 
 
0
 
kaka123Author Commented:
no we are using native solaris 8
0
 
woolmilkporcCommented:
What do you see on England when you issue 'ls' or 'dir'? The contents of the real root (/) or the contents of the user's home?
If it's the user's home, there is no other possibility - the user gets chrooted somehow.
If it's indeed '/' - double-check the user's homedir setting!
wmp
 
0
 
kaka123Author Commented:
yes it does get chrooted my question is how can i fix that ..on the other server evrything is the same how can i fix that so both servers are the same ...
0
 
woolmilkporcCommented:
Is there a dot (.) somewhere in the home directory path specification in /etc/passwd of the affected user?
Again - do you see the contents of the user's home with 'ls', or something else?
0
 
kaka123Author Commented:
it turns out that we are using the ncftpd and the information in the ncftpd.conf file need to be edited .thanks all for your reply
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.