Advanced Search will not search Subfolders in Outlook 2007

Okay, so here's my problem.  

We have Outlook 2007.  Initially, I was not able to do any advanced searches.  I rebuilt my index and am now able to search the Public Folder...  that has no subfolders.  However, when I try to search another person's inbox, even though I use browse> and check Include Subfolders, it will not work.  The option is NOT grayed out.  It gives no errors.  

One more really important note.  This was not an issue before I installed SP2 for Outlook.  When I uninstalled it from a computer, advanced search began to work properly.    I was going to do a registry edit, but the link that I found here on EE did not explain it correctly.  

Who is Participating?
FixerMonkeyConnect With a Mentor Author Commented:
After paying for support, I found out it is hotfix #968858kb
FixerMonkeyAuthor Commented:
Thanks for the reply, however, these links do not address my issue.

Link one:  Changing the default behavior is the least of my worries right now.

Link two:  The box is not grayed out.  I can actually check the box.  Outlook will just not search the subfolders regardless of whether the box is checked or not.  Also creating a new mailbox for every individual in our company is not feasible.  

This was NOT a problem before the latest Outlook service pack.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.