Solved

BES manager not working

Posted on 2009-05-15
30
1,177 Views
Last Modified: 2012-05-07
Hi all, exchange and BES have been working flawlessly. Usually BES never gives me problems. This is the 1st time.

I launch the MES manager and nothing. I get this screen. usually I get the whole console so that I can manage the settings and user accts.


IMG00210.jpg
0
Comment
Question by:sonic1394
  • 13
  • 10
  • 5
  • +2
30 Comments
 
LVL 20

Expert Comment

by:jdera
ID: 24400680
First thing to check are you logging into the box initially as the BES Admin or your account/domain admin.  If the later, you need to log in as BES admin.
0
 

Author Comment

by:sonic1394
ID: 24400839
I am logging in as THE domain admin. I always used this account to access Blackberry manager. I did some digging and I think it has to do with the blackberry manager mapi profile..

When I click the edit Mapi profile Icon, it gives me "ConfigureMsgService (8007000e)"
0
 

Author Comment

by:sonic1394
ID: 24401229
I've been looking for info on that BES admin accountt you mentioned. Its not in AD, so I don't think it was ever created. My blackberry is still working and therefore BES is functioning, however, the Manager program isn't running properly.

AND that MAPI error isn't normal. I don't know what to try.. Should I try reinstalling? BES is really important and I need to get it  up by Monday, latest..... HELP PLZ..
0
 
LVL 40

Expert Comment

by:Subsun
ID: 24401891
Please verify BlackBerry Configuration Database permissions. Refer below article for details.
The Database Owner right should be granted to user accounts that require access to the BlackBerry Enterprise Server Management Database.
 http://www.blackberry.com/btsc/viewContent.do?externalId=KB03112&sliceId=1#2
0
 
LVL 5

Expert Comment

by:consulteware
ID: 24402215
Hi all.

That is a very bad state in BES server, I had that problem before.

The solution that the client has asked was for install another server and that solved the problem, but I do think that you do not want to do that.

According to what I saw in that problem there were some inconsistecy data in the database and inconsistency in Exchange or Domino or GroupWise.

So first of all DO BACKUPS OF EVERYTHIG, BES, MSDE (Or SQL Server Database), and Information Store from Exchage where is stored the Mailboxes!!!!

Start the service that is disable "Blackberry DataBase Consistency", let the service do all the work around until it stops, after that pass it to disable again (THAT IS IMPORTANT).

And then that should be working.

After that just do the UPGrade your BES server to the last version.

I hope that helps.

Regards
0
 
LVL 26

Expert Comment

by:Gary Cutri
ID: 24406289
Hi, this issue is generally caused by a corruption in the Microsoft Management Console and it can normally be fixed very easily.  Assuming you have BlackBerry Enterprise Server (any version except BlackBerry Professional) you can just apply SP6 to correct the MMC issue (then apply MR 5 if possible).  To correct the "ConfigureMsgService (8007000e)" issue please perform the following steps:

1. Log in to the BES using the Blackberry Service account (e.g. BESadmin).
2. Stop the BlackBerry Enterprise Server services.
3. Open the Registry Editor and go to HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles
4. In the Profiles folder, select the profile name that is used for the BlackBerry Enterprise Server and delete it. If multiple profiles exist, delete all of them (including the "CDO__o_Companyname..." entries). Delete all sub-entries as well.
5. Close the Registry Editor.
6. Go to "Start > Program Files > BlackBerry Enterprise Server > Edit MAPI Profile" and configure it for the Blackberry Service Account (e.g. BESadmin)
7. Go to "Start > Program Files > BlackBerry Enterprise Server > BlackBerry Server Configuration > Blackberry Server Tab > Edit MAPI Profile" and configure it for the Blackberry Service Account (e.g. BESadmin)
8. Start the BlackBerry Enterprise Server services.

0
 
LVL 26

Expert Comment

by:Gary Cutri
ID: 24406294
Note: If you install ANY updates to the BES software you MUST run the updates whilst being logged on as the BlackBerry Service Account (e.g. BESadmin).
0
 
LVL 5

Expert Comment

by:consulteware
ID: 24406460
Sorry to tell you but changing Registry can be very messy, just do an BACKUP before if you try the solution of "garycutri", if something goes wrong you can and deed recover the information following the instructions of steps 6 and 7, but you can miss some configuration information what could stop your server information and work.
BE AWARE OF THAT!!!!
Regards
0
 
LVL 26

Expert Comment

by:Gary Cutri
ID: 24406494
The info above is the RIM official know fix but as mentioned a backup should be taken.
0
 
LVL 26

Expert Comment

by:Gary Cutri
ID: 24406503
To quickly backup your database just go to the command prompt type the following:

osql -E (press enter)
>backup database BESMgmt to disk = "c:\BESMgmt.bak" (press enter)
>go (press enter)

0
 

Author Comment

by:sonic1394
ID: 24408270
Hi garycutri

I did everything up till step 5-6

When I run the Mapi Profile editor, I get a message

"Invalid properties in MsgSvcTable (00000000)"

Looks like that caused more problems, now the BES system doesn't work with my exchange at all. Before at least my blackberry  phones were functional, now they're not.

I created the BESMgmt.bak file.
I also created a backup of my main os system drive.

which do you recommend backing up? I'm leaning towards the OS system drive restore. Please let me know, I guess I will be tyring consultware's solution after the restore.


Consultware, I'm not sure on your instruction where you say:

 "Start the service that is disable "Blackberry DataBase Consistency", let the service do all the work around until it stops, after that pass it to disable again (THAT IS IMPORTANT)."

So when I checked the service, it was AT disable. So basically your instruction says to enable it, start it, and when the service is started, stop it and disable it again??? Please let me know so I can try it exactly as you mean once I restore. Thanks.



-2.jpg
0
 
LVL 26

Expert Comment

by:Gary Cutri
ID: 24408541
Ok, you need to:

1. Make sure you are logged on as BESadmin
2. Ensure the BESadmin account isnt hidden from the GAL
3. Ensure the BESadmin account isnt disabled or locked out
4. Go back and ensure you deleted "HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\BlackBerryServer" (i.e. Delete the folder BlackBerryServer)
5. Now perform steps 5-6 above.


More Info:
http://www.blackberryforums.com.au/forums/microsoft-exchange/3804-invalid-properties-msgsvctable-error.html
0
 

Author Comment

by:sonic1394
ID: 24408649
I made sure I am in the account used to login to BES, the account used is the domain administrator. I checked through the services.msc console.

I know it's not the traditional BES account everyone here refers to, but the previous IT manager installed it and left it functional running through this domain admin account. Anyway, I deleted the registry profile specified. Now it went back to giving me the original error message: "ConfigureMsgService (8007000e)"


When I click the edit Mapi profile Icon, it gives me "ConfigureMsgService (8007000e)"


I'm currently downloading service pack 6. Do you think the upgrade would fix this? The registry fix doesn't look like it will work. My alternative is restoring the system drive with the backup utility that comes in server and replacing existing files with my backup of the system drive I made a while ago with, where all of my services are functioning flawlessly... Sounds crazy, but that was my backup plan....  please correct me, but this is logical right? I've never actually restored it, but the backup utility is usually what I have as a backup, the problem is this is the OS drive we're talking about. Has anyone done this successfully before?
0
 
LVL 26

Expert Comment

by:Gary Cutri
ID: 24408847
Hi, I would use this as an opportunity to correct your BlackBerry installation as using an Administrator account causes numerous issues with BES functionality.  Please follow the guide below to create the correct service account:

http://www.blackberry.com/btsc/search.do?cmd=displayKC&docType=kc&externalId=KB04293&sliceId=1&docTypeID=DT_SUPPORTISSUE_1_1&dialogID=87670524&stateId=0 0 90066891
0
 

Author Comment

by:sonic1394
ID: 24409352
Garycutri, I really appreciate your expertise with BES, I've seen your advice around the blackberry forums and have no doubt that you know what you're talking about. I did exactly as described, however i get an error when in exchange system manager, right click, delegate control. It says error in mmc snap in found. Then I try running the sp updates, but it won't update. Error after error.

when I open the edit mapi, same 0000000 error, even after deleting all entries under the profile folder. So far, that's all I've modified in my registry. I deleted all subfolders.

prior to doing that, i created the backup you suggested (osql -E (press enter)
>backup database BESMgmt to disk = "c:\BESMgmt.bak" (press enter)
>go (press enter)

I don't know how to use it though since .bak files are for sql right?

is the .bak I made a registry backup?


to recap on my situation, I opened another question found here:
http://www.experts-exchange.com/Software/Internet_Email/Email/Q_24416308.html


Thanks for all the help guys, I'm still up working on this.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 26

Expert Comment

by:Gary Cutri
ID: 24409754
If you click on the link below send me a message with your contact details and I can do a WebEx session with you and quickly fix the issue:

http://www.blackberryforums.com.au/forums/sendmessage.php
0
 
LVL 5

Expert Comment

by:consulteware
ID: 24410343
Hi
Sorry to happen that sonic1394, but the Experts are obligated to be aware of the knowlage of the users when they give support so that should not happen to you, but it happen now we must solve it.
So, if garycutri can't solve the problem I can help you and solve that once for all, without loosing any data, but you must decide for yourself.
Before I do anything I must know the following, number of users that are using BES,  what is the version of the Exchange, do you have the cd of the BES, do you have the SRP ID and Auth Key, do you have the CAL Keys and what is the version of the CD.
Just confirm all of this and them I can help you, do not put here the CAL Key or the SRP ID of the Auth Key, THAT IS IMPORTANT.
I wish you best luck.
0
 
LVL 26

Expert Comment

by:Gary Cutri
ID: 24410487
The backup copy of the BES database you have has all the required information (including SRP ID, Auth key, CALs, users, PINs etc, I.T Polices and backup data). So with the backup file and a copy of the installer BES can be restored anywhere very quickly without any lose of information (with just a little know how).  At this stage it is not required so as soon as I hear from you we can resolve the issue.
0
 
LVL 26

Expert Comment

by:Gary Cutri
ID: 24410512
Just as an FYI if you did need to move your BES all you need to do is as follows:

Note: this is not required at this stage and is only a FYI.

http://www.blackberryforums.com.au/forums/microsoft-exchange/4456-migrate-bes-4-1-new-server.html
0
 
LVL 5

Expert Comment

by:consulteware
ID: 24410618
Insted of trying to develop the Wheel just focus on solving the problem.
Usually who has and it is using it BES it is for the Board of Directors and the IT guy (Sonic1394) it is under pressure, so do not put now the reinstalation in front of other solutions.
If you are so good with 5000 instalations, and so many support, you should know that, solving a BES problem is very important for the IT, another server can be down but BES server cannot.
Please help Sonic1394 ASAP because He or She need it and deed.
Regards
0
 
LVL 26

Expert Comment

by:Gary Cutri
ID: 24411562
My last two comments are based on topics\path you directed the thread into (e.g. your comment ...do you have the SRP ID and Auth Key ...do you have the cd of the BES).  Also sonic1394 started a new question about restoring a BES\Server and asked "I dont know how to use it though since .bak files".  So until you posted your comments above I was on a clear path to assisting the user resolve the issue.  This issue is caused by profile corruption and a fault in MMC, instead of posting all the details which can be long winded (and can slightly vary depending on the server state) I offered to do a WebEx session to quickly fix the problem.

So as mentioned above if sonic1394 wants me to provide direct assistance I will happily do so (as I have done for many other members here).
0
 

Author Comment

by:sonic1394
ID: 24413328
I'm going to open a support request from Blackberry. I believe they charge $250, not sure. Anyway BES probably will have to get reinstalled from scratch. The delegate control problem might still be an obstacle though. So I'm going to work on fixing that error first.

The blackberry server profile gets recreated every time the system reboots. I deleted it again and now get the "ConfigureMsgService (8007000e)"

0
 
LVL 5

Expert Comment

by:consulteware
ID: 24413363
I'm sorry to hear that, that is not the intention of the Experts of Experts Exchange to create any problem in any ways.
Anything you are welcome to come back, there are many Experts and many can help you.
Please close the question and refund the points.
Regards
 
0
 
LVL 26

Accepted Solution

by:
Gary Cutri earned 500 total points
ID: 24413726
As everything is stored in the database it is very easy to uninstall BES (this does not remove the database), then remove the old profile and create a new Blackberry service account (and appropriate permissions) and setup BES again.  During the install you are able to point it back to the old database and service will resume as per normal.  My offer still stands to do it for you on save you $250:

Just send me your contact\email details and I can send you the support link:
http://www.blackberryforums.com.au/forums/sendmessage.php


0
 

Author Comment

by:sonic1394
ID: 24413940
Ohh Gary, consultware, ouch. I left this window open and did not see your latest responses because the page was not refreshed. Let me take back my previous comment.

Garycutri your url http://www.blackberryforums.com.au/forums/sendmessage.php isn't working.
0
 

Author Comment

by:sonic1394
ID: 24413965
Garycutri: "My last two comments are based on topics\path you directed the thread into (e.g. your comment ...do you have the SRP ID and Auth Key ...do you have the cd of the BES).  Also sonic1394 started a new question about restoring a BES\Server and asked "I dont know how to use it though since .bak files".  So until you posted your comments above I was on a clear path to assisting the user resolve the issue.  This issue is caused by profile corruption and a fault in MMC, instead of posting all the details which can be long winded (and can slightly vary depending on the server state) I offered to do a WebEx session to quickly fix the problem.

So as mentioned above if sonic1394 wants me to provide direct assistance I will happily do so (as I have done for many other members here)."

yes I have the  SRP ID and Auth Key  and the BEs install exe
0
 
LVL 26

Expert Comment

by:Gary Cutri
ID: 24414022
Try going to www.blackberryforums.com.au and then and the bottom bar you will see Contact Us (just fill in the details and press send).  I just tried the link I provided and it is working but try then step I just mentioned to see if that works for you.
0
 

Author Comment

by:sonic1394
ID: 24414043
slopez85@gmail.com
0
 
LVL 26

Expert Comment

by:Gary Cutri
ID: 24414105
Link sent
0
 

Author Closing Comment

by:sonic1394
ID: 31582118
Garycutri is an expert in his field. My problems were intertwined with exchange. Appeared as though system manager had corrupted files preventing it from working with BES. Garycutri found a workaround solution using mapi cdo 1.2.1

0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

Suggested Solutions

ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now