Solved

Issue Resolution: Shut Down Corrupts MUP.SYS: Refresh does work, However,  every reboot this file gets corrupted.

Posted on 2009-05-15
6
870 Views
Last Modified: 2016-10-27
This one of the many issues involving MUP.SYS.  My issue is not in Google searches that I could find, not precisely anyway.  Not in Expert Knowledge base either(I may have missed it).  Maybe some mixture of the various solutions may apply,but, I hesitate to just willy-nilly work them.  I could be making matters worse.  I need to do a plan of action first.

History:
I shut down on a Friday night.  I had disabled the UPS battery back up scheduled shut down.  I use it normally and now need it to be able to get to/stay in Windows.

I cannot reboot into any of the other boot options.  I can get into the Recovery Console without a Recovery Boot CD(HP's stuff), but, not with it - stops at the same place (the boot screen).  I cannot use the regular DOS command structure that I am used to.  Only a subset.  At least it lets me copy files.

After a lot of relearning DOS's 8.3 naming when traversing the file structure, I finally got to my back up (a USB 1 TB Drive) and copied over the corrupted MUP.SYS file.  It worked...I got in.
But, it didn't last and only was a temporary fix.  Upon reboot I went back to DOS via Recovery Console and copied again.  This time I rename dand copied a couple more of this file into that directory just in case I have to do this multiple times.

I have a couple of solutions that I may try, but I won't until I have them prioitized and I feel ready to work this issue.  What I really need now is a utility that will let me see/log the shut down sequence.  Like BootLogXP does for windows boot up.  BootLogXp doesn't start from the first thing that is loaded.

I am a disabled person ,but , I am also a professional developer.  I am experienced, but I have been out of the field for the last 5 years because of major illness and surgeries. I am trying to get back into IT work.

I know about going and disabling the .SYS file when in Recovery Console.  Always wondered why I can't just do that in a cmd console ( or in Windows itself)?

I originally thought I would have to do the fixmbr/fixboot thing. I found that this should not be the first thing to try. I had Acronis Disc Suite 10 trial and it did seem to have something I could try. However, the trial period just ran out today..geesh ...the luck I am having.  I would purchase it and the imaging software they offer if I was assured that it would solve this problem.  I have other software to get now.

I hope I don't need to low level format and reinstall a clean OS.  HP does not give its customers the OS CD to do this.  They did let me buy their 10 disk XP and all the stuff the way it was when I bought the computer.  I really just want to do a repair.  If I need to do this I will have a lot to do for a while.

After I get through this, it IS going to be a better and secure system.

I was planning on upgrading to an AMD Athlon 64 X2 4400+ chip and new cooler.  I may have to rethink and get my new motherboard/CPU and memory sooner.  I was going for next year when the i7 has a chance to go through a rev or two.  Same with Windows 7.

I am signing up and all.  I do find a great use for the Expert Exchange.  I have a lot of things I do for locals and myself.

Also just recently, it has been revealed that I have the "about:blank" hijack (doesn't do anything because I use a big host file) and something keeps trying to email something "on my behalf" via MS Outlook.  I am currently exsizing these while I wait for some quality solutions.

Thank you for any help.  I will promptly reply.  I hope Expert(you) and I can be successful on this.

BarJabba
Computer info:
 

OS Name	Microsoft Windows XP Home Edition

Version	5.1.2600 Service Pack 3 Build 2600

OS Manufacturer	Microsoft Corporation

System Name	AMERICAN-HOPE

System Manufacturer	Compaq Presario 061

System Model	ER919AA-ABA SR1820NX NA620

System Type	X86-based PC

Processor	x86 Family 15 Model 47 Stepping 2 AuthenticAMD ~2204 Mhz

BIOS Version/Date	Phoenix Technologies, LTD  3.11, 9/19/2006

SMBIOS Version	2.4

Windows Directory	C:\WINDOWS

System Directory	C:\WINDOWS\system32

Boot Device	\Device\HarddiskVolume1

Locale	United States

Hardware Abstraction Layer	Version = "5.1.2600.5512 (xpsp.080413-2111)"

User Name	AMERICAN-HOPE\Ben Curtis

Time Zone	US Mountain Standard Time

Total Physical Memory	4,096.00 MB

Available Physical Memory	2.64 GB

Total Virtual Memory	2.00 GB

Available Virtual Memory	1.96 GB

Page File Space	4.00 GB

Page File	C:\pagefile.sys

Open in new window

hijackthis.log
0
Comment
Question by:BarJabba
  • 4
  • 2
6 Comments
 
LVL 35

Expert Comment

by:torimar
ID: 24402901
Hi BarJabba, and welcome to Experts-Exchange.

As to the issue at hand:
Since your Mup.sys first works, then gets corrupted, it must be overwritten somehow. Try setting its attributes to "read-only", then it will no longer be available for overwriting. This does not affect the system in any way.

If this does not solve the issue, run a checkdisk on your drive. If again no joy, you could still test if a corrupted registry hive could cause things to fail by restoring to an earlier restore point. Sometimes, System Restore does not work - especially when needed dearly - then a manual restoration can be done via the Recovery Console.

Both methods, checkdisk and manual recovery of the registry, are explained in much detail here: http://www.aitechsolutions.net/winxpnoboot.html


ps:
Your HJT logfile seems clean to me and does not show any known nasties.
0
 

Author Comment

by:BarJabba
ID: 24405090
Hello,
I hope this is where I would respond to the Expert "tori mar".  

Thank you for the information.  I have some changes since trying to do the mention XP repair with the XP CD.   There are a few things you state that I am doing Sunday early morning.  I have gone into the install CD, but, the repair option takes me to the DOS prompt to select a install to log on to.  I select and then put in the password.  Then I am still at the DOS prompt.  I thought I'd be back into the XP install "blue screen".

I tried the other option which finds the partitions, but that starts the destructive stuff doesn't it?
I got a hair trigger finger and hit enter anyway, and my HD started to go crazy.  So I resetted.

I need to go back into that DOS prompt and copy over the sys file so I have a chance to go back into Windows.  I need to copy things over to my USB drive.  That way if all else fails, I can at least have available to me all mt Apps that are zipped and other documents and files.

If if this is not the right place to communicate this please inform me.  

If I press except solution, does that mean I have said it was successful?  I need to tell the Expert of the changes since I sent my original issue he answered.  I am new to this system.

BarJabba
0
 

Author Comment

by:BarJabba
ID: 24405114
Oh BTW... here are my notes thus far, it has some info that might make it clearer:

"Things have changed a little since Istated my original question/issue. I started to inact a solution. Disabling the MUP.SYS file. Well, XP now stops on the 1394?.SYS (the fire wire thing I think). I will have to look again for the right name. Now I will go back and refresh that file and maybe just stay in Windows for a day to back up more files...if I am lucky enough! :-/ I noticed that when I was finally on Windows, if I used the reboot instead of the shut off my original problem would occur. When I selected to completely turn off it worked. I am not sure if that is a consistent thing yet." :-)

BarJabba
0
Get up to 2TB FREE CLOUD per backup license!

An exclusive Black Friday offer just for Expert Exchange audience! Buy any of our top-rated backup solutions & get up to 2TB free cloud per system! Perform local & cloud backup in the same step, and restore instantly—anytime, anywhere. Grab this deal now before it disappears!

 
LVL 35

Accepted Solution

by:
torimar earned 500 total points
ID: 24406145
Have you tried setting the mup.sys file to read-only, as I suggested first?
Here's how you do this:
- inside Windows, open a command (DOS) prompt: Start > Run > type: cmd > hit ENTER
- then type:
attrib +r c:\windows\system32\drivers\mup.sys


The "DOS prompt" you are talking about in your reports above most likely is the "Recovery Console" (http://www.windowsnetworking.com/articles_tutorials/wxprcons.html). You can use it to check your HDD for bad sectors, by typing:
CHCKDSK /R

Try this only _after_ you backed up your valuable data, and _after_ you checked whether the trick described above (setting mup.sys to read-only) does work or not.


If you wish to perform a Repair installation, this is the best guide to use:
http://michaelstevenstech.com/XPrepairinstall.htm#RI
0
 

Author Comment

by:BarJabba
ID: 24406541
Thank you,
 
I am backing up in my machine until I can enact another solution.  As stated earlier , I disabled mup.sys and now the OS says that the ControlSet registry key is not present.  I am not sure why I cannot re-enable it.  
Yes, I did that just before writing this note.    
When I rebooted I did the Chkdsk.  It actually tied my Comp up long enough to get some much needed sleep...thank God for small favors.
"Try this only _after_ you backed up your valuable data, and _after_ you checked whether the trick described above (setting mup.sys to read-only) does work or not"
Yes, I am doing this right now in the background.  *** I need to know how to get the registry key that will let me re-enable MUP.SYS.
I am a noob at Expert Exchange.  I need to read the process more.  Do you know what I am supoosed to do when I recieve a communication from an expert?  In each message are two selections (accept the solution and accept a multiple solution)?
Upon rebooting I had a utility called UnHackMe scan to report Rootkits and other malwares.  It said that a TUKernal was a problem.  I think it is part of Tune Up 2009.  I am conversing with them about it.  Also, I still have to deal with the about:blank hijack and something keeps trying to senf an email on my behalf.  SO, I've got my hands full for awhile.
I'll report back later.
0
 

Author Closing Comment

by:BarJabba
ID: 31582137
There is nothing that seems to be working to get back to a normal Boot//Shut Down sequence without having to refresh what ever gets corrupted.  I still have yet to to try fixmbr or fixboot.  And the geeky solution that the Expert gave, well, I will try it when I partition some space on my USB drive and install a full version of XP Pro.  Then try fixing things from there.  I will come out ahead in the long run as I was about to upgrade the CPU and HSF before this happened.

I still have to go into Last Known when I have refreshed the files, as well as, Restore Points.  I talked to the OEM I bought this from...I learned a good lesson...buy you own OS and always do a image or back up.

I really like this Expert Exchange.  I wished that I could keep an expert in my back pocket.  I also wished that we could have resolved it.  Who knows, I probably will be comming here often.

I am closing this at this time because it will probably be awhile before I could get back with an answer to all the fixes I have to implement.  Besides, I do not get how to offer points and grades.  I only pay a small fee (compared to the service)for monthly membership and I think it is more fair for the Expert to get something tangible for his/her help.  I am impressed for this, my first time.

Thanks
BarJabba
0

Featured Post

Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Join & Write a Comment

If you have done a reformat of your hard drive and proceeded to do a successful Windows XP installation, you may notice that a choice between two operating systems when you start up the machine. Here is how to get rid of this: Click Start Clic…
What is Backup? Backup software creates one or more copies of the data on your digital devices in case your original data is lost or damaged. Different backup solutions protect different kinds of data and different combinations of devices. For e…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now