Solved

Cisco router with ISP

Posted on 2009-05-15
15
786 Views
Last Modified: 2012-06-22
Hello I have just got a cisco router 2651xm, and it has two fast ethernet slots.  I am trying to get my ISP to work with this router.  How do I go about doing that.  I plugged in my ISP's cable modem to interface fastethernet 0/0 and set it to dhcp, and i set fastethernet 0/1 to ip of 192.168.1.1 and I tried connecting to the net, and it still won't work.  What do I do.  Can you also post the commands to do it.  The router has a wic t1 slot installed.  Do i plug my ISPs cable modem to that, and is that interface known as serial in the list of interfaces on the cisco router.  As soon as I get this router running with my isp, do i just connect the other port to the cisco switch (2950) and configure each port, and once I configure the ports, do i have to configure hosts to the same ip as the switch ports (stupid question, I am positive i configure the host ports to a different ip but within the same subnet).  But most important question is how do I get my darn router to work with my isp's router.
0
Comment
Question by:falimorad
  • 7
  • 4
  • 3
  • +1
15 Comments
 
LVL 7

Assisted Solution

by:LANm0nk3y
LANm0nk3y earned 150 total points
ID: 24401325
You should be only using the fastethernet slots if it's a cable modem.  You won't be using any serial port.

your config should be:

interface FastEthernet 0/0
ip address dhcp

Interface FastEthernet 0/1
ip address 192.168.1.1 255.255.255.0

ip route 0.0.0.0 0.0.0.0 FastEthernet 0/0

if you can ping 4.2.2.2
then you are connected to the internet

The next thing you need to do is configure NAT
http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094e77.shtml
0
 
LVL 7

Expert Comment

by:LANm0nk3y
ID: 24401326
when i said ping, you should be pinging from the router -- not your pc.
0
 
LVL 8

Accepted Solution

by:
ludo_friend earned 350 total points
ID: 24401697
hi.
yes plug your cable modem into fastethernet0/0, and your switch into fastethernet0/1. T1 is completely different - don't use that.

very quick and simple config.
---

interface FastEthernet 0/0
ip address dhcp
ip nat outside
no shut

interface fastethernet 0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
no shut

ip nat inside source list NAT interface FastEthernet 0/0 overload
ip access-list extended NAT
 permit ip 192.168.1.0 0.0.0.255 any

---
at this time I'd ask you to do a
sh ip int brie
and confirm if fastethernet 0/0 has an ip address or not. if it does, see below, if not can you please post a
show interface fastethernet 0/0
and a
show run interface fastethernet 0/0
---
as LANm0nnk3y states - you need to also confirm ping from the router to an external host - he recommends 4.2.2.2. that will be fine :)

once you have replies from the ping test, you then need to get your clients connecting.
are you running an existing network dhcp and dns server? if so adjust your dhcp server to use the 2621XM as the default gateway and you should be good to go.
if you're not running a dns server and dhcp server, no problem... your 2621XM can do that for you as wel (and import dns settings from the cable)

ip dhcp pool Clients
 import all
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.1

easy as that :) - at this time your clients should be able to be configured for dhcp, pick up an ip address from the 2621XM, be able to ping out, resolve names and browse the internet etc...

if you want to be more selective about internet access you can adjust the acl NAT

let me know how you go :)


0
 
LVL 5

Expert Comment

by:devangshroff
ID: 24401746
provide the configuration
0
 

Author Comment

by:falimorad
ID: 24402398
Hey guys thanks for your replies, fastethernet 0/0 is not getting an address, here is the information.  One more thing, I have it connected to rogers, and I think that their cable modem is registered to work with one MAC address, because on my old linksys router I had to do a mac address clone of my machine, is there something like that on the cisco router ?

FastEthernet0/0 is up, line protocol is up
  Hardware is AmdFE, address is 000e.d7a5.3480 (bia 000e.d7a5.3480)
  Internet address will be negotiated using DHCP
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:10, output 00:00:07, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     9 packets input, 3392 bytes
     Received 9 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     78 packets output, 22349 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
     3 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out


FastEthernet0/1 is up, line protocol is up
  Hardware is AmdFE, address is 000e.d7a5.3481 (bia 000e.d7a5.3481)
  Internet address is 192.168.1.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:01:14, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     58 packets input, 8431 bytes
     Received 58 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     63 packets output, 7189 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     3 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
0
 
LVL 8

Assisted Solution

by:ludo_friend
ludo_friend earned 350 total points
ID: 24402587
the config to set a mac address in ios is mac-address

i.e.
interface fastethernet 0/0
 mac-address 0011.2233.4455

0
 

Author Comment

by:falimorad
ID: 24403615
thanks alot for all ur help, your configuration works fine except for one problem (from my end).  You know how we configured

interface FastEthernet 0/0
ip address dhcp
ip nat outside
no shut

well the dsl modem that I am connected too is also a router of the address of 192.168.2.1
Now do i confifure fastethernet 0/0 with that ip, and I know I will have to change fasthernet 0/1 to have an address of 192.168.2.x.  But should i configure fastethernet 0/0 with the router ip of the dsl modem that my isp provided me (192.168.2.1)
0
6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

 

Author Comment

by:falimorad
ID: 24404120
ok this is kind of driving me nuts, I cant get my computer to connect to an external site such as google.com, I do get an internal address.  Here is my configuration from the router

Current configuration : 780 bytes
!
version 12.2
service config
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
ip subnet-zero
!
!
!
ip dhcp pool console
   import all
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address dhcp
 ip nat outside
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
!
interface FastEthernet0/1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto

ip nat inside source list nat interface FastEthernet0/0 overload
ip classless
ip http server
!
!
ip access-list extended nat
 permit ip 192.168.1.0 0.0.0.255 any
!
dial-peer cor custom
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

Fastethernet 0/0 does resolve an address (192.168.2.27) and ping 4.2.2.2 yields success.  Am I missing something ?
0
 
LVL 7

Assisted Solution

by:LANm0nk3y
LANm0nk3y earned 150 total points
ID: 24404278
it looks likedoesn't look like you you have DNS?

can you ping 4.2.2.2 from the computer?
0
 
LVL 8

Assisted Solution

by:ludo_friend
ludo_friend earned 350 total points
ID: 24404402
are you able to give us a
ipconfig /all
from your pc (assuming its windows)

I'm with lanm0nk3y - seems like dns to me.
did the isp provide you with a some dns servers?

if not, you can use some public servers (again assuming your network doesn't need its own for active directory /whatever)

ip dhcp pool console
 no import all
 dns-server 4.2.2.1 4.2.2.2 4.2.2.3 4.2.2.4 4.2.2.5

then a ipconfig /renew from your client pc should pick up the changes.

if that doesn't work then I'll need to see the results of your ipconfig /all

0
 

Author Comment

by:falimorad
ID: 24404719
Ok i will need to check when I am on site with the client.  But when I did do a ipconfig, this is what it showed

IP Address. . . . . . . . . . . . : 192.168.1.3
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1

It does not show anything for DNS server, if I go to another host, it shows the exact same thing but different ip as it is set to dhcp.  for the dns-server setting, I see you put no import all, but earlier we put import all, would that effect
ip dhcp pool console
   import all
   network 192.168.1.0 255.255.255.0

if i set the dns servers on the router then I don't have to set it up on the host right ?
0
 
LVL 8

Expert Comment

by:ludo_friend
ID: 24404806
needs to be an ipconfig /all to see settings like dns :)

"import all" grabs settings from the upstream dhcp server and supplies them to your clients (dns servers included) . if you're not picking up dhcp settings from your cable modem then we'll have to specify it there.

if you set the dns servers in the routers dhcp server then yes, you will not have to set them up on each client. less effort is good in my books :)
0
 

Author Comment

by:falimorad
ID: 24404891
yes I only included the address section of ipconfig /all, it did not show any dns server, thats probably the issue.  I will contact the isp and see if they have a private dns server i can use if not I will use the public one.  Thanks guys, will give you an update.  You guys have been such a great help, I really really appreciate it.  I wish I can reward each of you a billion points.  
0
 

Author Comment

by:falimorad
ID: 24406723
Guys you were right, I did tested it on another host and it worked fine, the other hosts actually resolved a dns server which was the isp's gateway.  The isp's gateway router is 192.168.2.1 and thats the dns server the machine used and it worked perfectly.  Here is my ipconfig /all

Connection-specific DNS Suffix  . : no-domain-set.bellcanada
Description . . . . . . . . . . . : VIA Rhine II Fast Ethernet Adapter
Physical Address. . . . . . . . . : 00-11-D8-74-84-AE
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.1.2
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
                                    192.168.2.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.2.1
                                    192.168.2.1
Lease Obtained. . . . . . . . . . : Sunday, May 17, 2009 12:21:07 PM
Lease Expires . . . . . . . . . . : Monday, May 18, 2009 12:21:07 PM
0
 

Author Closing Comment

by:falimorad
ID: 31582163
Very fast and precise answers.  Wouldn't have done it without them
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Suggested Solutions

New Server 172.16.200.2  was moved from behind Router R2 f0/1 to behind router R1 int f/01 and has now address 172.16.100.2. But we want users still to be able to connected to it by old IP. How to do it ? We can used destination NAT (DNAT).  In DNAT…
This tutorial will go through the steps required to write a script that will back up the configuration settings of a HP-ProCurve switch. You will need to get the following things to follow this tutorial: Telnet Scripting Tool e.g. TST10.exe …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now