Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 548
  • Last Modified:

How can I install these in ubuntu

How can I install these in ubuntu
    * ncurses, and associated -devel
    * openssl, and associated -devel
    * zlib, and associated -devel
    * bison, and associated -devel (1.0.X only)

in order to have Asterisk installed successfully
0
1030071002
Asked:
1030071002
  • 4
  • 2
  • 2
  • +1
1 Solution
 
Kerem ERSOYPresidentCommented:
Hi,

Ncurses : sudo apt-get install libncurses5 libncurses5-dev
Openssl: sudo apt-get install openssl opsnssl-dev
I think zlib should be there already but you might need : sudo apt-get install zlib-dev
Bison: sudo apt-get install bison bison-devel

Cheers,
K.

0
 
Todd MummertCommented:
from the command line:

sudo apt-get install asterisk

should resolve all the dependencies

0
 
amroxCommented:
To find the right package to install you can simply type

apt-cache install <part_of_package_name>
as any user

This allows you to search for packages available in your listed repositories.
You can then do a apt-get install <package_name> as root to install

or, if you want a graphical method with a search facility, start synaptic
It shoud be in the menu either in System=>Administration=>Synaptic Package Manager
or
Applications=>Accessories/System Tools, depending on which ubuntu release you have.
You can then start typing what you are looking for in the search box which will filter the results in the box below
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
Kerem ERSOYPresidentCommented:
@climbgunks:

> sudo apt-get install asterisk

> should resolve all the dependencies

There are packages that Asterisk installs and still others that Asterisk only suggests to be installed.
0
 
1030071002Author Commented:
root@remote:/home/remotedesktop# sudo apt-get install zlib-dev
Reading package lists... Done
Building dependency tree      
Reading state information... Done
E: Couldn't find package zlib-dev
root@remote:/home/remotedesktop# sudo apt-get install bison bison-devel
Reading package lists... Done
Building dependency tree      
Reading state information... Done
E: Couldn't find package bison-devel
root@remote:/home/remotedesktop#
0
 
1030071002Author Commented:
getting error
E: Couldn't find package zlib-dev

0
 
Todd MummertCommented:

that's because it doesn't exist....   try the other suggestion...

and no, the optional/suggested  packages don't get installed... just the necessary ones... see below:

root@namib:~/puzzle# sudo apt-get install asterisk
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  asterisk-config asterisk-sounds-main libc-client2007 libct3 libgsm1
  libiksemel3 libpri1.0 libradiusclient-ng2 libtonezone1 libvpb0 mlock
  odbcinst1debian1 unixodbc
Suggested packages:
  asterisk-dev asterisk-doc asterisk-h323 kphone ohphone twinkle
  uw-mailutils vpb-utils libct1 libmyodbc odbc-postgresql
Recommended packages:
  vpb-driver-source
The following NEW packages will be installed:
  asterisk asterisk-config asterisk-sounds-main libc-client2007 libct3
  libgsm1 libiksemel3 libpri1.0 libradiusclient-ng2 libtonezone1 libvpb0
  mlock odbcinst1debian1 unixodbc
0 upgraded, 14 newly installed, 0 to remove and 208 not upgraded.
Need to get 6506kB of archives.
After this operation, 15.2MB of additional disk space will be used.
Do you want to continue [Y/n]?


0
 
Kerem ERSOYPresidentCommented:
getting error
E: Couldn't find package zlib-dev

sorry the package name is zlib1g-dev.

Also you'll need thse packages:
-  libssl-dev
-  ncurses-dev
-  libnewt-dev
-  gcc-3.4
-  subversion
-  openssh-server
-  build-essential linux-source-2.6.12

0
 
Kerem ERSOYPresidentCommented:
@ climbgunks:

> that's because it doesn't exist....   try the other suggestion...
> and no, the optional/suggested  packages don't get installed... just the necessary ones... see below:

Dear climgunks, what you don't get is these packages are required for compiling the Asterisk. They are not required for binary install.

Since the asker has initially asked these modules it is sure that he needs to compile his asterisk not just install the binary package.

Please try to fully understand the nature of the question before speculating. Thanks.
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

  • 4
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now