Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 505
  • Last Modified:

Client does not support authentication protocol requested by server; consider upgrading MySQL client

Hello Experts,

I am trying to connect to the MySQL 4.1 database from the PHP file on the windows live web server .

Google search suggesting to upgrade all the MySql clients and reset the password.

What is MySql Client? I have created the database using the hosting control panel.

Please can someone advise?

Thanks
S
0
newbie27
Asked:
newbie27
  • 3
  • 2
2 Solutions
 
ToskoCommented:
Hi there,
You are using an old MySQL version ( v 4.1 ). while the latest version is 5.4. The new version supports new commands and a lot of bugs/errors are fixed in the new version.
Try contacting your webhost and see if they are willing to upgrade the MySQL version.
Kind regards,
Tosko
0
 
newbie27Author Commented:
Hi Tosko

Thanks for your input, as suggested I have created a new database with version 5.0. I am still getting the same error.

All I am trying to do is setup osCommerce on the live webserver which is hosted on windows. Do you think its anything to do with the server incompatibility?

Please advise

Thanks
sam



There was a problem connecting to the database server. The following error had occured:
 
Client does not support authentication protocol requested by server; consider upgrading MySQL client
 
Please verify the connection parameters and try again.

Open in new window

0
 
ToskoCommented:
Oh I know what the problem is. MySQL >= 4.1 uses a new format for the password which is a longer hash. Which causes old clients to fail at working properly.
Check this out: Click here
0
 
newbie27Author Commented:
Howerver, I am trying now to version 5.0, I have created a complete new database and setup a username and password so this should not give me this error right?

also, i am getting the following error when i try to run the update command

UPDATE command denied to user 'dda'@'72xxxx233.37' for table 'user'

please advise
thanks
0
 
newbie27Author Commented:
The problem was the site was sitting on widows box ... it has now been moved to the linux ...

so its working all ok now !

thanks for the input anyway...

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now