• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 362
  • Last Modified:

Our DNS record in the forward lookup zone gets modified

we have a critical server with a static ip adress and a manula entry created for the server in the dns. we noticed that last week when users were trying to react the server they were being redirected to another server. we identified that a new device which was used for some conferencing was using the same name. it got an ip from the dhcp and probably registered it on dns overrighting the existing record. to avoid this problem we requested them to change the name of the device as it was creating this conflict. the name was changed and its record created in DNS with a different name. in spite of doin this we still see the original record is is getting renamed and its ip changing . what could be causing this and what is the way we can prebent this. maybe we could change the security permissions on this host record that it is not modified. our dhcp uses a service account to update the DNS. is it correct to remove permissions for the service account on this perticular host record.
1 Solution
Either remove the permissions for the service account for this special host entry, or stop allowing the DHCP server to register IP addresses completely. Domain members will be able to register themselves in DNS anyway, and there's usually not much use for non-domain members to have their names registered in DNS.
Or change the name of the critical server to something less generic; if there seem to be two devices in your network with the same name as your critical server, you should maybe look into setting up a proper naming scheme for your hosts.
Hi there.
This is what I do in my networks:
1. Use IP rules for network devices like this:
- IP's from 1 to 10 for servers;
- IP's from  11 to 30 for networking actives (switches, AP's, FW's, etc);
- IP 254 for the default GW (main router);
- Limit the DHCP pool from 31 to 250.
2. Set all these devices with manual IP and DHCP reservations.

This way, I never had problems with IP conflicts. For your situation, I suggest to set the IPs manually for special devices in your network (like that VTC equipment), and make reservation in DHCP in a different range than computers.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to Squarespace.com and use offer code ‘EXPERTS’ to get 10% off your first purchase.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now