Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 113
  • Last Modified:

favicons

I downloaded a favicon i made from http://www.favicongenerator.com/ and added the code they supplied into my page between the <head>s but i cant get it too work. i also tried a few other codes from other websites
<link rel="shortcut icon" href="/favicon.ico" >

Open in new window

0
corylester
Asked:
corylester
  • 7
  • 6
  • 2
  • +2
1 Solution
 
Philip_SparkCommented:
did you

upload favicon.ico to your root directory.?
0
 
corylesterAuthor Commented:
Yes of course
0
 
Philip_SparkCommented:
one thing I note is the end tag isn't closed
should be

/>

I also read someone suggested removing the slash before favicon

other ideas are available here

http://forums.creativecow.net/thread/191/855734
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
Jason C. LevineNo oneCommented:
>> one thing I note is the end tag isn't closed

Not necessary depending on the doctype.  Even if it is XHTML, that error wouldn't kill the favicon as the browsers would just ignore the error.  Worst-case scenario is that leaving the trailing / off will cause a validation error and throw you to quirks mode.

>> I also read someone suggested removing the slash before favicon

Also not necessary. The /favicon.ico notation just fixes favicon to the public root.

>>  but i cant get it too work.

Test from a different machine.  Favicons tend to get "stuck" in the browser cache and if you add one and do not empty the cache/force-reload the pages you may not see it on that machine for a bit.  The better check is to get someone who doesn't visit your site to check for you (like us).

Post a link...
0
 
Jason ThompsonSenior UX DesignerCommented:
You may have to bookmark the site for it to show up in your browser, especially if you haven't cleared your cache in a while.
0
 
corylesterAuthor Commented:
www.ackearthmovingptyltd.com.au
 I also tried the photoshop plug in to save a new picture but it doesnt seem to work.
 In dreamweaver i also tried insert,HTML,headtags,link to get the code which seemed to insert the code but it still does not work.
The photoshop plug in sucessfully installed but i am not sure have to save the file correctly in filename i wrote favicon.ico and saved but it didnt work. after saving it, its called favicon.ico but it has the photoshop picture on it like it has been saved as a photoshop file.
i have bookmarked the site, used different browsers and cleared my internet files any help would be greatly appreciated
0
 
Jason C. LevineNo oneCommented:
You have:

<LINK REL="SHORTCUT ICON" HREF="favicon.ico">

should be

<link rel="icon" type="image/vnd.microsoft.icon" href=favicon.ico" />

since you are using XHTML 1.0 Transitional.

Additionally:

http://www.ackearthmovingptyltd.com.au/favicon.ico

returns a 404, so something isn't where you think it is.
0
 
corylesterAuthor Commented:
Ok i put the favicon.ico file back on the web now http://www.ackearthmovingptyltd.com.au/favicon.ico
returns a small x is that suposed to be a picture

i also inserted your code

Is the picture file not the correct type of something
0
 
Jason C. LevineNo oneCommented:
I can see it now on your site.  Yellow square with something in the center...
0
 
corylesterAuthor Commented:
I use internet explorer and it is not working for me
0
 
Jason C. LevineNo oneCommented:
Sorry, the code above has a typo:


<link rel="icon" type="image/vnd.microsoft.icon" href="favicon.ico" />

Left out a "
0
 
corylesterAuthor Commented:
nah still not working in explorer, dreamweaver has its own linking function in design view so i dont think its the code, mabee its something to do with explorer settings?
0
 
Jason C. LevineNo oneCommented:
Give it one more try with this code:

<link rel="shortcut icon" href="favicon.ico">
0
 
corylesterAuthor Commented:
That is the same code dreamweaver generates but no bingo. It is working on a laptop running safari but not my main computer with explorer
0
 
Jason C. LevineNo oneCommented:
>> It is working on a laptop running safari but not my main computer with explorer

Once you see it on one, your code is now correct.  If you are concerned about the icon itself being the right file type, send it through the favicon creator:

http://tools.dynamicdrive.com/favicon/

Remember, once you get it working, it still may not show up for a bit unless you empty the cache and force-reload the page.
0
 
corylesterAuthor Commented:
How do i empty the cache and force-reload the page. from internet propeties i have deleted all internet browsing history and i have "check for newer versions of stored pages every time i visit a webage " selected
0
 
chrish16Commented:
The code looks fine; this is most likely a caching issue:

Go to http://yourwebsite.com/page.html

and append this onto the file (html, php, w/e):

?x=1

Then refresh.

So in the end, the url looks like http://yourwebsite.com/page.html?x=1

That should ignore the cache and freshly reload the website.

If it doesn't work, clear your temporary internet files and try again.
0
 
chrish16Commented:
Hmmm second idea, try replacing the whole line with this:

 
<link href="/favicon.ico" rel="shortcut icon" type="image/x-icon" />

Open in new window

0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 7
  • 6
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now