Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 28870
  • Last Modified:

Citrix Web Interface error- An error occurred while making the requested connection.

Hello - I've installed Citrix WI on one server and XenApp on another. I can get to the site successfully and log in with no errors. I have one application and whenever I select it it gives me an erroroccurred while making the requested connection. I believe the issue resides with WI gateway settings.

The WI is setup for Gateway Direct and I modified the Default (under client IP address). I got to this setting by following instructions that stated for me to go to managed secure client settings - gateway settings, however please note that gateway settings is not listed as an option for me. All I have is Managed secure client access - edit secure client access settings and this is where I modified default settings as I stated. Again I feel this is where the issue resides, however not sure why I do not see gateway settings.

My current settings are below. I can get to the website, however again when I select app it states error message. An error occurred while making the requested connection. it has to be the managed secure client access setting.

Address (FQDN): ecwtrainingdb.rapa.local
Port: 443
Enable Session Reliability (leave unchecked)
Secure Ticket Authority URLs: WIN08CITRIX
8080/scripts/ctxsta.dll

This has to be the issue. Before I changed the default setting, http access was working fine. Once I changed to gateway direct, HTTPS works, but can not access apps from either http/https.

I appreciate everyones help and look to get this resolved as soon as possible.

nimdatx
0
Jaime Campos
Asked:
Jaime Campos
  • 5
  • 3
1 Solution
 
LKaushalCommented:
Are you using Citrix Secure Gateway or Access Gaetway? If not, then why you have configured 'Gateway Direct', obsivously this will fail the apps launch as there is no CSG\AG box.

However, if you have CSG box? can you post 'Diagonstic information'?
0
 
Jaime CamposAuthor Commented:
Yes I have CSG  and below is the diagnostic report.

Thanks.

Version = 3.1.0

Computer NetBIOS Name: ECWTRAININGDB
Configuration captured on: 5/19/2009 8:48:37 AM
-----------------------------------------------

Secure Gateway Global Settings
------------------------------
  Version = 3.1.0
  Product secured = Citrix XenApp only
  Logging level =  2 (Warning, errors and fatal events)
  Client connection timeout =  100 seconds
  Maximum concurrent connections =  250
  Certificate FQDN = *.myrapadocs.com

Interfaces
----------

  All interfaces (0.0.0.0 : 443)
  ------------------------------
    Protocol = SSL, TLS
    Cipher suites = ALL
    Secured = Yes
    HTTP = No
    ICA = Yes
    SOCKS = Yes
    Gateway Client = No
    LoadBalancerIPs = None defined

Web Interface
-------------
  FQDN = localhost
  Port = 80
  Secured = No
  Protocol = SSL, TLS
  Cipher suites = ALL
  Access mode = Indirect
  Tested OK

Authority Servers
-----------------

  ID = STA362CE7A8D924
  --------------------
    FQDN = WIN08CITRIX
    Port = 8080
    Path = /Scripts/CtxSTA.dll
    Type = STA
    Secured = No
    Protocol = SSL, TLS
    Cipher suites = ALL
    Tested OK

Certificate Check
-----------------
  FQDN = *.myrapadocs.com
  This certificate is currently valid.

EOF
0
 
LKaushalCommented:
Why you have Acces Mode = Indirect under Web Interface
Web Interface
-------------
  Access mode = Indirect
------------------

Can you run the Secure Gateway Configuration wizard again and when it comes to 'Access option' select the 'Direct' instead of 'Indirect'.
By default, 'Indirect' is selected.
Let me know how it goes.
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 
Jaime CamposAuthor Commented:
I changed and tested. I could not access site with either http or https. When I change gateway settings to direct, I'm able to get to app from http only on internal LAN. Any other ideas?
0
 
Jaime CamposAuthor Commented:
I am not utlizing a DMZ just in case you think I am.
0
 
Jaime CamposAuthor Commented:
These are the errors in Event viewer on CSG/WI Server:

Connection was broken by either client or server.
Incoming Citrix Gateway Protocol downstream data could not be processed.

Site path: c:\inetpub\wwwroot\Citrix\XenApp.

All of the configured Secure Ticket Authorities failed to respond to this XML transaction. [Log ID: 78dea556]

Site path: c:\inetpub\wwwroot\Citrix\XenApp.

The Citrix servers sent HTTP headers indicating that an error occurred: 400 Bad request. This message was reported from the XML Service at address http://WIN08CITRIX:8080 [com.citrix.xml.CtxSTAProtocol.RequestTicket]. The specified Secure Ticket Authority could not be contacted and will be temporarily removed from the list of active services. [Log ID: 9dfb9522]

Site path: c:\inetpub\wwwroot\Citrix\XenApp.

A socket has been forcibly destroyed by the transaction layer. [Log ID: ab67cc4]

Thanks,

nimdatx
0
 
LKaushalCommented:
This looks more like a wrong STA URL is mentioned... Could you double check if the FQDN of the STA URL you have configured in WI is correct and similar to secure gateway.
0
 
Jaime CamposAuthor Commented:
I was missing .domain.local on STA name. After changing all worked. I appreciate your help and support.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now