Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3341
  • Last Modified:

User does not have permission to perform this action.

I have SQLExpress 2008 installed on my local machine running XP Pro SP 3.  I am loged in as Administrator. I am able to work with Visual Studio no problem. I am able to connect to the local instance of SQLExpress with SQL Managemant Studio but that is all that I could do. Anything else I try to do I get the error "User does not have permission to perform this action." Could anyone help me out on this

EXEC sp_grantlogin '(local)\[Administrator]'
Msg 15247, Level 16, State 1, Procedure sp_grantlogin, Line 13
User does not have permission to perform this action.

Thanks
0
ruffone
Asked:
ruffone
  • 3
  • 3
2 Solutions
 
bull_riderCommented:
You are connecting with what user credentials to SQL Expres Management Studio? Try connecting to it through windows authentication and then try.
0
 
bull_riderCommented:
Can you try this in osql?

C:\>osql -E
1> use dbname
2> exec sp_grantdbaccess loginname
3> go

This you have to do through the command prompt. And replace loginname with the user name u r logged in and replace dbname with your database name.

Hope it helps.
0
 
ruffoneAuthor Commented:
thanks for your response bull_rider
I am loged in as the local administrator of the maching. This is what have me so puzzled. This is literally what I type in and what I got back. I am loged into the machine "HYMAN" as "Administrator". Administrator is the name of the administrator account. It is the only account on the system. I use it to do everything on the system. I am very pissed that SQLExpress cannot see that.

C:\ >SQLCMD.exe -S HYMAN\SQLExpress -E
1>EXEC sp_grantlogin '[HYMAN]\[Administrator]'
2>GO
Msg 15247, Level 16, State 1, Server HYMAN\SQLEXPRESS, Procedure sp_grantlogin,
Line 13
User does not have permission to perform this action.
 
 
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
ruffoneAuthor Commented:
when I try to type in the command you send I get this
C:\>osql -E
[SQL Server Native Client 10.0]Named Pipes Provider: Could not open a
connection to SQL Server [2].
[SQL Server Native Client 10.0]Login timeout expired
[SQL Server Native Client 10.0]A network-related or instance-specific error
has occurred while establishing a connection to SQL Server. Server is not
found or not accessible. Check if instance name is correct and if SQL Server
is configured to allow remote connections. For more information see SQL Server
Books Online.
0
 
cdaly33Commented:
0
 
bull_riderCommented:
Then you can do one more thing, can you enable the Named Pipes in Sql Server surface area configuration and allow the remote connections as well there?
0
 
ruffoneAuthor Commented:
I do not understand what is going on why I can't login with Management Studio but I found that I could work quite successfully in Visual Studio using the database diagram. All I ever wanted was to be able to do my work. So I am happy. Thank you guys for responding when I was pulling my hair out
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now