Catalyst 2950 Web Interface blank

Posted on 2009-05-17
Medium Priority
Last Modified: 2012-05-07
I got 2 Catalyst 2950 switches from my work so i was planning selling them.  I tried to update them to that latest software from the cisco.com site.  After updating them using the directions on there site they booted just fine.  I try to use the Express Setup by holding down the mode button and that works just fine but when i pull up the website address from the computer connect to vlan1 it just shows a blank page.  I have no idea why the page wont come up but I can telnet just fine.  Any ideas?
Question by:W00dyW00d
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5

Expert Comment

ID: 24408693
did you do a archive to command to xtract all the files to the flash of the switch?

Author Comment

ID: 24408710
Yes, I delete the other html/* files and ran the archive tar /xtract tftp://... line, updated then reloaded

Expert Comment

ID: 24408921
I would make sure that the firmware that you downloaded had the web interface feature part of that firmware, it is available with and without the web interface.

Sorry if that was a dumb statement, I try not to assume anything.

When ransomware hits your clients, what do you do?

MSPs: Endpoint security isn’t enough to prevent ransomware.
As the impact and severity of crypto ransomware attacks has grown, Webroot has fought back, not just by building a next-gen endpoint solution capable of preventing ransomware attacks but also by being a thought leader.


Author Comment

ID: 24408930
Yes, i used:

Release Date: 03/Mar/2009
Size: 5030.00 KB  (5150720 bytes)
Minimum Memory: DRAM:16 MB  Flash:8 MB

Expert Comment

ID: 24408987
did you run the upgrade via the console cable?  Did the upgrade show any errors?

did you run a 'write erase' and delete the vlan.dat file?

after that were you prompted to run the initial setup and follow the prompts?


Expert Comment

ID: 24408989
Also, on a side note.  I would assume (big assumption) that anyone who buys a Cisco switch.  The first thing they would do is put the firmware rev that their environment calls for and config it as they wish.

The only thing they will look for is bad ports or DOA.

Just my additional two cents.

Author Comment

ID: 24413105

Thanks for the heads up on how must people buy cisco switches.  I wont attempt to update the other one.  I upgraded via vlan1 over telnet with tftp.  I did not do "write erase", is that something i should have?  No i didn't see any error messages.

Here is what i followed.  All but the "wr mem" said shut down down ... (I don't remember the rest)

After that I held the mode button to reset then tried to go to express setup.


Expert Comment

ID: 24413175
If you have a Cisco console cable, that is the way I would recommend.  With the console cable you can actually watch the device boot up.  It is more informative that connecting via TCP in my book (though I am no Cisco expert... yet!)

Good luck!

Author Comment

ID: 24414158
Here is from the console when i boot and try to enter express setup.

C2950 Boot Loader (C2950-HBOOT-M) Version 12.1(11r)EA1, RELEASE SOFTWARE (fc1)
Compiled Mon 22-Jul-02 17:18 by antonino
WS-C2950-24 starting...
Base ethernet MAC Address: 00:0f:34:34:84:c0
Xmodem file system is available.
Initializing Flash...
flashfs[0]: 326 files, 5 directories
flashfs[0]: 0 orphaned files, 0 orphaned directories
flashfs[0]: Total bytes: 7741440
flashfs[0]: Bytes used: 5006336
flashfs[0]: Bytes available: 2735104
flashfs[0]: flashfs fsck took 8 seconds.
...done initializing flash.
Boot Sector Filesystem (bs:) installed, fsid: 3
Parameter Block Filesystem (pb:) installed, fsid: 4
Loading "flash:c2950-i6q4l2-mz.121-22.EA13.bin"...##################################################################################

File "flash:c2950-i6q4l2-mz.121-22.EA13.bin" uncompressed and installed, entry point: 0x80010000

              Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

           cisco Systems, Inc.
           170 West Tasman Drive
           San Jose, California 95134-1706

Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA13, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by cisco Systems, Inc.
Compiled Fri 27-Feb-09 22:20 by amvarma
Image text-base: 0x80010000, data-base: 0x80570000

Initializing flashfs...
flashfs[1]: 326 files, 5 directories
flashfs[1]: 0 orphaned files, 0 orphaned directories
flashfs[1]: Total bytes: 7741440
flashfs[1]: Bytes used: 5006336
flashfs[1]: Bytes available: 2735104
flashfs[1]: flashfs fsck took 8 seconds.
flashfs[1]: Initialization complete.
Done initializing flashfs.
POST: System Board Test : Passed
POST: Ethernet Controller Test : Passed
ASIC Initialization Passed

POST: FRONT-END LOOPBACK TEST : Passedcisco WS-C2950-24 (RC32300) processor (revision M0) with 20957K bytes of memory.
Processor board ID FOC0808T080
Last reset from system-reset
Running Standard Image
24 FastEthernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:0F:34:34:84:C0
Motherboard assembly number: 73-5781-12
Power supply part number: 34-0965-01
Motherboard serial number: FOC08080VK5
Power supply serial number: DAB08062J3A
Model revision number: M0
Motherboard revision number: B0
Model number: WS-C2950-24
System serial number: FOC0808T080

         --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]:
00:00:15: %SPANTREE-5-EXTENDED_SYSID: Extended SysId enabled for type vlan
00:00:18: %SYS-5-RESTART: System restarted --
Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA13, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by cisco Systems, Inc.
Compiled Fri 27-Feb-09 22:20 by amvarma
00:00:18: %SNMP-5-COLDSTART: SNMP agent on host Switch is undergoing a cold start

Press RETURN to get started!

00:00:48: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
00:00:50: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
00:00:50: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up

Accepted Solution

KevinCovert earned 2000 total points
ID: 24414455
At that point press enter, it will then ask "Would you like to enter the initial configuration dialog? [yes/no]: type y or yes

and follow the prompts.

You will give it a name and an IP address, then you can attempt to connect to the http interface

I would run

write erase
delete flash:vlan.dat
and then reload without saving or running a write memory.

Then run the initial configuration setup.

Thats what works for me.


Author Comment

ID: 24414611
Perfect that worked.  After setting up the ip address it loaded.  Any idea why it wont load into the Express Setup without setting up the ip address like before i updated it worked that way.

Expert Comment

ID: 24414900
I don't know, as I don't do it that way.  I would think because it doesn't have an IP but I'm not certain without hands on lab to test. Sorry.

Glad you got it worked out.


Featured Post

Get real performance insights from real users

Key features:
- Total Pages Views and Load times
- Top Pages Viewed and Load Times
- Real Time Site Page Build Performance
- Users’ Browser and Platform Performance
- Geographic User Breakdown
- And more

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

As companies replace their old PBX phone systems with Unified IP Communications, many are finding out that legacy applications such as fax do not work well with VoIP. Fortunately, Cloud Faxing provides a cost-effective alternative that works over an…
WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…
Suggested Courses

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question