Solved

Scanner software crashes program but WIA drivers don't crach it.

Posted on 2009-05-17
5
741 Views
Last Modified: 2013-12-27
I have a client that has a Samsung SCX-4824 series MFP.  They use clinical software for patient management and scan documents straight into the software.  There is 2 ways of scanning into the software direct.  Going into a patients record and scanning or doing a bulk scan through a separate application that is part of the clinical program called bulk import.  If you try and scan into the patient record, as soon as you click scan it shuts down the clinical program, if you scan into the the bulk import application you can select the source as WIA scanner in the scanner window and scan without problems.  As soon as you select the Samsung driver as the source it shuts down the Bulk Import program.

The clinical software seems to be picking up the Samsung driver and not the WIA driver but there isn't anywhere to change the default scanner.  The bulk import seems to be picking up the WIA driver when you start the application and the Clinical software is picking up the Samsung driver (I assume it is anyway) as it crashes as soon as scan is clicked.  So in the clinical software I can't even bring up the scan window to select the source it just crashes instantly, no messages no errors.

I have searched through the registry but can't find anthing to do with DefaultScanner or the like.

Anyone got any leads on this.  I am about to perform a restore I think.

The system is XP Pro SP2, running Elusiva Terminal services, Elusiva Universal print driver, AVAST Pro, SuperAntiSpyware, Hamachi VPN software, Best Practice Clinical Software using MSDE SQL and various other applications.
Regards
Steve
0
Comment
Question by:HITSMAN
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 49

Assisted Solution

by:dbrunton
dbrunton earned 125 total points
ID: 24409579
Try doing the scan in Administrator mode.  I suspect it may work OK then.

I've had this problem before with an HP where if you used the HP driver it would lock up but no problems with the WIA.  And if I remember rightly it worked OK in administrator mode with the HP driver.
0
 

Author Comment

by:HITSMAN
ID: 24411054
Thanks for the reply. My client logs on as admin mostly and I had checked that already.  To make it even more interesting I was talking to them this afternoon and she said what did I do as it's working now???  All I had done was put some space between me and the problem so I could get some other things done and it has somehow corrected itself.  I hate that as it  now looks like its either intermittent or fixed.  I would rather find the solution and fix it but I am glad it's working.

Well just remoted into the the PC and find it's NOT WORKING again.  What the??

I installed Infranview to see what it does with the scanner and it also closes if I try and use the Samsung driver.  WIA works fine.  Obviously the Samsung drivers are the issue but I have already removed installed, downloaded updated drivers, installed and tested.  Any ideas?
Regards  Steve
0
 

Accepted Solution

by:
HITSMAN earned 0 total points
ID: 24411306
Looks like I have found the problem.  There was a HP Photosmart and Office Jet 7.0.A Corporate edition installed.  Not sure how it got there but when I removed it and rebooted the scanner and clinical software started working correctly with the Samsung driver.  Unless this is just to trick me into thinking its fixed.  WIll see in a couple of days of reliable operation.  Thanks for your time dbrunton.
0
 
LVL 49

Expert Comment

by:dbrunton
ID: 24413347
You may have just answered a question I had.  Why was I experiencing the problem I had.  HP software conflicting with the WIA drivers.

Give it a couple of days and then award the points to yourself as you solved the problem yourself.
0
 

Author Comment

by:HITSMAN
ID: 24439524
All seems ok.  So if you can't scan check to se if you have any other scanner or multifuction software/drivers installed and remove them.  Then re-install the drivers you want to work, re-boot and try again.
0

Featured Post

Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It is only natural that we all want our PCs to be in good working order, improved system performance, so that is exactly how programs are advertised to entice. They say things like:            •      PC crashes? Get registry cleaner to repair it!    …
When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup" or a blinking cursor with black screen. A loop for Auto repair will start but fix nothing.  You will be panic as there are no back…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question