?
Solved

Joomla Menus in Menu Manager Disappeared

Posted on 2009-05-17
6
Medium Priority
?
773 Views
Last Modified: 2012-05-07
I have been setting up a portal website using Joomla, and everything was going great.  I had a Main Menu and a Top Menu that were working exactly right, some items vieable to public, and some to registered users only.
When I login to the admin site now, ALL menus are GONE!  Under "Menus" at the top, I have the Menu Manager and the Menu Trash.  The Menu Trash still shows old menu items I had deleted, but Menu Manager shows NO menus.... ?!  What could have happened, and how can I get them back?
I was going to demo the site to my clients tomorrow, and now this!  Please help.

Rob
0
Comment
Question by:Rob Grinage
  • 3
  • 2
6 Comments
 
LVL 11

Expert Comment

by:j-b-t
ID: 24409140
Can you not go to trash and reinstate menus?
0
 
LVL 1

Author Comment

by:Rob Grinage
ID: 24409175
No... when I try to restore an old menu item to the Top Menu, it disappeared from the Trash area, but does not appear on the Top Menu.  Likewise, I tried to restore an old menu item to the User Menu, and it is now gone from the Trash area, but not on User Menu.
0
 
LVL 11

Expert Comment

by:j-b-t
ID: 24409870
Wow - really weird. OK what's changed since eth menus were working -
 - have you been hacked?
 - have you added a thrid party component thatt many be affecting things
 - does someone else have access to your site who may have done something?
 - have you noticed anything else?
 - go a url I can look at?
I assume the menu is absent on the website.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 1

Author Comment

by:Rob Grinage
ID: 24412439
Well, it's really weird now because I came in to work today and logged into the Admin area on my work computer and all of the Menus are now showing in the Menu Manager!?  I will continue to monitor the status of the Menus and post a new question if it comes up again.  If you know of a reason why they would not show up on one computer (home) and then they show up at work, let me know.

Thanks,
Rob
0
 
LVL 11

Accepted Solution

by:
j-b-t earned 1500 total points
ID: 24416676
cache perhaps
0
 

Expert Comment

by:justinjdean
ID: 25123797
Not much of a solution - it suddenly just re-appeared?  This has happened to me as well, except my menu hasn't suddenly re-appeared yet.  If its cache issues, how do I troubleshoot this?  I've cleared my cache on my local machine, tried different browsers, etc. - but the menu is still missing.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

CTAs encourage people to do something specific to show interest in your company, product or service. Keep reading to learn why CTAs should always be thought of as extremely important, albeit small, sections of websites.
Without even knowing it, most of us are using web applications on a daily basis.  In fact, Gmail and Yahoo email, Twitter, Facebook, and eBay are used by most of us daily—and they are web applications. We generally confuse these web applications to…
This video teaches users how to migrate an existing Wordpress website to a new domain.
The viewer will learn how to create and use a small PHP class to apply a watermark to an image. This video shows the viewer the setup for the PHP watermark as well as important coding language. Continue to Part 2 to learn the core code used in creat…
Suggested Courses
Course of the Month13 days, 8 hours left to enroll

750 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question