Joomla Menus in Menu Manager Disappeared

I have been setting up a portal website using Joomla, and everything was going great.  I had a Main Menu and a Top Menu that were working exactly right, some items vieable to public, and some to registered users only.
When I login to the admin site now, ALL menus are GONE!  Under "Menus" at the top, I have the Menu Manager and the Menu Trash.  The Menu Trash still shows old menu items I had deleted, but Menu Manager shows NO menus.... ?!  What could have happened, and how can I get them back?
I was going to demo the site to my clients tomorrow, and now this!  Please help.

Rob
LVL 1
Rob GrinageManagerAsked:
Who is Participating?
 
j-b-tConnect With a Mentor Commented:
cache perhaps
0
 
j-b-tCommented:
Can you not go to trash and reinstate menus?
0
 
Rob GrinageManagerAuthor Commented:
No... when I try to restore an old menu item to the Top Menu, it disappeared from the Trash area, but does not appear on the Top Menu.  Likewise, I tried to restore an old menu item to the User Menu, and it is now gone from the Trash area, but not on User Menu.
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

 
j-b-tCommented:
Wow - really weird. OK what's changed since eth menus were working -
 - have you been hacked?
 - have you added a thrid party component thatt many be affecting things
 - does someone else have access to your site who may have done something?
 - have you noticed anything else?
 - go a url I can look at?
I assume the menu is absent on the website.
0
 
Rob GrinageManagerAuthor Commented:
Well, it's really weird now because I came in to work today and logged into the Admin area on my work computer and all of the Menus are now showing in the Menu Manager!?  I will continue to monitor the status of the Menus and post a new question if it comes up again.  If you know of a reason why they would not show up on one computer (home) and then they show up at work, let me know.

Thanks,
Rob
0
 
justinjdeanCommented:
Not much of a solution - it suddenly just re-appeared?  This has happened to me as well, except my menu hasn't suddenly re-appeared yet.  If its cache issues, how do I troubleshoot this?  I've cleared my cache on my local machine, tried different browsers, etc. - but the menu is still missing.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.